Bug 228946 - I2o driver (Adaptec 2400 et al) not loaded properly
I2o driver (Adaptec 2400 et al) not loaded properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 228973 229614 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-15 20:54 EST by Kenneth Lam
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.6.20-1.2944.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 10:37:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel dmesg output from 2.6.19-1.2911.fc6.x86_64 (23.48 KB, text/plain)
2007-02-18 05:59 EST, Terry Froy
no flags Details
Kernel syslog output from 2.6.19-1.2911.fc6.x86_64 (35.40 KB, text/plain)
2007-02-18 06:00 EST, Terry Froy
no flags Details
Kernel dmesg output from 2.6.18-1.2869.fc6.x86_64 (22.14 KB, text/plain)
2007-02-18 06:40 EST, Terry Froy
no flags Details
Kernel syslog output from 2.6.18-1.2869.fc6.x86_64 (33.80 KB, text/plain)
2007-02-18 06:43 EST, Terry Froy
no flags Details

  None (edit)
Description Kenneth Lam 2007-02-15 20:54:22 EST
Description of problem:
I'm using Adaptec 2400A raid card with raid-5 configured. The I2o driver not
work properly in new kernel but worked in 2.6.18-1.2798.fc6.


Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2911.fc6

How reproducible:
When everytime boot in new kernel, the error messages shown
Buffer I/O error on device i2o/hda, logical block 183148784
Buffer I/O error on device i2o/hda, logical block 183148784
Buffer I/O error on device i2o/hda, logical block 0
Buffer I/O error on device i2o/hda, logical block 1
Buffer I/O error on device i2o/hda, logical block 2
Buffer I/O error on device i2o/hda, logical block 3
Buffer I/O error on device i2o/hda, logical block 4

and can't fdisk or mount the partition

Steps to Reproduce:
1.
2.
3.
  
Actual results: checked with the modules i2o_block not used with lsmod
Module                  Size  Used by
i2o_block              17613  0
i2o_core               45029  1 i2o_block

Expected results: i2o_block module locked and not be removed using rmmod.


Additional info:
Comment 1 Danny Yee 2007-02-16 03:02:00 EST
I just tried to update an i2o-based machine from FC5 to FC6 (using yum).  The
new system, with kernel 2.6.19-1.2911.fc6, doesn't seem to cope with having its
root filesystem on an i2o device.  (I have it temporarily working with the old
FC5 kernel.)

I have another system with the same hardware running 2.6.18-1.2869.fc6 fine, so
I'm wondering if there's a problem with i2o on 2.6.19-1.2911.fc6.
Comment 2 Joni Bäcklund 2007-02-16 05:29:21 EST
*** Bug 228973 has been marked as a duplicate of this bug. ***
Comment 3 Chuck Ebbert 2007-02-16 15:17:36 EST
Can you find the messages in your syslog from when the driver loads?
Does it throw any error messages?

And please post the corresponding log from a working kernel.
Comment 4 Terry Froy 2007-02-18 05:59:13 EST
Created attachment 148282 [details]
Kernel dmesg output from 2.6.19-1.2911.fc6.x86_64

I have just been bitten by this bug.

I'm running FC6 (x86_64) with my root filesystem connected to the onboard IDE
controller on my mainboard with a separate RAID-5 array on the Adaptec 2400A
card (uses the i2o driver).

While I can see the device node for the single array configured on the card
(/dev/i2o/hda), I cannot read its' partition table via fdisk nor mount any
filesystems on it.

Please find attached the kernel dmesg output from the most recent FC6 kernel
update that appears to cause the behaviour already described in this bug.

(I'll be attaching the syslog messages generated by this kernel in a few
seconds)
Comment 5 Terry Froy 2007-02-18 06:00:51 EST
Created attachment 148283 [details]
Kernel syslog output from 2.6.19-1.2911.fc6.x86_64

I have attached the syslog entries generated by 2.6.19-1.2911.fc6.x86_64.
Comment 6 Terry Froy 2007-02-18 06:40:57 EST
Created attachment 148284 [details]
Kernel dmesg output from 2.6.18-1.2869.fc6.x86_64

I am attaching the dmesg output from 2.6.18-1.2869.fc6.x86_64 as this is the
last known kernel which works correctly with my Adaptec 2400A card.

Expect the matching syslog within the next few seconds...
Comment 7 Terry Froy 2007-02-18 06:43:43 EST
Created attachment 148285 [details]
Kernel syslog output from 2.6.18-1.2869.fc6.x86_64

... and the syslog as promised!

I am happy to test any patches submitted to this bug as this box isn't a
production system that needs to stay up 24/7.
Comment 8 Danny Yee 2007-02-22 01:45:13 EST
I've just switched my system from 2.6.18-1.2257.fc5smp to 2.6.18-1.2869.fc6 with
no problems, so it definitely looks like a 2.6.19 problem.  (If I get a test
machine put together I'll try 2.6.19-1.2288.fc5smp - I expect that to fail.)
Comment 9 Chuck Ebbert 2007-02-22 09:26:46 EST
*** Bug 229614 has been marked as a duplicate of this bug. ***
Comment 10 Chuck Ebbert 2007-02-22 09:29:12 EST
Problem has been reported to linux-kernel mailing list -- no response.
Comment 11 Chris Jaeger 2007-03-18 00:45:10 EDT
The bug continues to persist in the 2.6.20 kernel. I've been relying on the
2.6.18 kernel for quite a while now in order to get my system to boot.
Comment 12 Terry Froy 2007-03-27 15:24:05 EDT
Someone has posted a patch which apparently fixes this bug to the linux-kernel
mailing list.

Details here: http://marc.info/?l=linux-kernel&m=117489656029021&w=2

While I am still happy to test a kernel from Red Hat, I will likely spin my own
binary RPM of the most recent FC6 kernel SRPM with this patch applied to it.

I will post an update to this bug if the above patch does indeed work.
Comment 13 Chuck Ebbert 2007-03-27 15:34:26 EDT
Go ahead and test. The patch will be in the next Fedora test kernel as well.
Comment 14 Terry Froy 2007-03-28 08:19:28 EDT
The aforementioned patch works for me (x86_64) against 2.6.20-1.2933.

If you wish for me to test an official Fedora test kernel, please let me know.
Comment 15 Danny Yee 2007-04-17 02:25:39 EDT
Is this fixed in 2.6.20-1.2944?

Note You need to log in before you can comment on or make changes to this bug.