Bug 22927 - punp sends wrong hostname on lease renewal
Summary: punp sends wrong hostname on lease renewal
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 31845 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-28 05:09 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 12:59:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-28 05:09:48 UTC
In the initial DHCP DISCOVER and REQUEST messages, pump sends the
name passed to it on the command line as the hostname (option 12).
I use the unqualified host name.
When the lease is renewed, pump sends (in my case) the fully qualified
host name (possibly from gethostname()) in the hostname option.

In the latest ISC dhcpd 3.0 betas, using dynamic dns,
the server changes the dns entry for the host on renewal from host.domain
to the bogus entry host.domain.domain.
I can also imagine this causing problems with cable modem users.

This is with pump-0.8.3-2

Comment 1 Tomasz Kepczynski 2001-03-14 12:59:43 UTC
This is the same problem as in 11933 which contains request to reopen the bug.
There is also small patch there which used to work for me.

Tomek

Comment 2 Erik Troan 2001-03-14 14:34:00 UTC
This should be fixed in the latest pump (0.8.8)

Comment 3 Elliot Lee 2001-08-26 21:53:30 UTC
*** Bug 31845 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.