Bug 229442 - festival package could be significantly reduced in size
festival package could be significantly reduced in size
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: festival (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Miller
:
Depends On: festival1.96
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-02-20 23:03 EST by Matthew Miller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.96-0.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 15:01:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2007-02-20 23:03:10 EST
Description of problem:

  Festival package is very large.

Version-Release number of selected component (if applicable):

  1.95-6

Additional info:

In short: the festival package installs some 50MB of stuff. It would be useful
to have the base install smaller, through a combination of creating subpackages
and of not packaging some cruft that's getting included now.

The following is a repost of something I just sent to fedora-desktop list:

On Tue, Feb 20, 2007 at 06:16:35PM -0500, Jeremy Katz wrote:
> > orca too, probably even more important (not sure whether it was removed
> > for FC7t1 cuz it drags in festival which is huge).
> Yeah, the space requirement of festival makes it (and the things which
> depend on it, including gok) a lot less attractive.  :-/   Not sure what
> to do on that front

Festival could by split up so some or all of the voices are in a subpackage.

I'm not hugely versed in the technical details, but the CMU ARCTIC HTS
voices sound great to me (better than the only free alternatives, the older
and much larger kal_diphone and ked_diphone ones). We could probably get
away with just including the CMU ARCTIC SLT voice (female US English
speaker), which is the smallest at 1756k. That alone would save us half the
size of the package.

Plus, the speech-tools binaries (in libexec) probably aren't needed by
almost everyone. And that's pretty significant.

*And*, there's some stuff packaged up under /usr/share/festival/dicts that I
think maybe doesn't need to be. For example, there's a 118K *patch* in
there, plus the 3.6M file that's getting patched. (cmudict-0.4.diff and
cmudict-0.4.scm). I assume that's done to fulfill the "Any modifications
must be clearly marked as such" clause in the license for the data files in
that directory -- probably that could be done in a somewhat smaller way.

Oh, and some stuff in /usr/share/festival/etc which is "etc" in the "misc
et cetera crap" sense, not the "config files" sense.

So, doing all of that would bring the package down to 16M from 54M (on
x86_64).

Someone who knew the package better and/or had more than a minimal working
knowledge of Lisp could probably pare down and/or subpackage non-core
functionality even further -- I bet the minimal-but-useful set is under 10M.
Comment 1 Matthias Clasen 2007-02-22 23:20:32 EST
David, I guess we should do some of this for FC7 to help shrink the live cd size
Comment 2 Matthew Miller 2007-03-12 14:06:56 EDT
I'm working on making an updated spec file that includes these suggestions.
Should have one RSN.
Comment 3 Matthew Miller 2007-03-13 17:09:02 EDT
Preview of work-in progress:


24M     festival-1.95-6.fc7.x86_64.rpm

vs.

1.8M    festival-1.96-0.5.fc7.mattdm.x86_64.rpm
1.1M    festival-speechtools-libs-1.2.96-0.5.fc7.mattdm.x86_64.rpm
1.7M    festvox-nitech-us-slt-arctic-hts-0.20061229-0.5.fc7.mattdm.x86_64.rpm
4.5M    total
Comment 4 Matthew Miller 2007-03-13 17:20:44 EDT
See bug #232105 for in-progress updated packages which address this issue.
Comment 5 Matthew Miller 2007-03-15 15:51:27 EDT
So, hmmm, with the new nitech versions of the voices, slt-arctic is no longer
the smallest. In fact, we've got:

1348    festvox-awb-arctic-hts-0.20061229-0.7.fc7.mattdm.x86_64.rpm
1384    festvox-jmk-arctic-hts-0.20061229-0.7.fc7.mattdm.x86_64.rpm
1528    festvox-rms-arctic-hts-0.20061229-0.7.fc7.mattdm.x86_64.rpm
1672    festvox-bdl-arctic-hts-0.20061229-0.7.fc7.mattdm.x86_64.rpm
1684    festvox-slt-arctic-hts-0.20061229-0.7.fc7.mattdm.x86_64.rpm
1868    festvox-clb-arctic-hts-0.20061229-0.7.fc7.mattdm.x86_64.rpm
6392    festvox-kal-diphone-0.19990610-0.7.fc7.mattdm.x86_64.rpm
6476    festvox-ked-diphone-0.19990610-0.7.fc7.mattdm.x86_64.rpm

But... AWB has a strong scottish accent, and JMK a kind of odd canadian one, so
they're not great candidates for inclusion. And I find RMS a bit hard to
understand. BDL isn't much smaller than SLT, and since I like it better, I think
I'm going to keep it as the default for a price 12k.

So, in case anyone later questions why this is the default, there's the answer. :)
Comment 6 Matthew Miller 2007-03-16 16:07:53 EDT
Oh, also:

Currently, festival is an optional package in "System Tools", and pulled in as
default in "Gnome Desktop Environment" by orca.

Really, we should default to also installing at least the non-accented HTS
voices (giving two male and two female choices by default):

  festvox-bdl-arctic-hts 
  festvox-clb-arctic-hts
  festvox-rms-arctic-hts 

plus I'd suggest making the other voices visible somewhere in comps as optional.
Probably somewhere better than "System Tools" -- "Sound and Video", maybe?
Comment 7 Matthew Miller 2007-03-20 15:01:37 EDT
This issue should be resolved by the release of festival-1.96-0.11, now in the
development tree. (See bug #232105 for details.)

Please reopen if there's still a problem. Thanks.

Note You need to log in before you can comment on or make changes to this bug.