Bug 232105 - (festival1.96) improved festival package cures all ills.
improved festival package cures all ills.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: festival (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
http://mattdm.org/misc/festival/
:
Depends On:
Blocks: 162137 198190 198908 220989 228315 229442 232226 233200
  Show dependency treegraph
 
Reported: 2007-03-13 17:18 EDT by Matthew Miller
Modified: 2013-03-05 22:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.96-0.11.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 17:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2007-03-13 17:18:56 EDT
I have updated Festival packages available at http://mattdm.org/misc/festival/
(new spec file at http://mattdm.org/misc/festival/festival.spec ).

This turned out to be a fairly big overhaul, and it's almost more changed than
the same.

Fixes:

  bug #162137   operation on 'outidx' is undefined
  bug #198190   ldd -r reports undefined symbols
  bug #198908   festival should be built with ESD support.
  bug #228315   multi-lib conflicts

and last but not least

  bug #229442   festival package could be significantly reduced in size

Plus, it's updated to the latest version, and there's a laundry list of other
improvements. (See the changelog for the gory details.)

It still needs a bit more work and cleanup before I'm done, but I figured it'd
be good to get some other eyes involved at this point.
Comment 1 David Zeuthen 2007-03-13 20:52:14 EDT
Hi, so I tried these and it's looking good; thanks a bunch for looking into this!

It appears, though, that orca won't run without having either Kevin
(festvox-kal-diphone) or Kurt (festvox-ked-diphone). In fact, no of the other
voices show up. Perhaps this is just a gnome-speech issue and gnome-speech
should Require one of them? (in the same breath, the same voice should be the
"default" one pulled in by the main festival package)

Thoughts?
Comment 2 Matthew Miller 2007-03-13 21:57:23 EDT
Looks like those are hard-coded into drivers/festival/festivalspeaker.c -- not
terribly elegant. 

Also, they call voice_ked_diphone "Kevin" although it's identified in the voice
scm file itself as "Kurt", and voice_kal_diphone  they call "Kal", although *it*
identifies itself as Kevin. (And one of the authors is Kevin A. Lenzo (K.A.L.)
--- hmmm). Clearly not a big deal, but potentially confusing.

Oh, wait! I'm looking at an old version. The 0.4.10 version in rawhide does
something more complicated.... okay, wow, thiat code needs some comments. It's
actually asking Festival for its list of voices. And I don't think it assigns
arbitrary names -- I'll have to look at the orca UI tomorrow. (I admit I haven't
-- does it still provide the "Kevin" and "Kal" names mentioned above?) Which
version are you using?

Anyway, looks like the nitech HTS voices aren't properly providing the metadata
with "proclaim_voice". I'd like to use one of the HTS voices (more recent
technology -- sounds more natural, smaller), so tomorrow I'll experiment with
patching that in, and I'll take it up with upstream as well.
Comment 3 Matthew Miller 2007-03-13 22:10:27 EDT
(uh, I'm talking about the gnome-speech package, which I think is what orca is
using)
Comment 4 Matthew Miller 2007-03-14 14:27:07 EDT
Okay, so I had a look. Current version just lists the voice name with no
description, so that's not an issue. Nice how it totally crashes if no voices
are found, eh?

Anyway, I'll work on making the other voices work.
Comment 5 Matthew Miller 2007-03-14 16:48:55 EDT
Confirming that the lack of proclaim_voice is the issue. I'm going to patch that
into the voices and ask about it upstream.
Comment 6 Matthew Miller 2007-03-15 00:23:55 EDT
New version (release 0.6) fixes the above issue and more:

http://mattdm.org/misc/festival/
http://mattdm.org/misc/festival/festival.spec 
Comment 7 Matthew Miller 2007-03-15 00:24:35 EDT
Note that I've changed the name of the voice subpackages again. And since this
is all intermediate, I didn't add an Obsoletes for my previous names -- make
sure to remove any old voices before installing this.
Comment 8 Ray Strode [halfline] 2007-03-15 10:33:09 EDT
*** Bug 232226 has been marked as a duplicate of this bug. ***
Comment 9 Matthew Miller 2007-03-15 16:00:13 EDT
Found some problems with the voices. Corrected in 1.96-0.7 packaages, coming soon.
Comment 10 Matthew Miller 2007-03-15 17:09:09 EDT
Okay. New package release 1.96-0.7:

http://mattdm.org/misc/festival/
http://mattdm.org/misc/festival/festival.spec 

I think I'm getting pretty close to the point where this is ready to go into
Rawhide to get some more testers....
Comment 11 Matthew Miller 2007-03-15 17:23:54 EDT
Actually, one thing I want to do first is examine the -doc and -devel
subpackages for bloat.
Comment 12 Matthew Miller 2007-03-15 22:17:56 EDT
So, I'm considering not packaging the contents of -devel at all. Rationale:
nothing uses it -- gnome-speechuses the socket interface instead. Futher, it's
never been properly complete -- there's a key "libFestival.a" that's only built
as a static library which got dropped in the update to 1.95, so practically
speaking we've been without a working devel package since that point and no one
seems to have noticed.

The other options are:

b) repackage libFestival.a as festival-lib-static

c) figure out what it'd take to get the somewhat byzantine build system to
   make a dynamic libFestival.so instead

or 

d) wait to see if upstream is interested in doing c).

I'm not terribly keen on "b", "c" might be a lot of work, and "d" I don't know
about but I wouldn't expect to happen quickly. Hence, leaning towards the "a"
option of dropping it. Any thoughts?

I guess there's always "e" -- punt and don't worry about it just yet and hope
"d" comes along eventually. :)
Comment 13 Francois Aucamp 2007-03-16 08:59:32 EDT
Just as a minor note, imo it is unlikely that (d) would happen - I had the same
issue with flite-devel...
Comment 14 Matthew Miller 2007-03-16 09:39:06 EDT
Yeah, I'm not holding my breath. :)


Hmm, on another note, is there anything we can share between these packages to
reduce overall size? I notice that ironically the minimal required festival
packages are now smaller than the flite binary rpm. 
Comment 15 Matthew Miller 2007-03-16 15:56:12 EDT
Okay, so I bit the bullet and made it build the proper shared lib, and included
that. So, we've now got release 1.96-0.8:

http://mattdm.org/misc/festival/
http://mattdm.org/misc/festival/festival.spec 

I think this version is pretty polished, barring any regressions I've
accidentally made.

David -- I'd like to see this go in before the Test 3 freeze, which Jesse just
mentioned on the devel list is Monday.

Comment 16 Matthew Miller 2007-03-18 13:42:48 EDT
1.96-0.9 cures a minor problem which should make this build on older Fedora Core
and RHEL:

http://mattdm.org/misc/festival/
http://mattdm.org/misc/festival/festival.spec 

and I *think* that's the last change for now. :)
Comment 17 Matthew Miller 2007-03-19 14:49:01 EDT
Test 3 freeze is now tomorrow. I'd *really* like to see this make that cutoff.
Comment 18 David Zeuthen 2007-03-19 15:57:55 EDT
I'll put in in right now. Hold on.
Comment 19 David Zeuthen 2007-03-19 17:43:40 EDT
Should be fixed in 1.96-0.11.fc7. Thanks. Do we need any gnome-speech changes
and is the upgrade path working?
Comment 20 Matthew Miller 2007-03-19 21:15:46 EDT
gnome-speech should just work as it is, but better than before. Only thing I'm
not sure about is what happens if you had your prefs set to a voice which isn't
installed on an upgraded system -- it might not handle that cleanly.

Comment 21 Matthew Miller 2007-03-19 21:28:07 EDT
Upgrade path for festival itself should be clean, except that on x86_64 packages
with both x86_64 and i386 previously installed, only the x86_64 portion will be
upgraded. The new packages don't conflict in that situation, so the only
downside is cruft -- everything will work fine. And of course that won't happen
on new installs.

Also, my intention was for the official package to be "1.96-1", not 0.x, but I
guess I should have said that. :)
Comment 22 Francois Aucamp 2007-03-20 06:03:15 EDT
(In reply to comment #14)
> Hmm, on another note, is there anything we can share between these packages to
> reduce overall size? I notice that ironically the minimal required festival
> packages are now smaller than the flite binary rpm. 

Quite ironic, I must say (and excellent work so far, by the way) :-). Sadly,
flite is a complete rewrite of festival, and even the voices aren't compatible
between the two engines. One of the departments in our company is working on
solving this issue, so maybe in the future... Anyway, thanks again for the great
work on festival.
Comment 23 Matthew Miller 2007-03-20 16:26:22 EDT
Oh, there is one gnome-speech thing! I filed it in a separate bug and forgot
about it. It's really trivial, though, and was also a bug with the old package
-- the dep on festival needs to be on all archs. See bug #232517.

Note You need to log in before you can comment on or make changes to this bug.