Bug 229792 - list tags are outputting invalid html
list tags are outputting invalid html
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Grant Gainey
Beth Nackashi
:
Depends On:
Blocks: 166615
  Show dependency treegraph
 
Reported: 2007-02-23 10:21 EST by Máirín Duffy
Modified: 2007-04-18 14:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 13:29:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
wiki page outlining details of issue (24.93 KB, text/html)
2007-02-23 10:22 EST, Máirín Duffy
no flags Details
screenshot of some symptoms from this issue (33.93 KB, image/png)
2007-02-23 10:23 EST, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2007-02-23 10:21:44 EST
Description of problem:
There seems to be some rendering issues with the list tag that's making it
create invalid html in a number of places, and it's starting to affect some of
the CSS's ability to be able to apply to particular tables.

I'm attaching the html and screenshot from an rhn wiki page describing the
broken html and how the html should look.

This is also related somewhat to bug 229659 ; the html doesn't have colspan tags
where it should, however the fix for that is more involved so it's being tracked
in a separate bug for a later release.
Comment 1 Máirín Duffy 2007-02-23 10:22:43 EST
Created attachment 148669 [details]
wiki page outlining details of issue
Comment 2 Máirín Duffy 2007-02-23 10:23:28 EST
Created attachment 148670 [details]
screenshot of some symptoms from this issue
Comment 3 Grant Gainey 2007-02-23 10:37:24 EST
ColumnTag emitting bad <thead> - fixed
Comment 4 Fanny Augustin 2007-02-23 11:22:25 EST
This bug is already fixed, so moving to the -must so it can receive QA testing. 
Comment 5 Grant Gainey 2007-02-23 17:09:43 EST
Pushed as part of 9.2
Comment 6 Beth Nackashi 2007-02-25 16:35:24 EST
The tables on webqa now look very multi-earthen.  But better than the attached
images.
Comment 7 Brandon Perkins 2007-03-13 10:07:09 EDT
Closed in rhn500h Release.
Comment 8 Brandon Perkins 2007-03-13 13:29:06 EDT
Closed in rhn500h release.

Note You need to log in before you can comment on or make changes to this bug.