Bug 23028 - Anaconda - Error mounting hda6:invalid argument
Anaconda - Error mounting hda6:invalid argument
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-30 12:31 EST by Bruce Bailey
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 18:25:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruce Bailey 2000-12-30 12:31:14 EST
This was second install attempt. 1st had gone into neverland. Disk Druid had done the partitions1st time around, but the mount points were 
blank. On this attempt I elected not to install LILO due to EZ-BIOS (I have a 46G Maxtor w/cylinder limit jumper, GRRR!).
I edited the mount points  in as:

	hda1	21461	21461	WIN95FAT32
/boot	hda2	16	23	Linux native
<swap>	hda5	125	125	Linux native
/	hda6	1	21320	Linux native
	hdc1	6149	6149	WIN95FAT32

here is the exception trace:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 21832303
fsystem: ext2
self: <fstab.GuiFstab instance at 84b9248>
msg: Invalid argument
doFormat: 0
errno: 22
device: hda6
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Bruce Bailey 2001-01-01 11:42:34 EST
The exception cited above may have been fixed by using the fix to anaconda cited in 
advisory  RHBA-2000:084-04. I ran the install again, supplying the anaconda update at the boot prompt and did not get the exception. Again I was not 
installing LILO. 
This time I edited the mount points  differently, adding mount points for the FAT32 portions:

/dos_c	hda1	21461	21461	WIN95FAT32
/boot	hda2	16	23	Linux native
<swap>	hda5	125	125	Linux native
/	hda6	1	21320	Linux native
/dos_d	hdc1	6149	6149	WIN95FAT32

The install still did not work but that is another problem.
Comment 2 Michael Fulbright 2001-01-03 18:25:30 EST
Thank you for the bug report. We are trying to reproduce this problem and find a
fix.

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.