Bug 23035 - Cannot install RH 7.0. System hangs or reboots.
Cannot install RH 7.0. System hangs or reboots.
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-30 14:51 EST by Charles Ruthford
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 18:24:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Ruthford 2000-12-30 14:51:39 EST
After a dozen tries I have not successfully completed the intallation 
process.  I have a Pentium 233 MMX with 60 MB of RAM and a 4.3 GB HDD.  I 
have tried the install without (3 times) and with (9 times )  a DOS 
partition on the system. I have tried installing the Workstation, Server, 
and Custom versions. 

The install process collects all the necessary information and goes 
through the Disk Druid process.  I have had the system either hang or 
reboot during the partition format process or when it was copying 
packages.  It hasn't stopped in the same place twice.  On one attempt I 
did receive the following message:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in 
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 514048
fsystem: ext2
Comment 1 Charles Ruthford 2000-12-30 15:11:59 EST
When I came back and checked the bug report I did not see the second half of my 
report.  I did query bugzilla and found bug number 18549 with an almost 
identical message.  It said that swap space wasn't large enough.  I increased 
my swap space to 700 MB and tried again.  The system rebooted itself while 
copying the 4th package.
Comment 2 Charles Ruthford 2000-12-31 17:34:07 EST
It is a day later and I continued to experiment.  I removed the DOS FAT32 
partition and replaced it with a FAT16 partition.  No improvement.  The install 
hung during the format of the /var partition.  

BTW, I am using the CDs that came with the book "Red Hat Linux 7 Weekend Crash 
Course" by Naba BArkakati

I thought that since I was having problems with the installer that I would 
download the fixes for the anaconda problems (20001009)  I tried using the 
update by entering "Linux Updates" at the boot prompt and got the following 
message and the system halted.

Running anaconda may take sometime to load
Trace back (inner most last):
File "/usr/bin/anaconda," line 206 in ? from todo import ToDo
File "/tmp/updates/todo.py.", line 143 if not self.isConfigured:
                                                               ^
Syntax Error: invalid syntax
Install exited abnormally
Sending termination signals...done
Sending kill signals...done
disabling swap...
Unmounting filesystems...
    /mnt/runtime
    /mnt/source unmount failed (16)
    /dev/pts
    /proc
you may safely reboot your system

That's all for now
Comment 3 Michael Fulbright 2001-01-03 18:24:02 EST
Sounds like bug 16686 as well. We've been trying to reproduce this issue and fix
it. Thanks for your bug report.

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.