Bug 230406 - MakeMaker has perl.mak depending on non-existent /usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/config.h'
MakeMaker has perl.mak depending on non-existent /usr/lib/perl5/5.8.8/i386-li...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 14:14 EST by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 10:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2007-02-28 14:14:57 EST
Description of problem:
I tried to build git here, the build fails:

make[2]: Entering directory `/home/vonbrand/tmp/git/perl'
make[2]: *** No rule to make target
`/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/config.h', needed by
`perl.mak'.  Stop.

The generated perl.mak file (essentially a Makefile with funny name) contains
the following:

  PERL_INC = /usr/lib/perl5/5.8.8/sparc-linux-thread-multi/CORE
  ...
  CONFIGDEP = $(PERL_ARCHLIB)$(DFSEP)Config.pm $(PERL_INC)$(DFSEP)config.h
  ...
  $(FIRST_MAKEFILE) : Makefile.PL $(CONFIGDEP)

I don't see how this could ever have worked, as the $(CONFIGDEP) file doesn't
exist. Strangely, the same git does build OK on Aurora Linux (essentially an
oldish Fedora Core), with the exact same Makefile, where the referenced file
doesn't exist either.

I'm blaming perl as it is the only piece I think might be involved that changed
today, and before updating today the build went fine.

Version-Release number of selected component (if applicable):
perl-5.8.8-13.fc7

How reproducible:
Don't know.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robin Norwood 2007-02-28 15:59:03 EST
Horst,

Do you have perl-devel installed?  And if not, does installing that fix it? 
This looks similar to the last few comments of bug #197841 - I suspect that
config.h got moved from perl to perl-devel with the new spec file for the perl
package review.  (that's bug #226276)
Comment 2 Horst H. von Brand 2007-03-01 08:00:55 EST
No, perl-devel is not installed, installing it fixes this.

Perhaps MakeMaker (and other -devel stuff) should move over?
Comment 3 Tom "spot" Callaway 2007-03-01 08:12:46 EST
We're still trying to get perl-devel sorted out. Suggestions of what should move
into perl-devel would be GREATLY appreciated. :)
Comment 4 Stepan Kasal 2007-07-27 10:06:03 EDT
In perl 5.8.8-16 from 2007-03-28, MakeMaker wasmoved to a a separate subpackage:
perl-ExtUtils-MakeMaker.
And that package requires perl-devel which contains the .../CORE/config.h.

I believe that this change has fixed the issue.

Note You need to log in before you can comment on or make changes to this bug.