Bug 230873 - tk may need an update - (trying do build brlcad)
tk may need an update - (trying do build brlcad)
Status: CLOSED DUPLICATE of bug 160441
Product: Fedora
Classification: Fedora
Component: tk (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-03 22:34 EST by Nicolas Chauvet (kwizart)
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 10:04:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2007-03-03 22:34:13 EST
Description of problem:
When trying to build brlcad the program wants to rebuild some libraries present
on the system (tcl tk iwidgets blt(unknow status) tkimg (unknwo status).
Unfortunately, it fails to rebuild them. 
When trying to disable the rebuild of all lib already on the system to force
brlcad to uses them, it do not find tk (but finds tcl...)

I expect this could be a problem with brlcad but anyway the needrebuild question
make me feel it bundles a newer version and need to link to a newer version...
So please update to the new tk-version (this may need to update also tcl)

I've worked on a spec file of tcl for the first step, but fail on the wall of
the dependency of packages using tcl...
http://kwizart.free.fr/fedora/SPECS/tcl.spec


Version-Release number of selected component (if applicable):
tk-8.4.13-3.fc6

How reproducible: build brlcad with disabled internal build of tk


Additional info: quote of the brlcad configure.am
dnl check if libtk library links
tk_link_works=no
LIBTK=""
AC_CHECK_LIB(tk8.6, Tk_MainLoop, tk_link_works=yes ; LIBTK="-ltk8.6",
    [AC_CHECK_LIB(tk8.5, Tk_MainLoop, tk_link_works=yes ; LIBTK="-ltk8.5",
	[AC_CHECK_LIB(tk8.4, Tk_MainLoop, tk_link_works=yes ; LIBTK="-ltk8.4",
	    [AC_CHECK_LIB(tk, Tk_MainLoop, tk_link_works=yes ; LIBTK="-ltk")]
	)]
    )]
)
Comment 1 Marcela Mašláňová 2007-03-05 03:43:46 EST
Hello,
on fedora-devel was long thread about upgrade tcl. I decided to stay on tcl/tk
8.4 until final release of tcl 8.5 (we don't want alfa version). I made some
changes in installation path of tcl, so I advice you to control installation
paths and let me know, if it's problem of tcl or tk package.
Comment 2 Nicolas Chauvet (kwizart) 2007-03-05 10:28:43 EST
Hello!
thx for your answear
So i've checked the tk version bundled with brlcad and it seems to be 8.4.6. So
this may not be a problem with up to date tk version...(thought tk 8.4.14 was
out in 10/2006)

The problem may be that it discovers automatically it in this directory:
(quote of the build log)
-DTK_LIBRARY="\"/usr/lib64/tk8.4
which seems good, but
[root@kwizatz tk8.4]# cd /usr/lib64/tk8.4/
[root@kwizatz tk8.4]# ls
pkgIndex.tcl
is empty because tk lib are in /usr/lib64

I don't know if i could overide this value so it can find the library for now...
I will give some tries...

The problem appears only with the tk package. tcl package seems to works fine...

Comment 3 Marcela Mašláňová 2007-03-06 02:36:07 EST
I saw the older version in FC-5/6 and everywhere was library *.so in /usr/lib or
/usr/lib64. So I close it like not a bug.
Comment 4 Nicolas Chauvet (kwizart) 2007-03-06 02:45:56 EST
But why did it search -DTK_LIBRARY="\"/usr/lib64/tk8.4 ???
i didn't gives him this path ? 
it should search tk lib here -DTK_LIBRARY="\"/usr/lib64 ! Why it do not find them ?
Comment 5 Nicolas Chauvet (kwizart) 2007-03-06 02:47:46 EST
I didn't gives him the first path ! 
Comment 6 Marcela Mašláňová 2007-03-06 03:26:01 EST
It seems to me like problem of brlcad. Which first patch? I use paths from
upstream in tk.
Comment 7 Nicolas Chauvet (kwizart) 2007-03-06 03:41:17 EST
So you think the problem would be that brlcad search for lib in /usr/lib64/tk8.4
(for 64bit) whereas they are in /usr/lib64 ?
I v' tryed to give an export LDFLAGS="-L%{_libdir} -pipe -fno-strict-aliasing
-fno-common -g -pthread -DTK_LIBRARY=%{_libdir}" But it didn't solve the problem
(same case with iwidgets and itk-devel but not sure since the process cannot go
until this point if rebuild is disabled)

Sorry to have insisted and thx for your answear!

I expect to check how it works with an other package that uses tk-devel so i can
see how it link...
Comment 8 Nicolas Chauvet (kwizart) 2007-04-13 19:59:39 EDT
The new version of brlcad is here (7.10) and i don't have a working tcl/tk
requirement...(it need tck/tk 8.5)
Do you have a workin progress package with last tcl tk so i can test with it ?

What is the current status of tcl tk into Fedora Core 7 ?
Comment 9 Marcela Mašláňová 2007-04-16 10:04:54 EDT
I don't want use alfa version in FC-7. 

I saw brlcad package and try to built it from source. I had tcl8.5 and tk8.5
(which is needed for build) and it fails, so the problem is somewhere in brlcad
maybe libraries, version of gcc... 

I'm closing it like duplicate of #160441.

*** This bug has been marked as a duplicate of 160441 ***

Note You need to log in before you can comment on or make changes to this bug.