Bug 160441 - update to Tcl/Tk 8.5
update to Tcl/Tk 8.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
: FutureFeature, Reopened
: 160442 230873 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 03:01 EDT by Ellen Shull
Modified: 2008-01-17 04:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 04:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to specfile to accomodate 8.4.9-3->8.5a3-1 changes (1.04 KB, patch)
2005-06-15 03:01 EDT, Ellen Shull
no flags Details | Diff

  None (edit)
Description Ellen Shull 2005-06-15 03:01:19 EDT
Tcl 8.5 is now in its third alpha release; schedule calls for release in the  
fall, which seems to fit FC5 timeline.  Since we're at the everything-breaks  
beginning of the rawhide cycle anyway, why not throw it in?   
   
(I don't really care about the Tcl part, but Tk 8.5 finally has Xft support,   
so that RFE will follow very shortly ;-)   
   
Current (8.5a3) builds fine and passes all automated tests (on my ~FC4 Athlon, 
anyway).  Attached is patch to specfile.  autoconf patch goes away, plus minor 
change to pick up new module directory tree (/usr/share/tcl8/).
Comment 1 Ellen Shull 2005-06-15 03:01:19 EDT
Created attachment 115456 [details]
patch to specfile to accomodate 8.4.9-3->8.5a3-1 changes
Comment 2 Jens Petersen 2005-06-16 01:33:46 EDT
Thank you for this.  I think I need to see the FC5 schedule first.
Can you ping again when beta1 is out say?  Thanks.
Comment 3 Jens Petersen 2005-09-12 05:00:47 EDT
*** Bug 160442 has been marked as a duplicate of this bug. ***
Comment 4 Jens Petersen 2005-09-12 05:02:20 EDT
Combine Tk 8.5 rfe with this one.
Comment 6 Marcela Mašláňová 2007-02-01 05:33:05 EST
update at tcl-8.5a5 & tk-8.5a5
Comment 7 Marcela Mašláňová 2007-02-08 12:13:58 EST
back to version 8.4.13
waiting for beta version -> too many things broken
Comment 8 Marcela Mašláňová 2007-04-16 10:04:59 EDT
*** Bug 230873 has been marked as a duplicate of this bug. ***
Comment 9 Nicolas Chauvet (kwizart) 2007-06-21 05:32:15 EDT
What is the status of this question with the current rawhide ?
i know few projects that have switched to tcl/tk 8.5 (amsn - brlcad which one is
knwo "stable" ...)
Is it possible to have two versions of thoses librairies installed at the same
time if tcl/tk 8.5 isn't planned to be stable with Fedora 8 ?

Comment 10 Marcela Mašláňová 2007-07-31 02:44:26 EDT
New stable version of tcl is available 8.4.15 (mentioned in #250117). Are we
interested in upgrading on 8.4.15 (maybe in F-8) or will be better to wait for 8.5?
Comment 11 Nicolas Chauvet (kwizart) 2007-08-01 07:46:41 EDT
As i'm interested in 8.5 i would prefer to have it. But maybe there will be a
need to have tcl84 and tcl85 for Fedora 8, until something get deceided for
which one should be the default, is it possible to have both for preparing the
linking to tcl85 ?
Comment 12 Marcela Mašláňová 2007-08-01 07:56:19 EDT
8.5 must be stable before pushing to rawhide. Yesterday I push to F-8
tcl-8.4.15. But if we can fix paths in 8.4.15 it would be nice. I had problem
with auto_paths here #248847. I made some fix for the meantime.

I'm not sure if it's possible to have two version of package in fedora. I think
that's not possible.
Comment 13 Nicolas Chauvet (kwizart) 2007-08-01 08:59:51 EDT
Well drpixel have experienced a parallele install of tcl85 with tcl from Fedora
(8.4). as i'm using it with amsn, it do not conflict with "system" tcl/tk 8.4
But -devel package are not parallele installable...

Unfortunnately, for an unknown reason brlcad do find tcl85 but not tk85 with
theses packages...

I'm still asking him to provide srpm and spec but he seems busy...


see:http://download.tuxfamily.org/rpm/drpixel/fedora/testing/7/
Comment 14 Marcela Mašláňová 2007-08-06 04:07:40 EDT
Yes, it's possible to have tcl8.4 and tcl8.5 install on one computer, but I
spoke about pushing two packages into yum. I think that's not possible and I
don't want try it. The main problem are related packages, which aren't changed
before stable version of tcl8.5 is out. 
I'm planning announce new stable tcl8.5 (not tcl8.5a5) in some list (fedora-*)
and wait for fix or reaction of maintainers related packages.

I built tcl8.5 before months, so I have my own spec file.
Comment 15 Nicolas Chauvet (kwizart) 2007-08-06 08:10:06 EDT
Maybe that would be a good idea to set up a testing repository for tcl/tk 8.5
outside of the rawhide tree. This could help to deceide what to do with it..

I Can take care of this on my own repository at http://kwizart.free.fr/fedora

If not necessary i'm interested in testing it for brlcad anyway (until i'm back
from vacation...)
Comment 16 Marcela Mašláňová 2007-08-08 08:50:23 EDT
Here are rpms and srpms of prepared version 8.5(a6)
http://mmaslano.fedorapeople.org/tcl/devel/

Now we can try to fix auto_paths. I used for this version some patches, which
are in stable version in rawhide.
Comment 17 Nicolas Chauvet (kwizart) 2007-10-19 05:27:55 EDT
Now there is a beta1, are we plan to update tcl/tk to 8.5 for Fedora 9 or are we
waiting to have it final ?
Are we expecting parallel installable tcl/tk (8.4 and 8.5) if needed ? or compat ?
Comment 18 Sander Hoentjen 2007-11-12 15:13:55 EST
Since Oct 26 beta 2 is out. I think it would make much sense to push this to
rawhide asap, so it will be in excellent shape at the time F9 comes out. Also it
would be nice to fix #227200 and other stuff in
http://fedoraproject.org/wiki/PackagingDrafts/Tcl
If there is any way I can help to make this happen please let me know. I am the
maintainer of aMSN and it would be a big improvement to have AA fonts.
Comment 19 Marcela Mašláňová 2007-11-13 04:02:21 EST
Did you notice what happened, when I update on alpha? I had to downgrade with
epoch and it was really long thread about that...

I think that will be better, if I make an announcement on fedora-devel, when
they can find rpm of tcl&tk-8.5b and try they packages with new version. After
release of new stable tcl, we can hopefully switch on new version without bigger
problems.
Comment 20 Nicolas Chauvet (kwizart) 2007-11-13 04:56:32 EST
@Marcela I agree with you.
Upgrade into rawhide must be tested first and only append when tcl/tk (and all
dependencies and packages using it) are stable or fixed.

I don't expect we can have dual versioned framework (with 8.4 and 8.5 - same
problem as python 2.4 and 2.5)

But since tcl/tk is a framework, I wonder how we could test multiple
dependencies packages against tcl/tk 8.5...
Actually that would be a task for a "special testing tcl/tk 8.5 repository" ?
For example, I need blt itck itk tkimg and iwidgets to test my package (brlcad)
- Could we find a place for such testing repository ?

Comment 21 Sander Hoentjen 2007-11-13 05:21:32 EST
(In reply to comment #19)
> Did you notice what happened, when I update on alpha? I had to downgrade with
> epoch and it was really long thread about that...
Yes, I was one that opposed to the epoch introduction, but that aside I think it
was said back then that we had to wait till the first beta came out to update.
That time has passed since then. I think there was only one package back then
that didn't work with 8.5, so we might want to check out if it does now.
I sent an email to the owner of the BLT package asking for some input.

> 
> I think that will be better, if I make an announcement on fedora-devel, when
> they can find rpm of tcl&tk-8.5b and try they packages with new version. After
> release of new stable tcl, we can hopefully switch on new version without bigger
> problems.

Sure we should announce it on devel first, see if anyone has a problem with it.

Sander
Comment 22 Marcela Mašláňová 2007-11-13 06:37:28 EST
If I use tcl8.5b, I'll be able also fix all related bugs, which we want see fix
in new version. For example #226893 should be fixed before release I suppose.
I'll give here link on new rpm as soon as it'll be fixed.
Comment 23 Marcela Mašláňová 2007-11-13 11:04:00 EST
Do you want tclsh and wish without version and what the libtclX.Y.so? I think
this should stay with numbers. Generally isn't good decision to create patches
don't included in upstream.
Comment 24 Marcela Mašláňová 2007-11-13 11:48:48 EST
Here are the testing packages:
http://mmaslano.fedorapeople.org/tcl/devel/tcl-8.5b2/
http://mmaslano.fedorapeople.org/tk/devel/tk-8.5b2/

I fix here hopefully bugs #227173 #227200 and I'd be happy if you test it on
your computers. I didn't test it on x86_64 yet.
Comment 25 Sander Hoentjen 2007-11-13 12:09:24 EST
Marcela, could you please put of SRPM and/or SPEC files as well?
Also i think it would be better to stick to beta package naming guidelines:
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-d97a3f40b6dd9d2288206ac9bd8f1bf9b791b22a
so the package would be:
tcl-8.5-0.1.b2.fc9.i686.rpm
I am on x86_64 so if you need me to build those package please tell me.
Comment 26 Marcela Mašláňová 2007-11-14 08:37:37 EST
Good point, I renamed files.

I've already compiled tcl on rawhide 64b and there's problem with linking. 
/usr/bin/ld: tclCompile.o: relocation R_X86_64_PC32 against `TclSetCmdNameObj'
can not be used when making a shared object; recompile with -fPIC

-fPIC option is used, but the TclSetCmdNameObj has something wrong in the code.
I'm still investigating. On i386 looks tcl ok.
Comment 27 Marcela Mašláňová 2007-11-15 03:59:45 EST
The problem is fixed. You can test it from repository mentioned in comment #24
Comment 28 Sander Hoentjen 2007-12-20 02:15:48 EST
It's out: http://www.tcl.tk/software/tcltk/8.5.html
Now it should definitely put in rawhide IMHO.
Can you try packaging the final version so we can test it?
Comment 29 Wart 2007-12-20 02:36:29 EST
(In reply to comment #28)
> It's out: http://www.tcl.tk/software/tcltk/8.5.html
> Now it should definitely put in rawhide IMHO.
> Can you try packaging the final version so we can test it?

+1

Work has finally settled down, so I'll have a bit more time to test this out
with the various extensions.  Does this mean we can finally get the auto_path
fixes in?  :)
Comment 30 Marcela Mašláňová 2007-12-20 03:23:24 EST
> Does this mean we can finally get the auto_path fixes in?  :)
I hope so. 

Now I package it and let know about new version on fedora-devel with list of
some of the dependent packages.
Comment 31 Marcela Mašláňová 2007-12-20 07:20:14 EST
You can find new (s)rpm here:
http://mmaslano.fedorapeople.org/tcl/devel/tcl-8.5.0
and here
http://mmaslano.fedorapeople.org/tk/devel/tk-8.5

I'd like to know, if the bug #227200 is fixed. If not than I'll be happy for a
patch. Please review it.

Also this draft http://fedoraproject.org/wiki/MichaelThomas/Tcl 
should be approved by Fesco. Shouldn't Michael do it or ask about approve?
Comment 32 Wart 2007-12-20 11:41:45 EST
(In reply to comment #31)
> You can find new (s)rpm here:
> http://mmaslano.fedorapeople.org/tcl/devel/tcl-8.5.0
> and here
> http://mmaslano.fedorapeople.org/tk/devel/tk-8.5

I get a 404 on the URL for the tk packages.

> I'd like to know, if the bug #227200 is fixed. If not than I'll be happy for a
> patch. Please review it.

Checking it out now...

> Also this draft http://fedoraproject.org/wiki/MichaelThomas/Tcl 
> should be approved by Fesco. Shouldn't Michael do it or ask about approve?

The packaging committee and I decided that the packaging draft should wait until
Tcl 8.5 was available.  Once the update is pushed to Rawhide, then I'll bring it
up with them again.

I think we should also get Tcl 8.5 added to the list of Fedora 9 proposed
features(http://fedoraproject.org/wiki/Features/Policy#feature-proposal), since
it's the first major upgrade to Tcl in many years and will affect many packages.
Comment 33 Wart 2007-12-21 02:28:28 EST
A couple of comments on the new package:

* The symlink from /usr/lib64/tcl8.5 -> /usr/share/tcl8.5 still exists. 
/usr/lib64/tcl8.5 should be an actual directory, not a symlink.
* The %pre section of the spec file should go away; it's not necessary once the
symlink is replaced with an actual directory.
* The man3 man pages are better located in the -devel subpackage, since the only
people who need them will be compiling against the Tcl C library.  The mann man
pages can stay in the base package, however.
* I still think the html documentation should be split out into a separate
package, and I'm willing to maintain that separate html doc package if you'd
like: https://bugzilla.redhat.com/show_bug.cgi?id=228782
* Bug #227200 is not yet fixed, because /usr/lib64/tcl8.5 is not in the
auto_path variable yet.  I'll make a patch for this and attach it here.
Comment 34 Marcela Mašláňová 2007-12-21 04:41:21 EST
> * The symlink from /usr/lib64/tcl8.5 -> /usr/share/tcl8.5 still exists. 
> /usr/lib64/tcl8.5 should be an actual directory, not a symlink.

So it's ok to install it twice? Once into datadir and once in libdir?

tk is  http://mmaslano.fedorapeople.org/tk/devel/tk-8.5.0
Comment 35 Sander Hoentjen 2007-12-21 05:15:47 EST
(In reply to comment #34)
> > * The symlink from /usr/lib64/tcl8.5 -> /usr/share/tcl8.5 still exists. 
> > /usr/lib64/tcl8.5 should be an actual directory, not a symlink.
> 
> So it's ok to install it twice? Once into datadir and once in libdir?
> 
No, only install it once. If it is arch specific install it in libdir, if not it
goes in datadir.
auto+path should contain both dirs, so application will look in both dirs.

Comment 36 Marcela Mašláňová 2007-12-21 09:18:28 EST
Hm, I start draft: https://fedoraproject.org/wiki/MarcelaMaslanova/Draft/tcl8.5

I remove html and start writing package for tcl-html. I'll be happy for a patch
of paths. I'm not sure of the correct solution. 

I'll update the packages immediately. I think that all *.tcl scripts have to be
in datadir, and libtcl8.5.so should be in libdir.
Comment 37 Wart 2007-12-21 23:26:39 EST
Here's an updated package that fixes the libdir issues, as well as a few other
minor cleanups:

http://www.kobold.org/~wart/fedora/tcl-8.5.0-1.1.src.rpm

* Includes patch for the restricted auto_path
* No more symlink; /usr/lib{64}/tcl8.5 is a real (empty) directory
* tcl-html docs have been exorcised
* No more hardcoded Sourceforge mirror in the source URL
* No more extra tcl8.5.0 directory in the build tree.

I have not tested Tk against this yet.  The tcl-8.5.0-autopath.patch may need
some adjustment to allow tk to find its own init.tcl.

The restricted auto_path is where we're likely to see most of the problems, I
expect.  Almost all Tcl extensions will have to be modified to install into
either /usr/lib{64}/tcl8.5 or /usr/share/tcl8.5.  Currently most packages
install directly into %{_libdir} or %{_datadir}.  Fortunately, I have patches
that will fix Tk, Expect, Tclx, and a couple of the other major extensions, and
the patches are pretty simple.
Comment 38 Marcela Mašláňová 2007-12-22 08:16:32 EST
Thanks, seems to be ok. I'll update it on my pages.

Do you think that's the right time for announce on fedora-devel or would you
like at firt fix Expect, Tclx and so on?
Comment 39 Sander Hoentjen 2007-12-25 05:49:31 EST
I think announcing now is the best thing. I really think we should ship 8.5 with
F9, so the earlier in the cycle things get done, the better shape it will be in.
Comment 40 Wart 2008-01-01 15:23:46 EST
(In reply to comment #39)
> I think announcing now is the best thing. I really think we should ship 8.5 with
> F9, so the earlier in the cycle things get done, the better shape it will be in.

+1

I have a patch for TclX that works, but Expect is generating build errors with
Tcl 8.5.  Let's give the Expect maintainer a chance to fix the build errors, and
then I can verify that the Expect patch for the restricted auto_path.
Comment 41 Marcela Mašláňová 2008-01-02 08:41:45 EST
8.5 is in rawhide
Comment 42 Marcela Mašláňová 2008-01-02 10:51:05 EST
Could someone review tcl-html bug#427264 ? I'd like to push it to repository.
Comment 43 Marcela Mašláňová 2008-01-17 04:07:14 EST
tcl-thml was pushed, update on tcl8.5 looks fine.

Note You need to log in before you can comment on or make changes to this bug.