Bug 230979 - Writes ServerBin into cupsd.conf!!
Writes ServerBin into cupsd.conf!!
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Radek Bíba
: Reopened
: 229738 250840 416101 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-05 04:26 EST by Tim Waugh
Modified: 2015-07-13 13:37 EDT (History)
7 users (show)

See Also:
Fixed In Version: 3.5.9-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 13:25:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-03-05 04:26:49 EST
Description of problem:
For some reason, using the KDE print tool can end up writing a line like this in
/etc/cups/cupsd.conf:

ServerBin /usr/lib64/cups

It must NEVER DO THIS!  That location is incorrect and causes a variety of
things to fail.  Why is it even trying to reconfigure the ServerBin setting? 
CUPS comes configured with a ServerBin setting at compilation time, and tools
were placed in the correct location at packaging time -- it isn't something that
can be reliably changed after the fact.

Version-Release number of selected component (if applicable):
kdelibs-3.5.6-0.3.fc6, probably others

How reproducible:
Don't know, but see the code.

Additional info:
I had this issue reported to me in private mail.
Comment 1 Tad Whitenight 2007-03-05 17:58:38 EST
Reproducible simply by running Settings->Printers (kcmshell printers).
Click Print Server and Configure Server. I receive an unrecognized options
warning dialog about optioins being left untouched, click OK. Click OK on CUPS
server configuration and bam, /etc/cups/cupsd.conf is modified with hundreds of
comment lines and option changes, especially the ServerBin which is fatal to
printing thereafter.
Comment 2 Tim Waugh 2007-03-12 09:48:34 EDT
*** Bug 229738 has been marked as a duplicate of this bug. ***
Comment 3 Rex Dieter 2007-11-17 16:34:01 EST
For now, our best recommendation is simply to not use kde's (kcmshel printers)
to configure cups.  It's just plain not very good, esp on 64bit platforms.
Comment 4 Rex Dieter 2007-11-17 16:40:54 EST
*** Bug 250840 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Dupuy 2007-12-07 16:32:36 EST
As noted in bug 416101, while this is definitely a KDE bug, it would be possible
to mitigate it (prevent the failure) by explicitly specifying ServerBin as
/usr/lib/cups in the cups RPM defauld /etc/cups/cupsd.conf since the KDE tools
will use an existing value in the file - they just have a broken default when it
is not present.

@alex
Comment 6 Tim Waugh 2007-12-11 12:36:29 EST
Seems to me it would be just as easy for kdelibs to just never write out that line.
Comment 7 Rex Dieter 2008-02-26 09:28:43 EST
*** Bug 416101 has been marked as a duplicate of this bug. ***
Comment 8 Lukáš Tinkl 2008-02-26 09:29:31 EST
Will be fixed in 3.5.9-2
Comment 9 Kevin Kofler 2008-02-26 15:11:12 EST
As per http://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow , the bug 
should be in MODIFIED state, not RESOLVED, as long as the update has not been 
pushed.
Comment 10 Fedora Update System 2008-02-28 16:37:12 EST
kdegames-3.5.9-1.fc7, kdesdk-3.5.9-1.fc7, kdeutils-3.5.9-1.fc7, kdeaccessibility-3.5.9-1.fc7, arts-1.5.9-1.fc7, kdeaddons-3.5.9-1.fc7, kdeartwork-3.5.9-1.fc7, kdebindings-3.5.9-1.fc7, kdegraphics-3.5.9-1.fc7, kdewebdev-3.5.9-1.fc7, kde-i18n-3.5.9-4.fc7, kdeadmin-3.5.9-1.fc7, kdeedu-3.5.9-1.fc7, kdemultimedia-3.5.9-1.fc7, kdenetwork-3.5.9-2.fc7, kdetoys-3.5.9-1.fc7, kdelibs-3.5.9-3.fc7, kdebase-3.5.9-1.fc7, kdepim-3.5.9-6.fc7, kdevelop-3.5.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdegames kdesdk kdeutils kdeaccessibility arts kdeaddons kdeartwork kdebindings kdegraphics kdewebdev kde-i18n kdeadmin kdeedu kdemultimedia kdenetwork kdetoys kdelibs kdebase kdepim kdevelop'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1892
Comment 11 Fedora Update System 2008-03-03 13:21:29 EST
kdevelop-3.5.1-3.fc7, arts-1.5.9-1.fc7, kdelibs-3.5.9-3.fc7, kdeaccessibility-3.5.9-1.fc7, kdeaddons-3.5.9-1.fc7, kdeadmin-3.5.9-1.fc7, kdeartwork-3.5.9-1.fc7, kdebase-3.5.9-3.fc7, kdebindings-3.5.9-1.fc7, kdeedu-3.5.9-1.fc7, kdegames-3.5.9-1.fc7, kdegraphics-3.5.9-1.fc7, kdemultimedia-3.5.9-1.fc7, kdepim-3.5.9-6.fc7, kdetoys-3.5.9-1.fc7, kdewebdev-3.5.9-1.fc7, kde-i18n-3.5.9-4.fc7, kdenetwork-3.5.9-2.fc7, kdesdk-3.5.9-1.fc7, kdeutils-3.5.9-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-03-03 13:25:43 EST
kdevelop-3.5.1-3.fc8, arts-1.5.9-1.fc8, kdelibs-3.5.9-3.fc8, kdeaccessibility-3.5.9-1.fc8, kdeaddons-3.5.9-1.fc8, kdeadmin-3.5.9-1.fc8, kdeartwork-3.5.9-1.fc8, kdebase-3.5.9-3.fc8, kdebindings-3.5.9-1.fc8, kdeedu-3.5.9-1.fc8, kdegames-3.5.9-1.fc8, kdegraphics-3.5.9-1.fc8, kde-i18n-3.5.9-4.fc8, kdemultimedia-3.5.9-1.fc8, kdenetwork-3.5.9-2.fc8, kdepim-3.5.9-6.fc8, kdesdk-3.5.9-1.fc8, kdetoys-3.5.9-1.fc8, kdeutils-3.5.9-1.fc8, kdewebdev-3.5.9-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.