Bug 250840 - kdelibs: "New Printer" hangs after setting printer name via cupsdconf
kdelibs: "New Printer" hangs after setting printer name via cupsdconf
Status: CLOSED DUPLICATE of bug 230979
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 17:11 EDT by Joel
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 16:40:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a trace file of the above hang (2.92 MB, application/octet-stream)
2007-08-03 17:15 EDT, Joel
no flags Details
requested cups config file (2.47 KB, application/octet-stream)
2007-08-09 17:09 EDT, Joel
no flags Details

  None (edit)
Description Joel 2007-08-03 17:11:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
After starting system-config-printer, I choose "New Printer" button.

Brings up a dialog where I can set a printer name, etc.  I click "Forward"

It hangs with a wait cursor.

Version-Release number of selected component (if applicable):
system-config-printer-0.7.63.2-2.fc7

How reproducible:
Always


Steps to Reproduce:
1.  See above
2.
3.

Actual Results:
It hangs interminably (at least an hour).  Ctrl-c does not work in the terminal from which the system-config-printer was executed.  ctrl-z, kill %1 however does work.

Expected Results:
Gone to the next dialog?

Additional info:
This program is completely opaque.  Perhaps the most opaque of any of the system-config utilities.
Comment 1 Joel 2007-08-03 17:15:11 EDT
Created attachment 160663 [details]
a trace file of the above hang
Comment 2 Joel 2007-08-07 13:02:48 EDT
WORKAROUND  --- bug source identified 

Ok.  I figured out what was causing the problem by setting LogLevel to debug in
/etc/cups/cupsd.conf.  It turns out that the web pages (http://localhost:631/)
were looking in /usr/lib64/cups however there was no /usr/lib64/cups.

ln -s fixed that problem.  

At first glance, this seems to still be a problem in fc8...
Comment 3 Tim Waugh 2007-08-08 04:18:39 EDT
The cupsd.conf we ship says to look in /usr/lib/cups, so the problem lies with
whatever tool edited it (and note, system-config-printer does not edit
cupsd.conf..).

Please attach /etc/cups/cupsd.conf.
Comment 4 Joel 2007-08-09 17:09:34 EDT
Created attachment 161023 [details]
requested cups config file
Comment 5 Joel 2007-08-09 17:22:45 EDT
I went back through my history file for the printer configuration and this is
what I see:

   85  system-config-printer
   87  cupsdconf
   94  system-config-printer-applet
   95  system-config-printer
   96  system-config-printer
   97  cd /etc/init.d/
   98  service cups restart
   99  system-config-printer
  100  system-config-printer
  101  system-config-printer
  102  system-config-printer
  103  system-config-printer
  105  system-config-printer
  106  kill %2

Maybe the cupsdconf (part of kde) did the damage?  I tried repeating with
cupsdconf but it doesn't seem to make the cupsd.conf look like the one I have.
Comment 6 Tim Waugh 2007-08-10 05:38:35 EDT
Yes, that's definitely it.  What does 'rpm -qf cupsdconf' say?
Comment 7 Rex Dieter 2007-08-13 10:00:20 EDT
$ rpm -q -f /usr/bin/cupsdconf
kdelibs-3.5.7-9.fc7.i386

Looks like we may want to consider omitting this from kdelibs.
Comment 8 Joel 2007-08-13 11:00:11 EDT
Before omitting it from kdelibs, it needs to be digested.  The configuration of
system-config-printer is extremely opaque to a new cups user.  Especially when
trying to interact in a windows domain.  That is why I tried cupsdconf, because
I was looking for a tool to give a useful selection on trying to point cups to a
windows print server...never did find anything useful...  ended up just going to
directly to :9100 on each of the printers and bypassing our print server.

Also, are all the cups cgi scripts not 64 bit?  Is cupsdconf right in expecting
to find them in lib64?
Comment 9 Tim Waugh 2007-08-13 11:10:54 EDT
Joel: I am aware that work is needed in system-config-printer for Windows shared
printers.  Other bugs are open for this.

cupsdconf is incorrect in expecting the CUPS ServerBin path to be
/usr/lib64/cups.  Although the binaries are indeed 64-bit, they are executables
not shared libraries, and are only in /usr/lib instead of /usr/libexec for
compatibility with upstream and other 3rd parties.

The issue here is that cupsdconf must not write incorrect cupsd.conf files.
Comment 10 Rex Dieter 2007-08-13 11:15:26 EDT
Right (what Tim said. :) ).  We can always certainly try patching kdelibs to do
the right thing here, (patches always welcome).

otoh, it simply makes little sense to me to include > 1 tool for the same job,
especially when one (cupsdconf) is known to by buggy.  *shrug*.
Comment 11 Joel 2007-08-13 11:30:30 EDT
Concur.  Note that cupsdconf didn't help me either...it hadn't clicked that it
was not part of cups until after I ran it and said "wow...the cups folks used
kde?"...I had gotten cups to work on redhat 9 and I loved it...unfortunately I
had forgotten that the real interface is the web interface on 631. 

Maybe system-config-printer can point that way?  Anywho, it seems that if we
just wack cupsdconf it would give more fuel to the fedora hates kde meme.

Thanks guys!
Comment 12 Tim Waugh 2007-08-13 12:37:57 EDT
Joel: does the CUPS web interface show you available printers that
system-config-printer does not? (I hope not: it uses the same API as the CUPS
web interface..)
Comment 13 Joel 2007-08-13 13:21:01 EDT
Concur.  Note that cupsdconf didn't help me either...it hadn't clicked that it
was not part of cups until after I ran it and said "wow...the cups folks used
kde?"...I had gotten cups to work on redhat 9 and I loved it...unfortunately I
had forgotten that the real interface is the web interface on 631. 

Maybe system-config-printer can point that way?  Anywho, it seems that if we
just wack cupsdconf it would give more fuel to the fedora hates kde meme.

Thanks guys!
Comment 14 Joel 2007-08-13 13:25:16 EDT
Ok..that was strange. (comment #13 reposting).  The CUPS web interface does not
show printers that system-config-printer does not.  
Comment 15 Rex Dieter 2007-11-17 16:40:53 EST

*** This bug has been marked as a duplicate of 230979 ***

Note You need to log in before you can comment on or make changes to this bug.