Bug 231012 - /etc/sysconfig/network has extraneous "yes" string
/etc/sysconfig/network has extraneous "yes" string
Status: CLOSED DUPLICATE of bug 227250
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-05 11:09 EST by Gerry Tool
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 13:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2007-03-05 11:09:25 EST
Description of problem:
[root@localhost ~]# cat /etc/sysconfig/network
NETWORKING=yes
yesHOSTNAME=f7t2.thetoolshed.us


Version-Release number of selected component (if applicable):
Don't know if this is the correct component to file this against

How reproducible:
Exists in f7t1 and f7t2, but not in FC6

Steps to Reproduce:
1.list contents of /etc/sysconfig/network
2.
3.
  
Actual results:
The second line has an extraneous "yes" at the beginning of line.

Expected results:
This "yes" should not be there.

Additional info:
Comment 1 Fred New 2007-03-06 07:15:49 EST
I also encountered this with the installation of F7T2.  I manually configured
the hostname during the installation, and after the first boot, the hostname was
localhost.
Comment 2 Harald Hoyer 2007-03-06 08:04:52 EST
did you even run system-config-network or is this an anaconda installation bug?
Comment 3 Fred New 2007-03-06 08:12:25 EST
I was wondering about whether this bug was assigned correctly...  I didn't run
system-config-network.  So I'm assuming that Gerry didn't either.
Comment 4 Gerry Tool 2007-03-06 09:39:09 EST
I could not recall the sequence of what I had done earlier, so this morning, I
did a fresh install.  This time I did this right after first boot:

[gerry@localhost ~]$ su
Password: 
[root@localhost gerry]# rpm -q --whatprovides /etc/sysconfig/network
file /etc/sysconfig/network is not owned by any package
[root@localhost gerry]# cat /etc/sysconfig/network
NETWORKING=yes
yesHOSTNAME=f7t2new.thetoolshed.us
[root@localhost gerry]# system-config-network
Bonobo accessibility support initialized
GTK Accessibility Module initialized
/usr/lib/python2.5/site-packages/rhpl/Conf.py:275: DeprecationWarning: raising a
string exception is deprecated
  raise FileMissing, self.filename + ' does not exist.'

[root@localhost gerry]# 

Content of Hosts pane in Network Configuration gui screen
IP		Name			Aliases
127.0.0.1	f7t2new.thetoolshed.us	f7t2new localhost.localdomain localhost
::1		localhost6.localdomain6	localhost6

[root@localhost gerry]# cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               f7t2new.thetoolshed.us f7t2new localhost.localdomain
localhost
::1             localhost6.localdomain6 localhost6
[root@localhost gerry]# 

The 'yes' is extraneous, put there by some program, but I have no way of knowing
if this is the cause of the hostname not being set to the value entered during
installation.

It was not clear to me which component to assign this bug to.  Harald probably
has a clear understanding, so please reassign as appropriate.

Comment 5 Gerry Tool 2007-03-06 09:46:19 EST
I forgot to run hostname in the above post.

Here it is:
[root@localhost gerry]# hostname
localhost
[root@localhost gerry]# 

Comment 6 Harald Hoyer 2007-03-06 09:48:29 EST
I think this is an installer bug
Comment 7 David Cantrell 2007-03-06 13:56:58 EST

*** This bug has been marked as a duplicate of 227250 ***

Note You need to log in before you can comment on or make changes to this bug.