Bug 23129 - fatal error reading rpm database
Summary: fatal error reading rpm database
Status: CLOSED DUPLICATE of bug 18994
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-02 07:27 UTC by imorgan
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-07 08:19:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description imorgan 2001-01-02 07:27:42 UTC
After retreiving header files for all available packages (or querying
locally cached headers), up2date (2.1.7-0.6.x) fails with:

There was a fatal RPM error. The message was:
error reading from database


I have verified the integrity of rpm's database files with db3_verify. They
all check out fine.

Comment 1 imorgan 2001-01-02 07:33:24 UTC
This fatal error does not occur if the "display all packages available" option
is disabled.

Comment 2 pedwards 2001-01-07 08:19:10 UTC
This also occurs with RH 7.0, up2date-2.1.7-1, with either -l or -d, both with
and without -a.

Forcing the user to not use -d is a bit annoying.


Comment 3 Preston Brown 2001-02-09 03:49:25 UTC

*** This bug has been marked as a duplicate of 18994 ***


Note You need to log in before you can comment on or make changes to this bug.