Bug 231414 - snd-hda-intel is broken in kernel 2.6.19-1.2911.6.5 and 2.6.20-1.2925.fc6
snd-hda-intel is broken in kernel 2.6.19-1.2911.6.5 and 2.6.20-1.2925.fc6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: sirius56 232912 233580 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-07 20:22 EST by Ravikiran Rajagopal
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.20-1.2933.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-25 19:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravikiran Rajagopal 2007-03-07 20:22:36 EST
Description of problem:
Upon updating from kernel 2911 to 2911.6.5, snd-hda-intel loads but produces 
the error message "hda-intel: no codecs initialized". This used to work with 
2911. Looking at the changelog, I see several changes related to hda-intel in 
2.6.19.6; I do not know which one is causing the problem. I am using an MSI 
7191 motherboard with ATI RS480 chipset with ATI SB450 express chipset. The 
hardware is correctly identified and the correct driver is also listed in 
hwconf. The output of lspci has the following lines relevant to the sound 
system:

00:14.2 Audio device: ATI Technologies Inc SB450 HDA Audio (rev 01)
        Subsystem: Micro-Star International Co., Ltd. Unknown device 7191
        Flags: slow devsel, IRQ 16
        Memory at fe9e8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 
Enable-

The relevant lines in my modprobe.conf:

alias snd-card-0 snd-hda-intel
options snd-card-0 index=0 position_fix=1
options snd-hda-intel index=0 position_fix=1
remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 
2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel

With 2911, /dev/dsp exists, but with 2911.6.5, /dev/dsp does not exist. 
Further, there are other flakiness issues with that 2911.6.5 that are not 
present in any of the previous FC6 kernels such as large network latency, long 
time to fork() before exec(), but I well submit separate bug reports for them.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2911.6.5

How reproducible:


Steps to Reproduce:
1. Install kernel-2.6.19-1.2911.6.5.
2. Reboot.
3. Run "ls /dev/dsp".
  
Actual results:
/dev/dsp does not exist.

Expected results:
/dev/dsp should exist.

Additional info:
As a workaround, I have switched back to kernel 2911. I can provide any other 
details, as necessary. I cannot take the machine off-line for more than a few 
minutes at a time; so, slowly ripping apart the snd-hda-intel patches to 
isolate the problem is probably impossible for me.
Comment 1 Popov R.I. 2007-03-08 03:21:31 EST
have problems with same device (ATI SB450) after updating from 2911.6.4 to
2911.6.5; 


from 2911.6.4 (works correctly):
------- /proc/asound/modules --------
 0 snd_hda_intel

------- /proc/asound/pcm --------
00-06: Si3054 Modem : Si3054 Modem : playback 1 : capture 1
00-02: ALC262 Analog : ALC262 Analog : capture 2
# it is correct pcm device 
00-00: ALC262 Analog : ALC262 Analog : playback 1 : capture 2   


from 2911.6.5 (dont works)

------- /proc/asound/modules --------
 0 snd_hda_intel

------- /proc/asound/pcm --------
00-06: Si3054 Modem : Si3054 Modem : playback 1 : capture 1

Comment 2 Chuck Ebbert 2007-03-15 18:14:38 EDT
*** Bug 231749 has been marked as a duplicate of this bug. ***
Comment 3 Richard Steck 2007-03-18 12:17:53 EDT
Same problems persists in 2.6.20.
Comment 4 Chuck Ebbert 2007-03-19 10:50:05 EDT
Should be fixed in next release. Test kernel is at

http://people.redhat.com/cebbert/kernels

or you can wait for release.
Comment 5 Chuck Ebbert 2007-03-19 10:51:19 EDT
*** Bug 232912 has been marked as a duplicate of this bug. ***
Comment 6 Michal Klich 2007-03-22 08:14:04 EDT
i`ll confirm later in the eveing but i think that its still a bug in a
kernel-2.6.20-1.2932.fc6.x86_64
Comment 7 Michal Klich 2007-03-22 18:21:18 EDT
ok, no sound in kernel-2.6.20-1.2932.fc6.x86_64 either. 
/sbin/lspci

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)


If You need some info don`t hesitate to ask.
Comment 8 Chuck Ebbert 2007-03-23 10:15:08 EDT
*** Bug 233580 has been marked as a duplicate of this bug. ***
Comment 9 Jarod Wilson 2007-03-23 13:44:49 EDT
FWIW, alsa 1.0.14rc3 fixes a number of audio issues with the onboard sound on an
core duo mac mini for me...
Comment 10 Chuck Ebbert 2007-03-23 14:03:26 EDT
Looking at the patch in the 2.6.20.4-review queue:

http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git;a=blob_plain;f=review-2.6.20/hda-intel-fix-codec-probe-with-ati-controllers.patch;hb=HEAD

it changes the max codecs to 4 but only for ATI controllers -- those
now work in kernel 2932/2933, which includes this patch. This is the
very latest from the upstream alsa tree. I guess I should try changing
the max to 4 for nvidia.

It used to be 4 for all controllers but that broke the ICH models...
Comment 11 Johan Cwiklinski 2007-03-24 04:13:45 EDT
Actually, kernel 2.6.20-1.2933.fc6 solves this problem for me :)
Comment 12 Michal Klich 2007-03-24 09:24:51 EDT
Works for me too. kernel-2.6.20-1.2933.fc6.x86_64.
Thank You
Comment 13 Richard Steck 2007-03-25 13:31:21 EDT
Sound now works for me with 2.6.20-1.2933.  The Intel onboard ATI SB450 HDA 
audio card is detected and PCM now shows up as ALC 833 Analog.

Thank you for your help.


Note You need to log in before you can comment on or make changes to this bug.