Bug 23161 - kudzu triggers autoload of non-existant cpia.o
kudzu triggers autoload of non-existant cpia.o
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hotplug (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
Florence Gold
:
: 23786 24853 25721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-02 12:14 EST by Pekka Pietikäinen
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 12:19:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2001-01-02 12:14:32 EST
When booting up b1 kudzu seems to trigger an autoload of cpia.o
although no such device exists on the system. This later
causes autoloading of bttv.o to fail since there already is a
char-major-81 device loaded.

This could be a kernel/modutils problem too. Both 
USB and parallel ports are completely unused.

/etc/modules.conf contains
alias eth0 tulip
alias scsi_hostadapter aic7xxx
alias char-major-81 bttv
alias usb-controller usb-uhci
post-install awe_wave /bin/sfxload /etc/midi/GU11-ROM.SF2
alias sound-slot-0 emu10k1


usb-uhci.c: $Revision: 1.242 $ time 02:59:14 Dec 13 2000
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0xd400, IRQ 9
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
Linux video capture interface: v1.00
V4L-Driver for Vision CPiA based cameras v0.7.4
Parallel port driver for Vision CPiA based cameras v0.7.4
Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
Winbond chip at EFER=0x3f0 key=0x87 devid=97 devrev=73 oldid=ff
Winbond chip type 83977TF / SMSC 97w33x/97w34x
Winbond LPT Config: cr_30=01 60,61=0378 70=07 74=03, f0=3b
Winbond LPT Config: active=yes, io=0x0378 irq=7, dma=3
Winbond LPT Config: irqtype=pulsed low, high-Z, ECP fifo threshold=7
Winbond LPT Config: Port mode=ECP and EPP-1.9
SMSC Super-IO detection, now testing Ports 2F0, 370 ...
0x378: FIFO is 16 bytes
0x378: writeIntrThreshold is 9
0x378: readIntrThreshold is 9
0x378: PWord is 8 bits
0x378: Interrupts are ISA-Pulses
0x378: ECP port cfgA=0x10 cfgB=0x48
0x378: ECP settings irq=7 dma=<none or set by other means>
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,COMPAT,EPP,ECP]
parport0: irq 7 detected
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
usb.c: registered new driver cpia
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 94M
agpgart: Detected Intel 440LX chipset
Comment 1 Bill Nottingham 2001-01-02 12:24:59 EST
kudzu doesn't know what a cpia *is*, much less how to load/configure it.

I'd guess that it's somehow getting dragged in by something else.

*Exactly* when is it getting loaded?
Comment 2 Pekka Pietikäinen 2001-01-02 13:22:17 EST
Appears to not be a kudzu problem, problem disappears if nousb is used 
or modules.usbmap deleted (depmod is run after rc.sysinit configures the USB
stuff)

Actually it looks like the problem is in /sbin/hotplug, since removing that
makes things work
again. cpia_usb.o is the first entry in modules.usbmap, so that just might be
the reason why
it's the one that gets randomly loaded.
Comment 3 Trond Eivind Glomsrxd 2001-01-03 06:11:18 EST
Bill, could you try pulling a new hotplug from sourceforge? URL in package... a
little hard to do from home.
Comment 4 Pekka Pietikäinen 2001-01-04 19:23:43 EST
This is from the 2.4.0 release notes, I'll try to check if this fixes the
problem tomorrow
(I tried getting a new /sbin/hotplug from CVS and the result was that it loaded
_ALL_ USB modules, not just cpia)

Matthew Dharm: 
 - USB hotplug fix - specify exactly which fields to match on
Comment 5 Bill Nottingham 2001-01-04 23:51:51 EST
... which requires a new modutils, which ain't out yet. Fun.
Comment 6 Bill Nottingham 2001-01-11 11:34:15 EST
*** Bug 23786 has been marked as a duplicate of this bug. ***
Comment 7 Glen Foster 2001-01-11 16:04:03 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 8 Bill Nottingham 2001-01-24 12:03:34 EST
*** Bug 24853 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2001-02-02 12:19:12 EST
*** Bug 25721 has been marked as a duplicate of this bug. ***
Comment 10 Trond Eivind Glomsrxd 2001-02-02 17:29:43 EST
I think it should be fixed now, with hotplug 1.9, coming soon to a Rawhide near you.

Note You need to log in before you can comment on or make changes to this bug.