Bug 23215 - in rhn-config the proxy url format is bad
in rhn-config the proxy url format is bad
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
: 35234 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-03 07:24 EST by Levente Farkas
Modified: 2015-01-07 18:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-08 18:59:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2001-01-03 07:24:34 EST
in rhn-config the proxy url format is bad is not very intuitive.
it would be better to be two line server: and port: rather than the
current form where the
http://proxy.x.y:3128/ is not valid and the
proxy.x.y:3128 is valid.
I don't think the joe user can find it out !
and there is not even a help button:-(((
Comment 1 Andrew Bartlett 2001-01-04 05:11:27 EST
Its even harder without the GUI, try editing the configuration file for that!
(The only hint is the compaint about non-numeric ports when you actualy try and
run up2date)
Comment 2 Jim Henderson 2001-01-04 12:41:44 EST
In addition to this, it seems that proxies that require authentication can't be
configured.  I can't find any documentation about how to do this.

I've tried user:password@proxy:80 as a format, and end up with nothing.

The error message I get is as follows:

There was a fatal error communicating with the server.  The message was:
unable to set up CONNECTION tunnel

Jim
Comment 3 Larry J. Kopenkoskey 2001-01-12 09:26:23 EST
>In addition to this, it seems that proxies that require authentication can't
>be configured.  I can't find any documentation about how to do this.

>I've tried user:password@proxy:80 as a format, and end up with nothing.

I'd like to stress this comment.  I have problems with this at my place of
employment.  The RH's update tool doesn't appear to have the hooks necessary to
authenticate through a proxy/firewall.  If it does, please let us all know how.
Comment 4 Steven Freed 2001-02-03 02:00:33 EST
I've had lenghty exchanges via email with RH support on this topic and
they don't seem to comprehend the fact that some proxies require a user
name and password. They kept telling me to talk to my firewall administrator.
...We'll just ignore the fact that I'm the Network Security Admin. here and I 
built the firewall.  I really hope someone addresses this soon.
Comment 5 Preston Brown 2001-02-09 00:31:10 EST
working on it.
Comment 6 Cristian Gafton 2001-02-19 20:32:39 EST
Assigned QA to jturner
Comment 7 Preston Brown 2001-03-05 16:33:57 EST
note on proxy format added to config file in CVS.
Comment 8 Jay Turner 2001-03-06 10:53:56 EST
Authenticated proxies appear to be working correctly with the latest CVS code
(from the 3/6 tree)  Should be shipped in the next release.
Comment 9 Preston Brown 2001-04-08 18:59:06 EDT
*** Bug 35234 has been marked as a duplicate of this bug. ***
Comment 10 Preston Brown 2001-04-12 16:57:49 EDT
addressed in errata due out today.
Comment 11 Steven Freed 2001-04-21 02:44:51 EDT
Sigh! I just got the new update for up2date and rhn-register and this still is
not resolved. While it appears that up2date supports an authenticated proxy,
rhn-register does not.

Since up2date requires that rhn-register be run, up2date is still useless. (and,
of course, I can't test up2date to make sure it really does work)

The release notes claim that rhn-register does support authenticated proxy, but
a quick perusal through the python code shows that this is clearly not true.

Can you *please* add authenticated proxy to rhn-register?
Comment 12 Jim Henderson 2001-04-24 15:41:25 EDT
As sfreed said, rhn_register still won't run because it doesn't support
authenticated proxies.  A workaround that I've just used with RH 7.1 is to go to
the Red Hat Network, create an identity if you don't have one already, and then
add a system to the profile.  Follow the instructions for a setup that does not
require rhn_register (ie, on the web).  Once you follow the steps there, run
up2date-config as root and set up the proxy.  I'm downloading updates to 7.1
right now, seems to be working just fine (so the up2date fix actually does work,
woohoo).

Note You need to log in before you can comment on or make changes to this bug.