Bug 232159 - gtk-qt-engine: squirrely disappearing icons, menu items in openoffice
gtk-qt-engine: squirrely disappearing icons, menu items in openoffice
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk-qt-engine (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-13 21:08 EDT by SZ BEAM
Modified: 2008-03-13 03:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.8-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PowerPoint slides that reproduce the icon problem (513.50 KB, application/vnd.ms-powerpoint)
2008-01-11 06:37 EST, Mary Ellen Foster
no flags Details
Movie of the icon problem manifesting (982.67 KB, application/ogg)
2008-01-11 06:44 EST, Mary Ellen Foster
no flags Details

  None (edit)
Description SZ BEAM 2007-03-13 21:08:37 EDT
Description of problem:
icons in openoffice disappear and then re-appear on mouseover:
when ooo apps are first launched, all looks normal. Moving the mouse over any
icon or menu causes all of the icons and menu items to disappear, leaving only
the grey frames. But they appear when the cursor is over them and work normally.

This occurs for the toolbar icons as well as all menu items, including the text
in the menus.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.4-5.5.10
gtk-qt-engine-0.70-4.20061211svn.fc6
kdelibs-3.5.6-0.3.fc6


How reproducible:
launch an ooo app and try to use it.

Steps to Reproduce: 
1. launch ooo app
2. mouse over any toolbar icon or use the menus 
3. continue. 
  
Actual results:
icons and menu items disappear and appear only when the cursor is over them

Expected results:
things should remain in place and not play silly games

Additional info:
I am assuming this is related to previous similar FC4 bugs I've seen with
gtk-qt-engine, if not, my apologies.
Comment 1 Rex Dieter 2007-03-13 21:21:23 EDT
Yep, see also bug #163110 and
https://bugs.freedesktop.org/show_bug.cgi?id=4650#c12
Comment 2 Rex Dieter 2007-03-15 16:53:01 EDT
Hrm, I'm unable to reproduce (it WORKSFORME regardless of how I launch ooo).

Could you try toggling your gtk-qt-engine settings via
KControl -> Appearance&Themes -> GTK Styles and Fonts
and try setting "Gtk Styles" to various things like Clearlooks, Bluecurve, Qt
?? 
Comment 3 SZ BEAM 2007-03-15 21:18:13 EDT
OK I started ooo just now the problem had magically fixed itself about 90% of
the way (no yum updates or any changes on my part since OP). There still was
some disappearing of _certain_ menu items when the mouse was over them this
time. But all the toolbar icons were OK.

Then went into the GTK Styles Controller and saw I had "Use my KDE Style..."
selected. My KDE style is "Light Style, 3rd revision"

But on selecting anyone one of the other styles in the drop-down, oowriter works
100%, no problems.

So I guess this is 99% solved, and workaround is to use Bluecurve or another
such style.

thanks for looking into it!
Comment 4 Reindl Harald 2007-04-06 08:31:39 EDT
No the Problem ist not solved and makes me crazy since some months :-(
If you use ooo2.1/oo2.2 from the original-packages there is no problem, but they
will "kill" package-cleanup --problems from yum-utils.

the problem is away if you start openoffice directly, and then you also can open
documents with double-click in konqueror - but if the apllication not is running
and you do this the icons are away

It is not a solve to use another style, because as i choosed the keramik-theme i
would have all applicatoons in this style and gnome is no alternative for
power-users.

I dont understand that the problem is only here if u use the feodra-package of
openoffice - what happens in this build?
Comment 5 Rex Dieter 2007-04-06 08:53:24 EDT
> I dont understand that the problem is only here if u use the feodra-package of
> openoffice - what happens in this build?

has something to do with gnome-theming not present in standard/upstream ooo
builds.  Past that, dunno.

As I said, I'm personally unable to reproduce (see comment #2), still.  I use
kde plastik theme, crystalsvg icons.
Comment 6 Reindl Harald 2007-04-06 09:09:46 EDT
it is also with plastik theme
i have tried it this moment with the result that all my personally
keramik-settings are destroyed and openoffice is stupid as before.

terrible enough that there is 2.0.x in a moment where 2.2 is out, the original
runs much better but the better way is the package-manager
Comment 7 dex 2007-04-20 12:04:10 EDT
This bug is bitting in rawhide
Keramik theme & style.
Comment 8 Reindl Harald 2007-04-20 12:16:37 EDT
(In reply to comment #7)
> This bug is bitting in rawhide
> Keramik theme & style.

Hmm what i dont understand is that the only application with the bug is
openoffice, and only the openoffice from fedroa and not the original.

If there is a bug in keramik why thunderbird and firefox who also
gtk-apllications and other gnome-applications like gthumb does not have any
problems?

Comment 9 Rex Dieter 2007-04-20 12:23:53 EDT
> i dont understand is that the only application with the bug is
> openoffice,

From what I've gathered from the gtk-qt-engine maintainer: openoffice (re)draws
it's gtk widgets in a unique (arguabley non-standard and/or buggy) way. 
Upstream ooo doesn't use/include gtk theming.

To narrow it down if keramik is to blame, try something else, like plastik.  Do
the problems still occur?
Comment 10 Reindl Harald 2007-04-20 12:55:50 EDT
On my machine yes it is also with plastik
See one of my last posts:

>it is also with plastik theme
>i have tried it this moment with the result that all my personally
>keramik-settings are destroyed and openoffice is stupid as before.

My problem is that with the original-ooo "check-packages --problems" is broken,
in other way i would not use the fedora-one with the display bug.

but i am sure that not ooo himself has the bug, because it is only in the
fedora-version. ooo 2.1 and 2.2 are making no troubles in this way
Comment 11 dex 2007-04-20 13:03:28 EDT
Yep still there with various styles & themes etc, not found one which works. 
Comment 12 Reindl Harald 2007-06-01 09:24:57 EDT
Same with Fedora 7 and OpenOffice 2.2
That does not make happy and i think it would be better to remove the changes
for gnome on fc7 instead users must break the package-manager under kde
Comment 13 Thomas Roessler 2007-06-08 06:50:16 EDT
OpenOffice is, in practice, a critical application for many who use Fedora 7. I
would suggest that a bug that makes this application essentially unusable in a
normal setup (and without a lot of fiddling) should be treated as much more
severe than just "medium."  Fix this; if not, it's going to cause people to
switch to different distributions.
Comment 14 Fedora Update System 2007-08-13 13:01:48 EDT
gtk-qt-engine-0.70-5.20070811svn.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Reindl Harald 2007-08-25 10:55:32 EDT
On Rawhide (VMware setup) this seems to work now

[root@fedora-test ~]# rpm -qa | grep gtk-qt
gtk-qt-engine-0.70-5.20070811svn.fc8
[root@fedora-test ~]# rpm -qa | grep openoffice
openoffice.org-graphicfilter-2.2.1-18.8.fc8
openoffice.org-calc-2.2.1-18.8.fc8
openoffice.org-langpack-de-2.2.1-18.8.fc8
openoffice.org-core-2.2.1-18.8.fc8
openoffice.org-xsltfilter-2.2.1-18.8.fc8
openoffice.org-math-2.2.1-18.8.fc8
openoffice.org-base-2.2.1-18.8.fc8
openoffice.org-impress-2.2.1-18.8.fc8
openoffice.org-javafilter-2.2.1-18.8.fc8
openoffice.org-draw-2.2.1-18.8.fc8
openoffice.org-writer-2.2.1-18.8.fc8
openoffice.org-pyuno-2.2.1-18.8.fc8

My Fedora 7 machines i wont test anymore because the app-links and
file-open-settings are not compatible with the packages from de.openoffice.org
and after creating a own repo with the original-packages updates in office,
private lan and on machines of friends work perfect.
Comment 16 Fedora Update System 2007-08-27 17:45:42 EDT
gtk-qt-engine-0.70-5.20070811svn.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Thomas Roessler 2007-08-30 06:46:52 EDT
OpenOffice seems fundamentally usable; yet, there are some broken interactions
in there. I've opened bug #266621 to describe the problems I'm currently seeing
in more detail.
Comment 18 Mary Ellen Foster 2007-09-12 09:55:13 EDT
I'm still seeing this problem, *sometimes*. It seems only to happen when I
specify a file on the command line (i.e., "openoffice.org $filename"), not when
I start the program and then open a file. And even then, only with some files ...

I've actually currently got a .ppt file that reliably reproduces this problem
every time -- icons go screwy when I open it from the command line, but if I
open it from within OO.o things are fine. It's sort of an internal document so
I'd rather not post it in this bug report, but I can probably send it privately
if necessary.
Comment 19 Mary Ellen Foster 2008-01-11 06:37:30 EST
Created attachment 291371 [details]
PowerPoint slides that reproduce the icon problem

This is still happening with gtk-qt-engine-0.8-1.fc8, especially when I open
files on the command line -- still, *sometimes*. At the moment, I can reproduce
it every time opening the attached document on the command line (i.e.,
"openoffice.org iva2007-slides.ppt"), but ONLY if the document is on my vfat
Windows XP partition. If I copy it to my home directory, nothing bad happens.

I'll try making an istanbul movie of this ...
Comment 20 Mary Ellen Foster 2008-01-11 06:44:57 EST
Created attachment 291373 [details]
Movie of the icon problem manifesting

Okay, I wasn't hallucinating -- this weird thing does happen with this file
*only* when I open it on the command line from my fat32 partition. Check out
the attached video. Argh!
Comment 21 Mary Ellen Foster 2008-02-29 04:44:22 EST
NB: Upstream is aware of this; activity seems to be at
http://gtk-qt.ecs.soton.ac.uk/trac/ticket/24
Comment 22 Fedora Update System 2008-02-29 06:57:51 EST
gtk-qt-engine-0.8-4.fc8 has been submitted as an update for Fedora 8
Comment 23 Fedora Update System 2008-02-29 06:58:15 EST
gtk-qt-engine-0.8-4.fc7 has been submitted as an update for Fedora 7
Comment 24 Fedora Update System 2008-03-01 04:28:03 EST
gtk-qt-engine-0.8-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-qt-engine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2165
Comment 25 Fedora Update System 2008-03-13 03:40:33 EDT
gtk-qt-engine-0.8-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2008-03-13 03:48:14 EDT
gtk-qt-engine-0.8-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.