Bug 163110 - gtk-qt-engine: menu/toolbar icons vanish
gtk-qt-engine: menu/toolbar icons vanish
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk-qt-engine (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-12 18:43 EDT by David Anderson
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: 0.60
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 16:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Horrible menus (21.90 KB, image/png)
2005-07-12 18:48 EDT, David Anderson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 4650 None None None Never

  None (edit)
Description David Anderson 2005-07-12 18:43:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4) KHTML/3.4.1 (like Gecko)

Description of problem:
I am using KDE, with gtk-qt-engine and the Plastik style. When I use  
openoffice.org, when I move my pointer over any icon in the user interface,  
then every other icon in the row or column vanishes.  
  
e.g. On a menu, all items vanish apart from the one underneath the pointer. On  
the toolbars, all icons on the row vanish apart from the one under the  
pointer.  
  
I saw bug 162387, and noticed that I was using gtk-qt-engine from kde-redhat  
(left over from FC2 installation). I switched this to gtk-qt-engine from FC4,  
and the problem changed - the icons are OK, but the menus have horrid clashes  
- see attached screenshot.  
 
Here are my installed RPMs: 
 
[david@shed ~]$ rpm -q qt --qf "%{NAME}-%{VERSION}-%{RELEASE} %{PACKAGER}\n" 
qt-3.3.4-15.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
 
[david@shed ~]$ rpm -qa kde* --qf "%{NAME}-%{VERSION}-%{RELEASE} 
%{PACKAGER}\n" 
kdeutils-3.4.1-0.fc4.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdeartwork-3.4.1-0.fc4.2 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdelibs-devel-3.4.1-0.fc4.1 Red Hat, Inc. 
<http://bugzilla.redhat.com/bugzilla> 
kdebase-3.4.1-0.fc4.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdemultimedia-extras-3.4.0-0.lvn.3.4 (none) 
kdewebdev-3.4.1-0.fc4.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdelibs-3.4.1-0.fc4.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdepim-3.4.1-0.fc4.2 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdenetwork-3.4.1-0.fc4.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdenetwork-devel-3.4.1-0.fc4.1 Red Hat, Inc. 
<http://bugzilla.redhat.com/bugzilla> 
kdegraphics-devel-3.4.1-0.fc4.2 Red Hat, Inc. 
<http://bugzilla.redhat.com/bugzilla> 
kdemultimedia-3.4.1-0.fc4.1 Red Hat, Inc. 
<http://bugzilla.redhat.com/bugzilla> 
kdegraphics-3.4.1-0.fc4.2 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdepim-devel-3.4.1-0.fc4.2 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdeadmin-3.4.1-0.fc4.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdeaddons-3.4.1-0.fc4.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
kdebase-devel-3.4.1-0.fc4.1 Red Hat, Inc. 
<http://bugzilla.redhat.com/bugzilla> 
kdeutils-devel-3.4.1-0.fc4.1 Red Hat, Inc. 
<http://bugzilla.redhat.com/bugzilla> 
 
[david@shed ~]$ rpm -q qt --qf "%{NAME}-%{VERSION}-%{RELEASE} %{PACKAGER}\n" 
qt-3.3.4-15.1 Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
 
[david@shed ~]$ rpm -q gtk-qt-engine --qf "%{NAME}-%{VERSION}-%{RELEASE} 
%{PACKAGER}\n" 
gtk-qt-engine-0.60-0.fdr.1.2 kde-redhat Developers <http://kde-redhat.sf.net/> 
 
Which I then switched to the one from extras: 
 
[david@shed ~]$ rpm -q gtk-qt-engine --qf "%{NAME}-%{VERSION}-%{RELEASE} 
%{PACKAGER}\n" 
gtk-qt-engine-0.41-6 (none) 
 
I had no problems in Firefox with gtk-qt-engine 0.6, but having switched to 
0.41 I now do get the same horrible menus. 
 
If I turn off gtk-qt-engine, the problems go away. 

Version-Release number of selected component (if applicable):
1.9.112-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Load OOo or Firefox 
   

Actual Results:  Very ugly menus 

Expected Results:  Normal menus 

Additional info:
Comment 1 David Anderson 2005-07-12 18:48:28 EDT
Created attachment 116691 [details]
Horrible menus
Comment 2 David Anderson 2005-07-12 18:48:59 EDT
#153976 looks very relevant. 
Comment 3 Caolan McNamara 2005-07-13 02:56:55 EDT
caolanm->than: reportedly affects OOo and firefox under kde
Comment 4 Ngo Than 2005-07-13 03:56:09 EDT
It's a bug in gtk-qt-engine, you should please report this issue to the
gtk-qt-engine upstream author. thanks
Comment 5 David Anderson 2005-07-13 17:12:00 EDT
Oh, I see. Does that mean that bugzilla.redhat.com is only for reporting 
packaging errors, then?? 
Comment 6 Ngo Than 2005-07-14 08:15:14 EDT
If there're any bugs in any packages, which are included in FC release, we will
try to fix them, of course. This bug is not in kdelibs, but seems in
gtk-qt-engine, which we don't have in our release. In this case you should report
this problem to the package maintainer or upstream author.
Comment 7 David Anderson 2005-07-14 11:32:22 EDT
Thanks for being patient with me, I'm a bit slow... I'm getting the bug with  
the version of gtk-qt-engine from Fedora Extras... are things from there not 
suitable for bugzilla.redhat.com? 
Comment 8 Ngo Than 2005-07-14 12:01:03 EDT
It's now assigned to correct component. If you find a bug in package from Fedora
extra, please choose product as "Fedora Extra" and then select the correct
component. sorry for confusion
Comment 9 Rex Dieter 2005-09-16 14:04:27 EDT
WORKSFORME, using gtk-qt-engine-0.60-3.fc4, kdelibs-3.4.2, ooo-1.9.125-1.1.0.fc4

Please re-open if you have further troubles or additional information.
Comment 10 David Anderson 2005-09-17 06:25:06 EDT
Re-opening, bugs still present with same versions as Rex is using, all these 
packages from Fedora Core/Extras. 
  
[david@shed ~]$ rpm -q openoffice.org-core gtk-qt-engine kdelibs  
openoffice.org-core-1.9.125-1.1.0.fc4  
gtk-qt-engine-0.60-3.fc4  
kdelibs-3.4.2-0.fc4.1  
 
I get the original problem reported (i.e. the one with gtk-qt 0.60, not the 
one from gtk-qt 0.44) - namely "On a menu, all items vanish apart from the one 
underneath the pointer. On the toolbars, all icons on the row vanish apart 
from the one under the pointer.   
Comment 11 Rex Dieter 2005-09-17 06:31:37 EDT
A few details please.  Which kde widget style are you using?  Which menus
exactly are showing this problem?  A stretch: what X video driver are you using?

As I said, it appears to work for me, but perhaps I'm looking in the wrong place.
Comment 12 David Anderson 2005-09-17 07:02:18 EDT
Using Plastik. All menus from the main toolbar show this problem, and all 
icons on the main toolbar similarly. Using nv driver (i.e. the x.org driver 
that is part of FC, not the NVidia proprietary driver). 
 
Comment 13 Rex Dieter 2005-09-30 08:33:07 EDT
To reiterate, I've still been unable to reproduce the problem reported.

For all who see it please provide:
1.  X video driver in use
2.  kde widget style in use
3.  output of: rpm -q xorg-x11 qt kdelibs openoffice.org gtk-qt-engine
Comment 14 Paul Smith 2005-09-30 11:16:52 EDT
Regarding 1 and 2, could you be more specific? That is, how can I know what is
the X video driver and the kde widget style in use?

# rpm -q xorg-x11 qt kdelibs openoffice.org gtk-qt-engine
xorg-x11-6.8.2-37.FC4.49.2
qt-3.3.4-17.4.fc4.kde
kdelibs-3.4.2-1.2.fc4.kde
package openoffice.org is not installed
gtk-qt-engine-0.60-3.fc4
#   

I do have openoffice installed (version 1.9.125).

I would like to add that the reported problem also occurs on Bluefish.
Comment 15 Rex Dieter 2005-09-30 11:24:40 EDT
For X driver, 
$ grep Driver /etc/X11/xorg.org

kde widget, KDE Control Center -> Appearance and Settings -> Style -> Widget Style

And ah, for openoffice, I goofed, should be:
rpm -q openoffice.org-core

Please report the version-release of Bluefish as well.
Comment 16 Paul Smith 2005-09-30 11:48:24 EDT
> For X driver,
> $ grep Driver /etc/X11/xorg.org

# grep Driver /etc/X11/xorg.org
grep: /etc/X11/xorg.org: No such file or directory
#

> kde widget, KDE Control Center -> Appearance and Settings -> Style -> Widget Style

Alloy.
 
> And ah, for openoffice, I goofed, should be:
> rpm -q openoffice.org-core

# rpm -q openoffice.org-core
openoffice.org-core-1.9.125-1.1.0.fc4
#  

> Please report the version-release of Bluefish as well.

# rpm -q bluefish
bluefish-1.0.4-1.2.fc4.rf
# 
Comment 17 Rex Dieter 2005-09-30 11:51:11 EDT
Sorry, let's try again:
grep Driver /etc/X11/xorg.conf
this one should *really* work.  (-:
Comment 18 Paul Smith 2005-09-30 11:57:05 EDT
Fine, now:

$ grep Driver /etc/X11/xorg.conf
        Driver      "kbd"
        Driver      "mouse"
        Driver      "nv"
$  
Comment 19 Rex Dieter 2005-09-30 12:05:39 EDT
Interesting.  Anyone seeing this problem who's *not* using xorg's nv driver?

For those using nv, could you try editing /etc/X11/xorg.conf, adding
Option "NoAccel" "yes"
to the section labelled "Device" containing the line
    Driver "nv"

and restart X (or reboot), and see if that makes any difference (X may run a bit
slower after this modification)?
Comment 20 Paul Smith 2005-09-30 12:22:35 EDT
> For those using nv, could you try editing /etc/X11/xorg.conf, adding
> Option "NoAccel" "yes"
> to the section labelled "Device" containing the line
>    Driver "nv"

In my case, no progress follows from adding the line

Option "NoAccel" "yes"

just below the line 

Driver "nv"
Comment 21 Rex Dieter 2005-09-30 13:35:04 EDT
Had to re-toggle gtk-qt and change my KDE widget style a few times, but finally
was able to reproduce.
Comment 22 Rex Dieter 2005-09-30 13:59:29 EDT
Reported upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=4650
Comment 23 Steve Storey 2005-10-25 05:53:28 EDT
Upstream poster reports that the vanilla release direct from OpenOffice.org does
not exhibit this behaviour. I've confirmed this as well. I guess this makes it
something to do with the way the FC4 build is done?
Comment 24 Caolan McNamara 2005-10-25 06:05:30 EDT
I'd be astonished, the only difference in this area from upstream and FC4 is
that the FC-4 soffice script explictly has

if [ -z $SAL_USE_VCLPLUGIN ]; then export SAL_USE_VCLPLUGIN=gtk; fi

i.e. with upstream version

export SAL_USE_VCLPLUGIN=gtk

and see if it shows the same behaviour
Comment 25 Paul Smith 2005-10-25 06:11:16 EDT
> I guess this makes it something to do with the way the FC4 build is
> done?

To confirm that, one should try to install the problematic programs directly
from their creators' site to check whether they exhibit the same problem. The
problematic programs are (at least): abiword, bluefish and gedit.
Comment 26 Steve Storey 2005-10-25 19:34:33 EDT
(In reply to comment #24)
> I'd be astonished, the only difference in this area from upstream and FC4 is
> that the FC-4 soffice script explictly has
> 
> if [ -z $SAL_USE_VCLPLUGIN ]; then export SAL_USE_VCLPLUGIN=gtk; fi
> 
> i.e. with upstream version
> 
> export SAL_USE_VCLPLUGIN=gtk
> 
> and see if it shows the same behaviour

Prepare to be astonished ... I noted in the upstream bug report in gtk-qt-engine
that there were various error messages on the console. When I export the above,
and run the vanilla swriter (or soffice -writer) from a console, it does all
still work ok (from basic testing, everything seems to appear ok - didn't do
anything with it as such) - however, I see a load of errors on the console which
are very similar indeed with the errors that come from the FC4 one (generated by
starting it, and also be mousing over some menus and toolbars):

(soffice.bin:2328): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion
`gdk_window_is_viewable (src)' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample:
assertion `pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(soffice.bin:2328): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion
`gdk_window_is_viewable (src)' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample:
assertion `pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(soffice.bin:2328): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion
`gdk_window_is_viewable (src)' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample:
assertion `pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(soffice.bin:2328): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion
`gdk_window_is_viewable (src)' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample:
assertion `pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(soffice.bin:2328): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion
`gdk_window_is_viewable (src)' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample:
assertion `pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(soffice.bin:2328): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion
`gdk_window_is_viewable (src)' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample:
assertion `pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(soffice.bin:2328): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion
`gdk_window_is_viewable (src)' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample:
assertion `pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(soffice.bin:2328): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion
`gdk_window_is_viewable (src)' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample:
assertion `pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion
`pixbuf != NULL' failed

(soffice.bin:2328): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

So I then went and commented the line in the FC4 version of soffice forcing
SAL_USE_VCLPLUGIN, and it then all seems to work ok - although it doesn't match
the QT look and feel (I think it goes for the Win98 toolkit it contains) and web
searching seems to imply there are problems even if you force it to KDE when
using Plastik, it does all work fine.

Given all of this, while the direct cause is the FC4 change, I see exactly why
it's been made - otherwise you get the default toolkit which is nothing like as
nice as forcing GTK in usual circumstances. I suppose the root cause is
something still in gtk-qt-engine or openoffice still? Now I know, I'm happy to
live with changing the soffice script when I update it - perhaps this can be put
on some FAQ somewhere?
Comment 27 Caolan McNamara 2006-01-27 11:10:55 EST
*** Bug 179059 has been marked as a duplicate of this bug. ***
Comment 28 Rex Dieter 2006-01-27 11:20:29 EST
This affect other gtk2 apps (not just ooo) too, changing summary.
Comment 29 David Sansome 2006-06-24 20:55:04 EDT
(Copied from https://bugs.freedesktop.org/show_bug.cgi?id=4650) 
 
Sadly it seems that this is a bug in OpenOffice - it differs from GTK in the   
order it calls the drawing functions for menus and toolbars.  When the mouse   
is moved over a toolbar button or menu item, the background is redrawn on top   
of all the existing entries and those entries not redrawn.   
   
Other theme engines seem to get away with this as they simply draw a frame,   
whereas the gtk-qt engine paints the entire area.   
   
I've committed a workaround which draws an unthemed frame around toolbars and   
menus if it detects OpenOffice is running.  It's not perfect, but I can't see  
anything else that I can do.  
Comment 30 Rex Dieter 2006-06-29 09:27:19 EDT
*** Bug 197210 has been marked as a duplicate of this bug. ***
Comment 31 Mary Ellen Foster 2006-06-29 09:32:24 EDT
My bug (197210) just got duplicated to this one. I'm not actually convinced this
is the same problem -- I'm seeing *missing* icons (i.e., red "X"s), not bad
rendering of icons.
Comment 32 Rex Dieter 2006-06-29 09:37:51 EDT
doesn't "missing icons" essentially mean the same thing as "icons vanish"?  (;
Comment 33 Mary Ellen Foster 2006-06-29 09:41:36 EDT
You'd think so, but no: one is a *rendering* problem (to quote from the original
bug report, "When I use openoffice.org, when I move my pointer over any icon in
the user interface, then every other icon in the row or column vanishes."); the
other is an *existence* problem (see
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=131734).
Comment 34 Rex Dieter 2006-06-29 16:02:51 EDT
Re: comment 29
Many thanks David.

%changelog
* Thu Jun 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.60-9
- gtk-qt-engine-cvs20060629, fix ooo issues (bug #163110)
Comment 35 Mary Ellen Foster 2006-12-04 08:37:15 EST
I think this exact problem is back again with the latest FC6 packages:
- gtk-qt-engine-0.70-3.fc6
- openoffice.org-2.0.4-5.5.3

Anyone else seeing this? I know I've seen it on one other FC6 system locally ...
Comment 36 Mary Ellen Foster 2006-12-04 08:41:49 EST
Okay, I just noticed this at https://bugs.freedesktop.org/show_bug.cgi?id=4650#c12

"This should now be fixed (again) in SVN."

So maybe gtk-qt-engine needs to be resynched with upstream again.
Comment 37 Rex Dieter 2006-12-22 12:20:37 EST
Ask and ye shall receive:

%changelog
* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.70-4.20061211svn
- gtk-qt-engine-20061211svn
Comment 38 Mary Ellen Foster 2007-03-14 05:59:20 EDT
This is mostly okay. Except, it only seems to work if I start OpenOffice from a
command prompt; if I browse my home directory with Konqueror and click on a Word
or Powerpoint file, then the icons disappear.

100% reproducible.

Note You need to log in before you can comment on or make changes to this bug.