Bug 232496 - Can not get higher resolution than 1024x768 on external lcd monitor
Can not get higher resolution than 1024x768 on external lcd monitor
Status: CLOSED DUPLICATE of bug 231359
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-15 15:12 EDT by Rob Rheault
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 11:27:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file after letting X11 autodetect my display and video card (952 bytes, text/plain)
2007-03-16 08:08 EDT, Rob Rheault
no flags Details
Xorg.0.log file from after X11 autodected display and video card (67.49 KB, text/plain)
2007-03-16 08:09 EDT, Rob Rheault
no flags Details
Xorg.0.log file from before letting X11 autodetect display and video card (64.48 KB, text/plain)
2007-03-16 08:10 EDT, Rob Rheault
no flags Details
xorg.conf file before letting X11 autodetect display and video card (1.17 KB, text/plain)
2007-03-16 08:11 EDT, Rob Rheault
no flags Details
first Xorg log (50.85 KB, text/plain)
2007-04-08 16:58 EDT, Matěj Cepl
no flags Details
the current Xorg log (48.83 KB, text/plain)
2007-04-08 16:59 EDT, Matěj Cepl
no flags Details
system-config-display generated xorg.conf (930 bytes, text/plain)
2007-04-08 17:00 EDT, Matěj Cepl
no flags Details
working xorg.conf file (1.70 KB, application/octet-stream)
2007-04-09 07:48 EDT, Rob Rheault
no flags Details

  None (edit)
Description Rob Rheault 2007-03-15 15:12:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10

Description of problem:
I have a thinkpad t42 with an ATI 7500 mobility video card and an HP L1706 monitor connected via VGA port on the docking station for the T42. I am not able to get the resolution on the L1706 monitor to go higher than 1024x768. I have tried increasing the settings in Display to 1280x1024 but it just resets back to 1024x768.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2911.6.5.fc6

How reproducible:
Always


Steps to Reproduce:
1.Change Display settings to 1280x1024
2.Restart X but logging out and back in again
3.

Actual Results:
Resolution gets reset to 1024x768

Expected Results:
Resolution should have stayed at 1280x1024.

Additional info:
Comment 1 Matěj Cepl 2007-03-16 07:56:28 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Rob Rheault 2007-03-16 08:08:28 EDT
Created attachment 150214 [details]
xorg.conf file after letting X11 autodetect my display and video card
Comment 3 Rob Rheault 2007-03-16 08:09:40 EDT
Created attachment 150215 [details]
Xorg.0.log file from after X11 autodected display and video card
Comment 4 Rob Rheault 2007-03-16 08:10:32 EDT
Created attachment 150216 [details]
Xorg.0.log file from before letting X11 autodetect display and video card
Comment 5 Rob Rheault 2007-03-16 08:11:23 EDT
Created attachment 150217 [details]
xorg.conf file before letting X11 autodetect display and video card
Comment 6 Matěj Cepl 2007-04-08 16:58:44 EDT
Created attachment 151937 [details]
first Xorg log

It's funny, but we have just bought this monitor for my wife (with a new HP
desktop), and although this doesn't work as expected (the monitor was not
recognized, so we've got 800x600 on startup, I had to switch to Generic LCD
Panel 1280x1024), but I cannot reproduce the above mentioned behavior -- once I
have setup the monitor with system-config-display everything works almost
smoothly.

ajax, should I file new bug on the non-recognition of the monitor?
Comment 7 Matěj Cepl 2007-04-08 16:59:23 EDT
Created attachment 151938 [details]
the current Xorg log
Comment 8 Matěj Cepl 2007-04-08 17:00:08 EDT
Created attachment 151939 [details]
system-config-display generated xorg.conf
Comment 9 Rob Rheault 2007-04-09 07:48:46 EDT
Created attachment 151984 [details]
working xorg.conf file
Comment 10 Rob Rheault 2007-04-09 07:50:39 EDT
My install of FC6 was able to recognize the monitor and autoconfig it. However,
this did not allow the video card to push a higher resolution to it. After
searching in google and other forums I was able to fix this by setting the
Monitor Layout in xorg.conf to TMDS.
Comment 11 Adam Jackson 2007-04-09 11:27:31 EDT

*** This bug has been marked as a duplicate of 231359 ***
Comment 12 Rob Rheault 2007-04-09 13:52:50 EDT
I don't see how this bug can be a duplicate of 231359. I don't see any
similarities between them at all.

Note You need to log in before you can comment on or make changes to this bug.