Bug 23271 - Anaconda hangs during upgrade, then crashes during 2nd attempt
Anaconda hangs during upgrade, then crashes during 2nd attempt
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-04 02:19 EST by Harry Hart
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-19 23:40:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Hart 2001-01-04 02:19:12 EST
Background: Attempt upgrade RH6.2 --> RH7.0 using original installation
media.  After about 75% of the package installation is completed, system
hangs (mouse is frozen, no disk or CD-ROM activity).  Reboot to original
system fails (kernel panic, something about no "init").  Re-attempt
upgrade, but anaconda crashes with verbose error.  Go to RH WWW site and
download updated anaconda installer.  Run that, but get same crash as
before (not the frozen mouse, but the verbose error).  Anaconda offers to
copy error log to floppy.  I've attached that file to this report.  What
could have caused the original failure, and how can I get my system to boot
again? 
Thanks - Harry
Anaconda error log follows:
===========================================================================
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/examine_gui.py", line
30, in getScreen
    self.parts = self.todo.upgradeFindRoot ()
  File "/tmp/updates/todo.py", line 881, in upgradeFindRoot
    isys.umount('/mnt/sysimage')
  File "/usr/lib/anaconda/isys.py", line 113, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point

Local variables in innermost frame:
what: /mnt/sysimage
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2001-01-09 17:55:11 EST
Assigning to a developer.
Comment 2 Need Real Name 2001-03-31 14:00:33 EST
Anaconda died trying to do a hard-drive upgrade to Redhat 7.0. The traceback 
info looks awfully similiar to the one shown in the original report. I have two 
hard drives, about 4 Gb each. They both contain an MS-DOS partition as the 
first partition. The upgrade data is on /dev/hdb3.


===============================================
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in 
__call__
  File "/tmp/updates/todo.py", line 941, in upgradeFindPackages
    self.getCompsList ()
  File "/tmp/updates/todo.py", line 539, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in 
readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: XFree86

Local variables in innermost frame:
self: <comps.HeaderList instance at 819ea28>
item: XFree86

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10

<failed>
Comment 3 Matt Wilson 2001-03-31 16:42:13 EST
are you sure you propery copied all the rpms to your hard drive?
Comment 4 Brent Fox 2001-04-19 23:40:37 EDT

*** This bug has been marked as a duplicate of 18019 ***

Note You need to log in before you can comment on or make changes to this bug.