Bug 232810 - no widescreen resolution for intel g965 chipset
Summary: no widescreen resolution for intel g965 chipset
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords: Patch, Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-18 08:56 UTC by filippo david
Modified: 2018-04-11 14:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 22:09:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (587 bytes, application/octet-stream)
2007-03-18 08:58 UTC, filippo david
no flags Details
log file with xorg.conf (78.47 KB, text/plain)
2007-03-18 08:58 UTC, filippo david
no flags Details
log without xorg.conf (69.18 KB, text/plain)
2007-03-18 08:59 UTC, filippo david
no flags Details
latest xorg logfile (143.85 KB, text/plain)
2007-04-11 11:09 UTC, filippo david
no flags Details
osd info (1.33 MB, image/jpeg)
2007-04-11 11:12 UTC, filippo david
no flags Details
messed fonts (762.03 KB, image/jpeg)
2007-04-11 11:15 UTC, filippo david
no flags Details
patch (390 bytes, text/x-patch)
2007-05-29 20:04 UTC, filippo david
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 10545 None None None Never

Description filippo david 2007-03-18 08:56:58 UTC
Description of problem: i can't get the proper resolution (1680x1050_60) with
the intel video driver (modesetting i believe).
I have an Intel DG965WH botherboard with the g965 video chipset and i'm running
Fedora rawhide with latest updates.


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.5-13.fc7
xorg-x11-server-Xorg-1.2.99.901-2.fc7
  
Actual results: if i choose the i810 driver i can only get a stretched 1280x1024
resolution, while with the intel driver i get a 1400x1050_60 resolution wiche
does look odd on my screen (worse than 1280x1024).


Expected results: get the 1680x1050_60 resolution

Comment 1 filippo david 2007-03-18 08:58:17 UTC
Created attachment 150330 [details]
xorg.conf

Comment 2 filippo david 2007-03-18 08:58:58 UTC
Created attachment 150331 [details]
log file with xorg.conf

Comment 3 filippo david 2007-03-18 08:59:35 UTC
Created attachment 150332 [details]
log without xorg.conf

Comment 4 Adam Jackson 2007-03-23 15:45:35 UTC
The intel log looks like it's giving you 1680x1050.  What does 'xrandr -q' say?

Comment 5 filippo david 2007-03-23 17:10:40 UTC
meanwhile i updated to the latest rawhide (and xorg-x11-drv-i810-1.6.5-14.fc7),
but still the same problem.
 

[filippo@localhost ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1680
VGA connected 1680x1050+0+0 (normal left inverted right) 433mm x 271mm
   1680x1050      60.0*+   60.0  
   1280x1024      75.0     59.9  
   1280x960       59.9  
   1152x864       75.0     74.8  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  

also gnome-display-properties shows 1680x1050_60 as current resolution, but it's
a lie: the desktop looks odd and the OSD of my monitor shows it's working at
1400x1050_60.

Comment 6 Adam Jackson 2007-04-10 22:36:27 UTC
As of xorg-x11-drv-i810-1.6.5-19.fc7, 915GM and all 945 and 965 chips will use
the intel modesetting driver by default.  Please update, and test with that
driver, and reopen if you have further issues.

Comment 7 filippo david 2007-04-11 11:06:27 UTC
I have updated to the latest drivere and still I get the same problems. I'm
giong to upload a couple of files that i hope will make the problem clear.
It looks like that if I check the xorg log and xrandr -q everything should be
fine but it is not. Even if i take a screenshot and look it on a different PC,
it is a perfect 1680x1050 picture with all in the right place.
And when I tried this monitor on a different PC with a Nvidia videocard (with
fedora core 5) everything was perfect.

Comment 8 filippo david 2007-04-11 11:09:33 UTC
Created attachment 152259 [details]
latest xorg logfile

I had to choose the intel driver via system-config-display because without it
still load the i810 driver by default.

Comment 9 filippo david 2007-04-11 11:12:13 UTC
Created attachment 152261 [details]
osd info

this is the osd info of the monitor showing it working at the wrong resolution

Comment 10 filippo david 2007-04-11 11:15:37 UTC
Created attachment 152262 [details]
messed fonts

the resolution problem is clear looking at how i see the fonts: look at "Home
di filippo" in particular the first "o" and the "i". This is just an example of
how i see the whole screen.

Comment 11 Adam Jackson 2007-04-11 15:21:07 UTC
Do the other resolutions available from xrandr work?  For example:

$ xrandr --output VGA --mode 1024x768 --rate=60.0

Comment 12 filippo david 2007-04-11 16:31:39 UTC
Yes, I just tried some resolution and they do work. All of them work well except
they are stretched from 4:3 to 16:10, but looks fine.
It seems the problem is just with 1680x1050, maybe not but it's the only 16:10
resolution I can try.

Comment 13 filippo david 2007-04-12 17:08:19 UTC
I forgot to tell: the monitor is connected via VGA cable not DVI.

Comment 14 filippo david 2007-04-13 15:28:51 UTC
searching on the web, I found this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=10545
I guess it's the same problem I have: same motherboard, similar monitor (same
native resolution, same brand) and same driver version.

Comment 16 Gary Lerhaupt 2007-04-17 18:18:58 UTC
For what it's worth, a new version of 915resolution was released on Monday which
supports the q965/g965.  I'm running a q965 chipset (Dell optiplex 745) and was
having similar problems as documented here (using latest fc7 xorg).  Now with
915 I can get 1920x1200, but any lower widescreen resolutions do not fill the
entire monitor.

http://www.geocities.com/stomljen/915resolution-0.5.3.tar.gz

Comment 17 filippo david 2007-05-12 08:14:08 UTC
with:

xorg-x11-server-Xorg-1.3.0.0-3.fc7
xorg-x11-drv-i810-2.0.0-2.fc7

the problem is still there. Looking at freedesktop, a similar bug was "resolved"
for both a Samsung Syncmaster 226BW (bug #10545) and a 225BW (see
https://bugs.freedesktop.org/show_bug.cgi?id=10814), in the same way.
Unfortunately i am absolutely unable to modify and install the patch by myself.
Thus, if anybody could make a patched rpm or explain how to make one, i can test
right away.

Comment 18 filippo david 2007-05-29 20:04:51 UTC
Created attachment 155623 [details]
patch

Applying the attached patch i got everything working as it should. The patch is
obtained modifying those found on bugzilla.freedesktop.org for SyncMaster226
and 225bw.

This is the first patch i ever "made", so probably it could be better or
something.
I really hope there will be an update with the fix for fedora 7 soon after the
release.

Comment 19 Adam Jackson 2007-07-27 22:09:17 UTC
This patch has been integrated in F7 updates.


Note You need to log in before you can comment on or make changes to this bug.