Bug 232842 - soft lockup when running 'service cpuspeed stop'
soft lockup when running 'service cpuspeed stop'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 232903 233225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-18 14:36 EDT by Mads Villadsen
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-24 13:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel stack trace from soft lockup (1.70 KB, text/plain)
2007-03-18 14:36 EDT, Mads Villadsen
no flags Details
output of /proc/cpuinfo && uname -mrp (772 bytes, text/plain)
2007-03-20 07:44 EDT, Julius B.
no flags Details

  None (edit)
Description Mads Villadsen 2007-03-18 14:36:47 EDT
Description of problem:
A soft lockup occurs when stopping the cpuspeed daemon.

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2997.fc7
cpuspeed-1.2.1-1.57.fc7


How reproducible:
Always.

Steps to Reproduce:
1. service cpuspeed stop (or attempt to shutdown computer)
2. the attached soft lockup occurs.
Comment 1 Mads Villadsen 2007-03-18 14:36:47 EDT
Created attachment 150339 [details]
kernel stack trace from soft lockup
Comment 2 Jarod Wilson 2007-03-19 09:50:59 EDT
Can you please give us some details as to what sort of system you're seeing this
on? (System vendor, cpu type, whether or not you're running the latest bios for
it, etc).
Comment 3 Jarod Wilson 2007-03-19 10:10:08 EDT
*** Bug 232903 has been marked as a duplicate of this bug. ***
Comment 4 Ralf Ertzinger 2007-03-19 12:50:15 EDT
Seeing this on an IBM ThinkPad X60s, Core Duo, 1.66GHz.

kernel-PAE-2.6.20-1.2997.fc7

This is the first kernel to show this.
Comment 5 Mads Villadsen 2007-03-19 13:50:27 EDT
I am seeing it on a Dell Latitude D820, Centrino Duo 1.8GHz. Do you want the
output from /proc/cpuinfo as well?
Comment 6 Julius B. 2007-03-20 07:44:40 EDT
Created attachment 150475 [details]
output of /proc/cpuinfo && uname -mrp

Don't know if you need it :-)
Comment 7 Jarod Wilson 2007-03-20 17:24:02 EDT
Okay, seems the breakage is Intel's fault, but they're looking into it, so just
sit tight and it ought to be sorted out shortly... :)
Comment 8 Jarod Wilson 2007-03-20 22:42:49 EDT
*** Bug 233225 has been marked as a duplicate of this bug. ***
Comment 9 Skip Palin 2007-03-21 08:31:42 EDT
So i have an AuthenticAMD can we still blame Intel?
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 95
model name      : AMD Athlon(tm) 64 Processor 3200+
stepping        : 2
cpu MHz         : 1000.000
cache size      : 512 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt rdtscp lm
3dnowext 3dnow pni cx16 lahf_lm svm extapic cr8_legacy
bogomips        : 2005.75
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

2.6.20-1.2999.fc7 x86_64 x86_64
Comment 10 Jarod Wilson 2007-03-21 09:50:26 EDT
Yep, these code changes were done in the frequency scaling code, not in any
intel-processor-specific code. From what davej tells me, w/o the change they
made, the ondemand governor was waking up about 100 times per second to do
pretty much nothing, so humorously, power saving code was needlessly sucking up
extra power. The attempted fix obviously wasn't quite complete and/or uncovered
another problem, which is being worked on now... :)
Comment 11 Julius B. 2007-03-23 17:49:22 EDT
Okay, after the update from 2999 to 3016 it works now correctly. So from my
point of view it's closed.
Comment 12 Mads Villadsen 2007-03-24 04:04:08 EDT
It also works so me now.
Comment 13 Skip Palin 2007-03-24 21:04:52 EDT
Works for me

Note You need to log in before you can comment on or make changes to this bug.