Bug 233056 - Add support for Areca RAID controllers (include arcmsr driver from 2.6.19)
Add support for Areca RAID controllers (include arcmsr driver from 2.6.19)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 233399
  Show dependency treegraph
 
Reported: 2007-03-20 02:40 EDT by nickcheng
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 09:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nickcheng 2007-03-20 02:40:25 EDT
As the description below and other customers' practical requests, we hope the
driver could be included in the subsequent Fedora core. It will really benefit
the customers and contributes the win-win situation.
Thank you.
   
+++ This bug was initially created as a clone of Bug #205897 +++

Description of problem:
The arcmsr driver provides support for a line of extremely high performance RAID
cards. This includes PCI Express SATA controllers.

Their website is: http://www.areca.us/

The arcmsr driver has cleared all reviewer hurdles, and now James Bottomley has
it in his scsi-misc git tree for merge (waiting for 2.6.19 to open).

As of today, the driver is located at:

http://kernel.org/pub/linux/kernel/people/jejb/scsi-misc-2.6.diff

Please include this driver in the RHEL5 kernel.

BTW, Ubuntu has included this in their kernel since 6.06 LTS.

-- Additional comment from coughlan@redhat.com on 2006-09-11 09:40 EST --
RHEL 5 will be based on the 2.6.18 kernel. Unfortunately, this will not include
the arcmsr driver, and it is too late in the RHEL 5 development schedule to add
a new driver like this. I will put this on the list for consideration on in 5.1.
I will also see about getting some hardware here so we can test and support it
properly. 

-- Additional comment from dijuremo@math.gatech.edu on 2006-09-28 10:11 EST --
These cards have been out there for a while already, it is actually irritating
that Red Hat does not provide support for them. They perform even better than
any other SATA raid card available in the market. Hacking the install kernel to
add the drivers is a pain. The least you guys could do is provide a driver disk
if you are not including the driver in the kernel.

I currently use these cards in 7 of my servers running RHEL4 and updating a
kernel is a pain since I also have to go through the extra step of manually
building and installing the driver.

There is even a driver disk for CentOS and several kernel rpms as well as an
srpm provided at http://www.bodgit-n-scarper.com/code.html#centos, so you guys
really need to step up and include this somehow or provide a download to make it
easy for the end users to include this cards.

-- Additional comment from dijuremo@math.gatech.edu on 2006-09-29 13:57 EST --
Hi Dax and all,

Here is a driver disk for RHEL5 Beta1 x86_64:

https://services.ibb.gatech.edu/wiki/index.php/Howto:Software:Areca#Driver_Disk_for_RHEL5-beta1

Enjoy,

Diego

-- Additional comment from dijuremo@math.gatech.edu on 2007-02-28 07:39 EST --
The Areca drivers were oficially merged in the 2.6.19 Kernel tree. Should we
expect a backported patch to the RHEL5 release kernel (2.6.18)?  These cards are
really very popular and beat the 3ware 95XX series models. The new Areca cards
based on the IOP341 chipset are extremely fast. I have used the Areca cards with
RHEL4 for almost two years now and have not had any problems other than the pain
to install the OS since the drive is not part of the kernel in RHEL4.

Installing a new machine is sort of a pain and if the driver is now oficially in
the kernel, then backporting it should be the way to go. I plan to update to
RHEL5 when it comes out and would really like this driver to be included in the
kernel if possible.

-- Additional comment from andriusb@redhat.com on 2007-03-01 01:21 EST --
Adding Areca... Kevin, does Erich have a Bugzilla account?

Diego - Red Hat understands your frustration in this matter but we must rely
heavily on the vendor to provide equal support for any drivers we include in our
distro. We are in the process of acquiring more information from Areca at this
time. 

Although it is quite technically trivial to include a backported patch into
RHEL, there are a *lot* of other items that must go along with this, which
include things such as joint support alignment, joint roadmap alignment and
planning, and most importantly internal QA.

It's great to hear that the cards Just Work, but Red Hat must make sure all
bases are covered in case things don't go so smoothly for others. We are looking
forward to testing this for possible inclusion.

Stay Tuned! :-)

-- Additional comment from dijuremo@math.gatech.edu on 2007-03-05 12:45 EST --
The drivers are now part of the kernel tree in 2.6.19, so I though that would be
enough assurance that their hardware is supported under linux. Unfortunately, I
do not have a support contract for my RHEL4 boxes since our campus has a site
license and we have our own Satelite server with no support, otherwise, I would
have inquired about Red Hat backporting the drivers earlier for RHEL4. It was
not until I got the first beta of RHEL5 when I noticed the drivers were not
there, but that was to be expected, as the driver was not officially accepted
and released as part of the Linux kernel until 2.6.19.

However, since the driver is now officially part of the kernel, I would like to
ask you guys to really consider including a back ported patch on the 2.6.18
RHEL5 kernels.  Even if it is not right away on RHEL5 release; at least add it
to the list of things to consider for a possible Update 1 or Update 2 releases
of RHEL5.

I know how to create Initrds and manually add the driver to boot from a USB
keychain from which I boot to then install RHEL over the network. After the
system is kickstarted, I run up2date in thye %post% section to fully patch the
system from the sattelite and then I make sure I have the RPMS for the driver
compiled for the latest kernel (which the system will get from up2date) and
install the RPMS after applying updates. However, every time a new kernel is
released, I need to re-compile the drivers, so if they were included in the
release kernel, it would be as easy as up2date -uf then reboot, which would be
so convenient.

Thanks for looking into this. I know I am not the only one using the Areca
cards. The people from the CentOS project actually now provide RPMS to install
the areca drivers with their distribution. I know CentOS is a re-compile of the
RHEL SRPMS, so I know it is very possible, but I also understand Red Hat has to
do testing and such, before supporting the hardware. The faster this process is
started, the faster the end user will get it. 

Thanks in advance for any progress you can make towards including the driver.

Diego

-- Additional comment from andriusb@redhat.com on 2007-03-05 13:09 EST --
Diego,

Building and providing the code is the trivial part. We are more interested in
making sure Areca's support channels are 100% committed to RHEL for escalations,
 and that Red Hat has sufficient resources in development/QA to support the cards.

We are in the midst of a dialog with Areca to ensure that they can support the
RHEL platforms for the *entire* life of the product (7+ years).

You are correct though, the code would have to be backported into a future minor
release to make it into base RHEL 4 or RHEL 5.

Specifically for your situation, since you are pretty much self-supported though
in your organization anyway, maybe you could convince Areca to at least
build/provide/support DUDs for RHEL4/RHEL5 and post them on their website to
make your life easier in the meantime? See http://www.kerneldrivers.org/

-- Additional comment from nick.cheng@areca.com.tw on 2007-03-05 22:31 EST --
Dear all,

Thanks for your efforts to care Areca driver.
Areca has signed the NDA and sent off the adapters for RedHat's need.
Areca will continuously support this driver as before without a doubt.

Appreciate your help!!

-- Additional comment from dijuremo@math.gatech.edu on 2007-03-06 07:37 EST --
> Specifically for your situation, since you are pretty much self-supported though
> in your organization anyway, maybe you could convince Areca to at least
> build/provide/support DUDs for RHEL4/RHEL5 and post them on their website to
> make your life easier in the meantime? See http://www.kerneldrivers.org/

Hi,

Like I said, I know how to do this, it is just a pain to have to do it every
time.  I actually even provide a driver disk for RHEL5 Beta1 on the web site:

https://services.ibb.gatech.edu/wiki/index.php/Howto:Software:Areca

However, the initial install is not the only pain, every kernel update means
extra work. So I am really looking forward to this being added to the release
kernels.

Thanks for all your help. I hope the driver can be added soon after passing all
your required tests.
Comment 1 nickcheng 2007-03-20 02:47:18 EDT
No matter what distribution the driver it is on and what version of the
distribution, Areca will continue to maintain and support it.
(In reply to comment #0)
> As the description below and other customers' practical requests, we hope the
> driver could be included in the subsequent Fedora core. It will really benefit
> the customers and contributes the win-win situation.
> Thank you.
>    
> +++ This bug was initially created as a clone of Bug #205897 +++
> 
> Description of problem:
> The arcmsr driver provides support for a line of extremely high performance RAID
> cards. This includes PCI Express SATA controllers.
> 
> Their website is: http://www.areca.us/
> 
> The arcmsr driver has cleared all reviewer hurdles, and now James Bottomley has
> it in his scsi-misc git tree for merge (waiting for 2.6.19 to open).
> 
> As of today, the driver is located at:
> 
> http://kernel.org/pub/linux/kernel/people/jejb/scsi-misc-2.6.diff
> 
> Please include this driver in the RHEL5 kernel.
> 
> BTW, Ubuntu has included this in their kernel since 6.06 LTS.
> 
> -- Additional comment from coughlan@redhat.com on 2006-09-11 09:40 EST --
> RHEL 5 will be based on the 2.6.18 kernel. Unfortunately, this will not include
> the arcmsr driver, and it is too late in the RHEL 5 development schedule to add
> a new driver like this. I will put this on the list for consideration on in 5.1.
> I will also see about getting some hardware here so we can test and support it
> properly. 
> 
> -- Additional comment from dijuremo@math.gatech.edu on 2006-09-28 10:11 EST --
> These cards have been out there for a while already, it is actually irritating
> that Red Hat does not provide support for them. They perform even better than
> any other SATA raid card available in the market. Hacking the install kernel to
> add the drivers is a pain. The least you guys could do is provide a driver disk
> if you are not including the driver in the kernel.
> 
> I currently use these cards in 7 of my servers running RHEL4 and updating a
> kernel is a pain since I also have to go through the extra step of manually
> building and installing the driver.
> 
> There is even a driver disk for CentOS and several kernel rpms as well as an
> srpm provided at http://www.bodgit-n-scarper.com/code.html#centos, so you guys
> really need to step up and include this somehow or provide a download to make it
> easy for the end users to include this cards.
> 
> -- Additional comment from dijuremo@math.gatech.edu on 2006-09-29 13:57 EST --
> Hi Dax and all,
> 
> Here is a driver disk for RHEL5 Beta1 x86_64:
> 
>
https://services.ibb.gatech.edu/wiki/index.php/Howto:Software:Areca#Driver_Disk_for_RHEL5-beta1
> 
> Enjoy,
> 
> Diego
> 
> -- Additional comment from dijuremo@math.gatech.edu on 2007-02-28 07:39 EST --
> The Areca drivers were oficially merged in the 2.6.19 Kernel tree. Should we
> expect a backported patch to the RHEL5 release kernel (2.6.18)?  These cards are
> really very popular and beat the 3ware 95XX series models. The new Areca cards
> based on the IOP341 chipset are extremely fast. I have used the Areca cards with
> RHEL4 for almost two years now and have not had any problems other than the pain
> to install the OS since the drive is not part of the kernel in RHEL4.
> 
> Installing a new machine is sort of a pain and if the driver is now oficially in
> the kernel, then backporting it should be the way to go. I plan to update to
> RHEL5 when it comes out and would really like this driver to be included in the
> kernel if possible.
> 
> -- Additional comment from andriusb@redhat.com on 2007-03-01 01:21 EST --
> Adding Areca... Kevin, does Erich have a Bugzilla account?
> 
> Diego - Red Hat understands your frustration in this matter but we must rely
> heavily on the vendor to provide equal support for any drivers we include in our
> distro. We are in the process of acquiring more information from Areca at this
> time. 
> 
> Although it is quite technically trivial to include a backported patch into
> RHEL, there are a *lot* of other items that must go along with this, which
> include things such as joint support alignment, joint roadmap alignment and
> planning, and most importantly internal QA.
> 
> It's great to hear that the cards Just Work, but Red Hat must make sure all
> bases are covered in case things don't go so smoothly for others. We are looking
> forward to testing this for possible inclusion.
> 
> Stay Tuned! :-)
> 
> -- Additional comment from dijuremo@math.gatech.edu on 2007-03-05 12:45 EST --
> The drivers are now part of the kernel tree in 2.6.19, so I though that would be
> enough assurance that their hardware is supported under linux. Unfortunately, I
> do not have a support contract for my RHEL4 boxes since our campus has a site
> license and we have our own Satelite server with no support, otherwise, I would
> have inquired about Red Hat backporting the drivers earlier for RHEL4. It was
> not until I got the first beta of RHEL5 when I noticed the drivers were not
> there, but that was to be expected, as the driver was not officially accepted
> and released as part of the Linux kernel until 2.6.19.
> 
> However, since the driver is now officially part of the kernel, I would like to
> ask you guys to really consider including a back ported patch on the 2.6.18
> RHEL5 kernels.  Even if it is not right away on RHEL5 release; at least add it
> to the list of things to consider for a possible Update 1 or Update 2 releases
> of RHEL5.
> 
> I know how to create Initrds and manually add the driver to boot from a USB
> keychain from which I boot to then install RHEL over the network. After the
> system is kickstarted, I run up2date in thye %post% section to fully patch the
> system from the sattelite and then I make sure I have the RPMS for the driver
> compiled for the latest kernel (which the system will get from up2date) and
> install the RPMS after applying updates. However, every time a new kernel is
> released, I need to re-compile the drivers, so if they were included in the
> release kernel, it would be as easy as up2date -uf then reboot, which would be
> so convenient.
> 
> Thanks for looking into this. I know I am not the only one using the Areca
> cards. The people from the CentOS project actually now provide RPMS to install
> the areca drivers with their distribution. I know CentOS is a re-compile of the
> RHEL SRPMS, so I know it is very possible, but I also understand Red Hat has to
> do testing and such, before supporting the hardware. The faster this process is
> started, the faster the end user will get it. 
> 
> Thanks in advance for any progress you can make towards including the driver.
> 
> Diego
> 
> -- Additional comment from andriusb@redhat.com on 2007-03-05 13:09 EST --
> Diego,
> 
> Building and providing the code is the trivial part. We are more interested in
> making sure Areca's support channels are 100% committed to RHEL for escalations,
>  and that Red Hat has sufficient resources in development/QA to support the cards.
> 
> We are in the midst of a dialog with Areca to ensure that they can support the
> RHEL platforms for the *entire* life of the product (7+ years).
> 
> You are correct though, the code would have to be backported into a future minor
> release to make it into base RHEL 4 or RHEL 5.
> 
> Specifically for your situation, since you are pretty much self-supported though
> in your organization anyway, maybe you could convince Areca to at least
> build/provide/support DUDs for RHEL4/RHEL5 and post them on their website to
> make your life easier in the meantime? See http://www.kerneldrivers.org/
> 
> -- Additional comment from nick.cheng@areca.com.tw on 2007-03-05 22:31 EST --
> Dear all,
> 
> Thanks for your efforts to care Areca driver.
> Areca has signed the NDA and sent off the adapters for RedHat's need.
> Areca will continuously support this driver as before without a doubt.
> 
> Appreciate your help!!
> 
> -- Additional comment from dijuremo@math.gatech.edu on 2007-03-06 07:37 EST --
> > Specifically for your situation, since you are pretty much self-supported though
> > in your organization anyway, maybe you could convince Areca to at least
> > build/provide/support DUDs for RHEL4/RHEL5 and post them on their website to
> > make your life easier in the meantime? See http://www.kerneldrivers.org/
> 
> Hi,
> 
> Like I said, I know how to do this, it is just a pain to have to do it every
> time.  I actually even provide a driver disk for RHEL5 Beta1 on the web site:
> 
> https://services.ibb.gatech.edu/wiki/index.php/Howto:Software:Areca
> 
> However, the initial install is not the only pain, every kernel update means
> extra work. So I am really looking forward to this being added to the release
> kernels.
> 
> Thanks for all your help. I hope the driver can be added soon after passing all
> your required tests.

Comment 2 Chuck Ebbert 2007-03-20 09:44:22 EDT
The driver is already there:

/lib/modules/2.6.20-1.2925.fc6/kernel/drivers/scsi/arcmsr/arcmsr.ko

It's been in FC 5 and FC 6 since we went to kernel 2.6.19.
Comment 3 nickcheng 2007-03-21 02:20:14 EDT
Hi Chuck,
We knew the Areca driver has been included in the kernel after version 2.6.19.
But are there any chances to backport it to 2.6.18-XXXX.fc5 or .fc6?
When does Redhat expect to issue FC core with kernel 2.6.19-XXXX?
We are afraid there is still quite long time to wait.
Thanks,



Comment 4 nickcheng 2007-03-21 02:23:10 EDT
Hi Chuck,
We knew the Areca driver has been included in the kernel after version 2.6.19.
But are there any chances to backport it to 2.6.18-XXXX.fc5 or .fc6?
When does Redhat expect to issue FC core with kernel 2.6.19-XXXX?
We are afraid there is still quite long time to wait.
Thanks,



Comment 5 Chuck Ebbert 2007-03-21 09:43:26 EDT
It is in the released Fedora kernel for both FC 5 and FC 6:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/i386/kernel-2.6.19-1.2911.fc6.i686.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/i386/kernel-2.6.20-1.2925.fc6.i686.rpm

2.6.18 is no longer even supported on Fedora Core.
Comment 6 nickcheng 2007-03-21 22:29:21 EDT
Ok, I got you.
Because I heard RHEL 5 will stay in kernel 2.6.18-XXXX for 7-year, I though FC
core 5/6 will  stay in kernel 2.6.18-xxxx as well. If I will claim the inclusion
of Areca driver on RHEL3/4, should I open another bug??
Thanks,
Comment 7 Andrius Benokraitis 2007-03-21 22:37:50 EDT
Nick, please refer to the email I sent to you on 20-Mar-7...

"So three Bugzillas, one for RHEL 4, one for RHEL 5, and one for Fedora. There is
already the one created for RHEL 5."

To clarify, the kernel is rebased each time in Fedora, while RHEL is a snapshot
in time, therefore items must be backported from upstream/Fedora.

The driver is in FC 5 and FC 6 because it was included upstream in 2.6.19. RHEL
5, the newest RHEL just announced, is 2.6.18-based and therefore does not have
the driver, since that kernel version is older. In order for the driver to be
included in RHEL 4 and RHEL 5 (sorry, RHEL 3 is out of the question) there needs
to be separate bugzillas entered.
Comment 8 nickcheng 2007-03-22 00:21:06 EDT
Andrius, thank you.

Note You need to log in before you can comment on or make changes to this bug.