Bug 23322 - poweroff fails
poweroff fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Florence Gold
:
Depends On:
Blocks: 24198
  Show dependency treegraph
 
Reported: 2001-01-04 11:16 EST by Michael Redinger
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-14 05:09:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2001-01-04 11:16:49 EST
On a Compaq EXD Deskpro with a Intel 815 mainboard, poweroff fails. It says
that
the system is halted, but doesn't power off. Seems to hang the machine,
normal
power switch doesn't work anymore either (pressing it for some seconds does
the
job as usual - this is really a hard power-off).
Comment 1 giulioo 2001-01-08 03:50:19 EST
Poweroff fails on "Asus P2  (rev1011.A) / i440ZX" too.

I see
...
...
Poweroff.

and it stays on. I have not the power switch problem, though; I can switch it 
off ok with just a quick press (no need to do a 2/3 seconds press or hard power-
off).

Comment 2 Glen Foster 2001-01-11 16:02:41 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 3 Michael K. Johnson 2001-01-19 13:50:08 EST
Because this is APM-related, it could even be related to the BIOS versions
you have.  Have you checked to see if there are BIOS updates for your
machines?
Comment 4 Michael Redinger 2001-01-20 15:27:51 EST
Did check it (and upgraded it to the latest version). Did also try this with
beta2, still the same.

Did some further testing - this bug does occur in 7.0, too. However, after
upgrading to
2.2.19-pre1 (needed the pre1 because of some AGP related stuff) this worked.
Didn't
really note it right then.
Comment 5 Arjan van de Ven 2001-02-14 05:10:28 EST
This is believed to befixed by having READ_MODE_POWEROFF disabled in the 
config of the next Rawhide kernel we build (version 2.4.1-0.1.6 or later).
If these kernels does not fix the problem for you, please reopen this
bug.

Note You need to log in before you can comment on or make changes to this bug.