Bug 24198 - [ACPI] "poweroff" didn't - it rebooted
[ACPI] "poweroff" didn't - it rebooted
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
Florence Gold
:
Depends On: 23322
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-17 00:33 EST by Chris Adams
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 14:50:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2001-01-17 00:33:27 EST
When I run "poweroff" (as root), it does a normal shutdown and then reboots
instead of powering off.  It works in 7.0 (and 6.2).
Comment 1 Bill Nottingham 2001-01-17 12:51:27 EST
SysVinit didn't change how it called poweroff/reboot/etc. Sounds like it's a
kernel problem in the APM support.
Comment 2 Glen Foster 2001-01-17 13:22:04 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 3 Chris Adams 2001-01-17 14:25:16 EST
Hmm...  My main install on this computer is 7.0 (actually
6.9.8, RC2 - I haven't had a chance to upgrade yet).  I do test
installs to a different hard drive.  I've upgraded the 6.9.8
install to kernel 2.4.0-prerelease (again, haven't had a chance
to upgrade to -release), and it powers off on shutdown just
fine.

I'll try to dig some more and see if I can figure out what is
happening.
Comment 4 Michael K. Johnson 2001-01-19 14:24:35 EST
Since we're now based on 2.4.0-ac9, I'll assume that the fix
has been included.  Re-open this bug report if 2.4.0-0.99.5
or later still has this bug.  Thanks!
Comment 5 Chris Adams 2001-01-21 17:29:56 EST
The newer kernel didn't help.

After some recompiles and testing, it appears that the problem is with
the CONFIG_APM_REAL_MODE_POWER_OFF option.  If I recompile the kernel
with the i586 non-SMP config except for turning this option off, I can
power off on "poweroff" just fine.

This is an EpOX EP-MVP3G2 motherboard with the VIA MVP3 chipset and an
AMD K6-III CPU.  I've got the latest BIOS on it from 12/21/2000.
Comment 6 Arjan van de Ven 2001-01-23 05:03:57 EST
CONFIG_APM_REAL_MODE_POWER_OFF works fro about half the machines I've seen,
and doesn't for the others. Unfortionatly, disabling it is no option as there
have been reports of broken bioses doing very evil things in that case.
Comment 7 Stephen Rasku 2001-01-31 03:54:09 EST
I am also seeing this on a Asus K7M motherboard.  7.0 works fine.
Comment 8 Stephen Rasku 2001-02-08 04:05:49 EST
Still happening on beta3.
Comment 9 Arjan van de Ven 2001-02-14 05:08:31 EST
This will be fixed by disabling READ_MODE_POWEROFF in the next
Rawhide kernel we build (version 2.4.1-0.1.6 or later).
If these kernels does not fix the problem for you, please reopen this
bug.

Note You need to log in before you can comment on or make changes to this bug.