Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 23433 - boot.img+CD+ks=floppy installer crashes
boot.img+CD+ks=floppy installer crashes
Status: CLOSED DUPLICATE of bug 19384
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 13:37 EST by vcrump
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 16:37:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vcrump 2001-01-05 13:37:10 EST
Anaconda crashes on kickstart installation.  Updating anaconda (which 
appears to be successful) does not make any difference in the crash or the 
traceback.

Particulars:
RedHat 7.0 boot.img and CD-ROM (from iso download)
ks.cfg created with mkkickstart included on floppy
boot command line: linux ks=floppy OR linux updates ks=floppy

What does work:
same setup but no ks.cfg

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-
7.0.1//usr/lib/anaconda/textw/partitioning_text.py", line 134, in __call__
    todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in 
allowLiloLocationConfig
    if bootDevice[0:2] == "md":
TypeError: unsliceable object

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 820afc8>
self: <lilo.LiloConfiguration instance at 827bf70>
bootDevice: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2001-01-09 16:37:05 EST

*** This bug has been marked as a duplicate of 19384 ***

Note You need to log in before you can comment on or make changes to this bug.