Bug 234345 - should not require openjade
should not require openjade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
: Reopened
: 449954 (view as bug list)
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-03-28 12:27 EDT by Matthias Clasen
Modified: 2009-02-18 23:04 EST (History)
2 users (show)

See Also:
Fixed In Version: docbook-dtds-1.0-41.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 09:20:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2007-03-28 12:27:36 EDT
While looking for space to save on the live cd, I noticed that
docbook-dtds requires openjade, which in turn pulls in opensp.

Is that really necessary ? I mean docbook-dtds is just a bunch of
data files, really...
Comment 1 Tim Waugh 2007-03-29 05:29:12 EDT
It needs to register them in the openjade catalog.
Comment 2 Matthias Clasen 2007-03-29 09:52:02 EDT
If openjade is not installed, there is no openjade catalog. Seems silly to
require openjade just to have the catalog in place so that you can register the
dtds in it.

How about openjade %post does that instead ?
Comment 3 Ondrej Vasik 2008-02-08 18:46:35 EST
I'm not sure if you are still searching space on live cd this way, but maybe
suitable solution could be to use %triggerin -- openjade . Anyway - I see in
spec file "## Clean up pre-docbook-dtds mess caused by broken trigger" - so it
will need some testing before doing that change. 
Comment 4 Bug Zapper 2008-05-13 22:42:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Ondrej Vasik 2008-06-04 09:56:35 EDT
*** Bug 449954 has been marked as a duplicate of this bug. ***
Comment 6 Ondrej Vasik 2008-06-05 07:10:14 EDT
To keep discussion here - moved from #449954:
Comment #2 From Jeremy Katz (katzj@redhat.com)  	 on 2008-06-04 11:42 EST  

Requires(post) doesn't help as it still gets pulled in for it.  A trigger might,
but triggers are very tricky to get right.  

A simple fix might be checking if the openjade catalog is there and registering
with it if so, else just leaving it for the openjade %post to later pick up


Comment #3 From Ondrej Vasik (ovasik@redhat.com) 	on 2008-06-05 07:08 EST 	

As I maintain both packages, I will think about that solution - although I would
say trigger in docbook-dtds is slightly better (as the goal is to register
openjade catalogs in docbook-dtds catalogs - and it has almost nothing to do
with openjade package). 

So we have three ways now:
1) Keep it as it is - will save no space on LiveCD
2) triggerin openjade in docbook-dtds - will save space on LiveCD (as openjade
catalogs will be not registered when no openjade available), a bit tricky to
have it running correctly, but it is not affecting other packages
3) move registration to openjade - will save space on LiveCD - but could cause
troubles in some situation (e.g. if you install openjade first, it will not be
registered in docbook-dtds - which could cause some troubles). So registration
has to be doubled (done in both - openjade and docbook-dtds %post - just for
cases that the second package is already installed - that's almost as tricky as
the trigger solution and affects both packages as they have to be synchronized.

I like the trigger solution, as this affects only one package and will have
minimal impact if properly written. But as you said, it could easily be broken
and has to be tested before applying to Fedora (definitely not to F9 or lower to
not break stable release).
Comment 7 Matthias Clasen 2008-09-24 13:33:54 EDT
We should really get this fixed for F10. This is forcing openjade on the the live cd for no good reason, where we have no space at all for this kind of dead baggage.

Please ?
Comment 8 Ondrej Vasik 2008-09-24 14:42:34 EDT
Ok, I'll try to do it by trigger ... there is already request to remove perl dependency because of FedoraMini, so hopefully we could get rid off both space-eating dependencies.
Comment 9 Ondrej Vasik 2008-09-25 09:20:59 EDT
Ok, done by triggers and built as docbook-dtds-1.0-41.fc10, hopefully it will work as expected and will not break (m)any thing(s) ...Checked with/without installed openjade, removed openjade, updated openjade... so I guess it will be ok... Closing RAWHIDE.
Comment 10 Matthias Clasen 2008-09-25 10:59:20 EDT
Cool, thanks
Comment 11 Tom Lane 2009-02-18 23:04:51 EST
This solution didn't actually work, see bug #486257

Note You need to log in before you can comment on or make changes to this bug.