Bug 449954 - no real dependency on openjade?
no real dependency on openjade?
Status: CLOSED DUPLICATE of bug 234345
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 09:40 EDT by Jeremy Katz
Modified: 2008-06-05 07:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 09:56:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-06-04 09:40:09 EDT
rawhide's yelp adds a dependency on docbook-dtds which significantly increases
its footprint due to the depchain of docbook-dtds.  From a quick look, I can't
see any real reason why openjade would be required by docbook-dtds and snipping
the dep would help keep the livecd size under control
Comment 1 Ondrej Vasik 2008-06-04 09:56:34 EDT
Thanks for report, discussed in the past in #234345. I would say triggerin would
be good solution (or at least change to Requires(post): openjade)

*** This bug has been marked as a duplicate of 234345 ***
Comment 2 Jeremy Katz 2008-06-04 11:42:33 EDT
Requires(post) doesn't help as it still gets pulled in for it.  A trigger might,
but triggers are very tricky to get right.  

A simple fix might be checking if the openjade catalog is there and registering
with it if so, else just leaving it for the openjade %post to later pick up
Comment 3 Ondrej Vasik 2008-06-05 07:08:46 EDT
As I maintain both packages, I will think about that solution - although I would
say trigger in docbook-dtds is slightly better (as the goal is to register
openjade catalogs in docbook-dtds catalogs - and it has almost nothing to do
with openjade package). 

So we have three ways now:
1) Keep it as it is - will save no space on LiveCD
2) triggerin openjade in docbook-dtds - will save space on LiveCD (as openjade
catalogs will be not registered when no openjade available), a bit tricky to
have it running correctly, but it is not affecting other packages
3) move registration to openjade - will save space on LiveCD - but could cause
troubles in some situation (e.g. if you install openjade first, it will not be
registered in docbook-dtds - which could cause some troubles). So registration
has to be doubled (done in both - openjade and docbook-dtds %post - just for
cases that the second package is already installed - that's almost as tricky as
the trigger solution and affects both packages as they have to be synchronized.

I like the trigger solution, as this affects only one package and will have
minimal impact if properly written. But as you said, it could easily be broken
and has to be tested before applying to Fedora (definitely not to F9 or lower to
not break stable release).

Note You need to log in before you can comment on or make changes to this bug.