Bug 23439 - install fails to start properly on IBM Thinkpad T20
install fails to start properly on IBM Thinkpad T20
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence Beta-3
:
: 23655 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 14:52 EST by David Lawrence
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 16:18:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2001-01-05 14:52:58 EST
Video chipset: S3 Savage IX Mobility (requires S3 download for native X
support)

Produces traceback when loading second stage installer and not typing any
additional options at syslinux boot prompt:

going to test the x server
File "/var/tmp/anaconda-7.1//usr/lib/anaconda/xserver.py", line 133, in
testx
server = x.test ([':1', 'vt7', '-s', '1440', '-terminate'], spawn=1)
File "/var/tmp/anaconda-7.1//usr/lib/anaconda/xf86config.py", line 1020, in
test
serverpath = "/usr/X11R6/bin/" + self.server
TypeError: illegal argument type for built-in operation


tested the x server
Waiting for the X server to start
File "/usr/bin/anaconda", line 279, in ?
result = xserver.startX (runres)
File "/usr/lib/anaconda/xserver.py", line 125, in startX
testx(mouse, x)
File "/usr/lib/anaconda/xserver.py", line 156, in testx
pid, status = os.waitpid (server, os.WNOHANG)
NameError: server

and then install exits abnormally

Never attempts to run text mode install.

Note: Graphical installer comes up properly if you give vga= line at boot
prompt such as

boot:  linux vga=791
Comment 1 Michael Fulbright 2001-01-09 16:18:01 EST
Assigned to developer.
Comment 2 Brent Fox 2001-01-10 13:52:48 EST
*** Bug 23655 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fox 2001-01-10 14:30:09 EST
*** Bug 23655 has been marked as a duplicate of this bug. ***
Comment 4 Glen Foster 2001-01-11 16:12:22 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 5 Brent Fox 2001-01-12 13:30:24 EST
vga=791 will force the card into 16 bit color at 1024x768.  It appears that the
card won't work in any other framebuffer mode except this.  The installer tries
to put the card into 16 bit color 800x600 resolution, and it seems like the card
and the installer collide and the installer loses.
Comment 6 Brent Fox 2001-01-18 19:34:44 EST
There are two problems.  One is that the installer shouldn't traceback in this
manner.  This is caused by self.server being empty.  Dr. Mike added code to
check for this, so this issue should be fixed.  Will test tomorrow on the
laptop.  

Issue two is why is self.server empty?  It's because the card isn't in the
pcitable or the Cards database.  We will add this card to the lists so that the
card can be correctly identified.  Will do this tomorrow.
Comment 7 Brent Fox 2001-01-19 16:17:59 EST
Both items should be fixed now.  We've inserted code to fall back to text mode
gracefully if the card can't be detected.  Also, we've updated the card database
so that this card will be detected in the future.  Thanks for this report.

Note You need to log in before you can comment on or make changes to this bug.