Bug 234618 - wpa psk - association request to the driver failed
wpa psk - association request to the driver failed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-30 12:23 EDT by das_deniz
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 16:44:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog for attempt to use NetworkManager to select SSID (11.90 KB, text/plain)
2007-04-23 18:11 EDT, das_deniz
no flags Details
another attempt with SELinux Permissive at boot (rebooted) (29.19 KB, text/plain)
2007-04-23 18:25 EDT, das_deniz
no flags Details

  None (edit)
Description das_deniz 2007-03-30 12:23:42 EDT
Description of problem:

trying to use wpa_supplicant-gui to get networking w/ wireless + WPA
can't seem to find the right combination of parts yet - NetworkManager doesn't
have a dialog for WPA (just WEP or LEAP (802.1x or WPA-EAP))

so, with iwlwifi-firmware loaded, NetworkManager, and wpa_supplicant running I
launch the wpa_supplicant-gui - it scans and finds my ssid and shows that
WPA-PSK and WPA-PSK2 are supported.  But when I provide the key and try to
connect I get the 'subject line' message

  Trying to associate with <MAC> (SSID='<mine>'freq=2447MHz)
  Association request to the driver failed
  Authentication with 00:00:00:00:00:00 timed out.

Note that <MAC> *is* the mac address of my LAN wireless access point but that
the auth timed out msg is all zeros.

Version-Release number of selected component (if applicable):

> rpm -qa NetworkMan\*
NetworkManager-0.6.5-0.6.svn2474.fc7
NetworkManager-glib-0.6.5-0.6.svn2474.fc7
NetworkManager-glib-0.6.5-0.6.svn2474.fc7
NetworkManager-openvpn-0.3.2-7.fc6
NetworkManager-gnome-0.6.5-0.6.svn2474.fc7
NetworkManager-vpnc-0.6.4-3.fc7
> rpm -qa wpa\*
wpa_supplicant-0.5.7-1.fc7
wpa_supplicant-gui-0.5.7-1.fc7
> rpm -qa iwl\*
iwlwifi-firmware-2.14.1-4

Linux hostname 2.6.20-1.3025.fc7 #1 SMP Wed Mar 28 20:09:47 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux

How reproducible:

always.

Steps to Reproduce:
1. laptop with intel 3945 - and iwlwifi-firmware
2. service NetworkManager running
3. service wpa_supplicant running
4. wireless access point running WPA-PSK or WPA-PSK2
5. wpa_supplicant-gui
6. File -> Add Network
7. fill in dialog (SSID name, AUTHENTICATION WPA-PSK, ENCRYPTION (either), PSK
passphrase/key) click 'Add'
8. select the new network in the Network: drop box
9. click 'Connect'

  
Actual results:

error msg in subject line shows up in "Last message:" line and File -> Event log

Expected results:

Authenticate, DHCP, and /. and google till i drop.

Additional info:

NetworkManager "Wireless Network Key Required" dialog does not pop-up in the
forground for me... (behind other open applications)... but i suppose that's a
different bug.
Comment 1 Dan Williams 2007-03-30 15:13:56 EDT
Can you do an 'iwlist eth0 scan" (and replace eth0 with the name of your wifi
interface) and paste the entire entry for your access point here?
Comment 2 das_deniz 2007-03-30 15:23:48 EDT
wlan0     Scan completed :
          Cell 01 - Address: 00:17:9A:2F:0B:73
                    ESSID:"home802dot11n"
                    Mode:Master
                    Frequency:2.447 GHz
                    Signal level=-36 dBm  
                    Encryption key:on
                   
Extra:wpa_ie=dd1a0050f20101000050f20202000050f2020050f20401000050f202
                   
Extra:rsn_ie=30180100000fac020200000fac02000fac040100000fac020000
                    Extra:tsf=0000030da8474a84
                    Extra:bcn_int=100
                    Extra:rssi=-36
                    Extra:capab=0x0431
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
Comment 3 Dan Williams 2007-03-30 15:32:03 EDT
Driver is broken; which is why NetworkManager does not recognize the AP as
wpa-capable.  It needs to use the GENIE element when returning scan results, not
a custom "extra" element.
Comment 4 Dan Williams 2007-03-30 15:37:01 EDT
john; odd here but I thought mac80211 was doing the right thing WRT scan result
handling.  The handler for SIOCGIWSCAN that converts the internal mac80211 BSS
structure into the WEXT event stream should be using the GENIE element, like
airo and libertas do...  the output above suggests that at least that verison of
iwlwifi or mac80211 isn't doing that.
Comment 5 Dan Williams 2007-03-31 13:52:19 EDT
Verified (and posted to linux-wireless) that mac80211 in wireless-dev doesn't
use IWEVGENIE when returning scan results, like every other WPA-enabled driver
including ieee80211-based ones, hostap, prism54, airo, libertas,
ieee80211_softmac, etc.  mac80211 needs to do that rather than use custom events.
Comment 6 John W. Linville 2007-04-09 17:00:39 EDT
Please try the test kernels here:

   http://people.redhat.com/linville/kernels/fc7/

Do these work any better for you?
Comment 7 das_deniz 2007-04-10 16:12:55 EDT
doesn't seem to. i had to reinstall f7 from t2 and update so things have changed:

rpm -qa NetworkManager\*
NetworkManager-gnome-0.6.5-0.7.svn2547.fc7.x86_64
NetworkManager-0.6.5-0.7.svn2547.fc7.x86_64
NetworkManager-glib-0.6.5-0.7.svn2547.fc7.x86_64
NetworkManager-glib-0.6.5-0.7.svn2547.fc7.i386
NetworkManager-0.6.5-0.7.svn2547.fc7.i386

rpm -qa wpa\*
wpa_supplicant-gui-0.5.7-2.fc7.x86_64
wpa_supplicant-0.5.7-2.fc7.x86_64

rpm -qa iwl\*
iwlwifi-firmware-2.14.1-4.noarch

2.6.20-1.3048.2.1.fc7.jwltest.7 #1 SMP Thu Apr 5 17:47:09 EDT 2007 x86_64 x86_64
x86_64 GNU/Linux

NetworkManager failed to start
/usr/sbin/NetworkManager: error while loading shared libraries: libhal.so.1:
cannot open shared object file: No such file or directory
had to install hal-devel

wpa_gui still says "Association request to the driver failed"

and i get this alot in /var/log/messages:

[root@localhost ~]#  Apr 10 15:44:53  iditarod kernel: iwlwifi: TODO: Look into
long/short preamble change handling.

the iwlist does look better :)

iwlist wlan0 scan
Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

wlan0     Scan completed :
          Cell 01 - Address: 00:17:9A:2F:0B:73
                    ESSID:"home802dot11n"
                    Mode:Master
                    Frequency:2.447 GHz
                    Signal level=-31 dBm  
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP 
                        Pairwise Ciphers (2) : TKIP CCMP 
                        Authentication Suites (1) : PSK  
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP 
                        Pairwise Ciphers (2) : TKIP CCMP 
                        Authentication Suites (1) : PSK  
                    Extra:tsf=000003eb0a64bc98
                    Extra:bcn_int=100
                    Extra:rssi=-31
                    Extra:capab=0x0431
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
Comment 8 das_deniz 2007-04-10 16:28:12 EDT
Oh no... all that because i missed the NetworkManager passphrase dialog (it
comes up in the background behind all open windows :(

I tried it again and when i found the dialog NetworkManager asks for a proper
WPA personal TPIK passphrase - YEA!!!

It then proceeds to connect and DHCP properly - *BUT* I am unable to ping or
connect ... and the iwlwifi msg i mentioned in the earlier post is seen over and
over....
(yes /etc/resolv.conf is correct)

sooo close....
Comment 9 das_deniz 2007-04-23 18:11:05 EDT
Created attachment 153321 [details]
syslog for attempt to use NetworkManager to select SSID

hoping to help get this right for f7 test4 -  prompting for allowable password
now works... but SELinux seems to be in the way. 

Still, even if I use thee system-config-selinux python app and set the "current
enforcing mode" to "Permissive" and get an IP via DHCP ... and have
NetworkManager report that "Connected - You are now connected to the wireless
network "ssid"" I cannot ping anything in the local network or via the default
route/gateway.

Interface status looked good (had IP via DHCP, was UP) and the netstat -rn
output looked good and so did /etc/resolv.conf	... But the wireless indicator
on my laptop never lit-up and I was not able to ping local or remote devices.
Comment 10 das_deniz 2007-04-23 18:25:52 EDT
Created attachment 153323 [details]
another attempt with SELinux Permissive at boot (rebooted)
Comment 11 das_deniz 2007-04-23 18:28:41 EDT

iwlwifi: Error clearing ASSOC_MSK on current configuration (-110).
iwlwifi: Error sending RXON: time out after 500ms.
iwlwifi: Error clearing ASSOC_MSK on current configuration (-110).
iwlwifi: Error sending RXON: time out after 500ms.
iwlwifi: Error clearing ASSOC_MSK on current configuration (-110).
iwlwifi: No space for Tx
iwlwifi: Error sending RXON: ipw_queue_tx_hcmd failed: -28
iwlwifi: Error clearing ASSOC_MSK on current configuration (-28).
Comment 12 John W. Linville 2007-05-02 16:28:19 EDT
Please try the 3122 or later kernels -- is this problem still there?
Comment 13 das_deniz 2007-05-02 16:58:06 EDT
john,

running davej kernel 2.6.21-1.3125 and i *can* get 9345 wirelss working by
invoking 'wpa_supplicant -iwlan0 -cwpa.conf -d -B' and then 'dhclient wlan0'

however - at startup if eth0 is unpluged (link down) the module is never loaded
and the wmaster0 reports SIOCSIFFLAGS: Operation not supported.

so if NetworkManager and wpa_supplicant are running (not in the 'by hand' case
above) there are two issues:

  1) doesn't detect link change on eth0 and bring that interface up
  2) iwlist wlan0 scan - segfaults (bug 238657)

so... i'm not sure if any of this falls into the domain of the original bug or not.

thank you for looking into this.
Comment 14 das_deniz 2007-05-02 17:07:27 EDT
even with NetworkManager and wpa_supplicant services off and the ethernet link
plugged in (after having it unplugged at boot time) - restarting networking
'/etc/init.d/network restart' doesn't bring the e1000 interface to life... ugh.
Comment 15 John W. Linville 2007-06-07 16:44:07 EDT
Looks like bug 238567 was resolved, and comment 13 suggests that things were 
working as far as the driver is/was concerned.  If you are still having 
NetworkManager or e1000 problems, please open new bugs specific to those 
issues...thanks!

Note You need to log in before you can comment on or make changes to this bug.