Bug 234661 - SAS tape drive does not show up in the test plan.
Summary: SAS tape drive does not show up in the test plan.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: YangKun
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-30 20:54 UTC by Keith Orsak
Modified: 2008-07-16 21:57 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-04-28 08:01:54 UTC


Attachments (Terms of Use)
dmesg (38.12 KB, application/octet-stream)
2007-04-25 06:45 UTC, YangKun
no flags Details
hal.log (103.60 KB, text/plain)
2007-04-25 06:48 UTC, YangKun
no flags Details
hwconf (12.98 KB, application/octet-stream)
2007-04-25 06:48 UTC, YangKun
no flags Details
plan.xml (1.44 KB, text/xml)
2007-04-25 06:49 UTC, YangKun
no flags Details
sysreport (578.64 KB, application/x-bzip2)
2007-04-26 06:58 UTC, YangKun
no flags Details
proc-tree.log (245.68 KB, text/plain)
2007-04-26 07:01 UTC, YangKun
no flags Details
sys-tree.log (141.52 KB, text/plain)
2007-04-26 07:01 UTC, YangKun
no flags Details

Description Keith Orsak 2007-03-30 20:54:35 UTC
Description of problem:
After setting up a test plan for hts the SAS tape drive does not show up in 
the test plan.

Version-Release number of selected component (if applicable): R32


How reproducible:
Every time.

Steps to Reproduce:
1. Install HTS.
2. Power down server.
3. Plug in a SAS tape drive into the server ( I used a HP Ultrium LTO 448 SAS )
4. Turn on the tape drive and insert a tape.
5. Turn the server back on and boot to RHEL 5.
6. Open up a terminal and type:
->hts server start
->hts plan
->hts print --report plan
  
Actual results:
The tape drive did not show up in the list of devices to test in the test plan.

Expected results:
I expected the tape drive to show up.

Additional info:
I was testing on a DL380 G5 server with RHEL 5 X86_64 installed.  I also tried 
to use the "lshal | grep info.udi" command to find the udi but could not 
determine the correct udi.

Comment 1 YangKun 2007-04-09 13:57:04 UTC
please run "hal-device > hal.log", and attach the file "hal.log" here, please
also attach following three files here:
  1) "/etc/sysconfig/hwconf"
  2) "/var/log/dmesg"
  3) "/var/hts/plan.xml"

Thanks

Comment 2 YangKun 2007-04-25 06:45:45 UTC
Created attachment 153397 [details]
dmesg

Comment 3 YangKun 2007-04-25 06:48:04 UTC
Created attachment 153398 [details]
hal.log

Comment 4 YangKun 2007-04-25 06:48:38 UTC
Created attachment 153399 [details]
hwconf

Comment 5 YangKun 2007-04-25 06:49:17 UTC
Created attachment 153400 [details]
plan.xml

Comment 6 YangKun 2007-04-25 07:13:34 UTC
Hi Keith,

I checked the attached 4 files. Both kudzu and HAL can not find any TAPE device.
And I can not find it in dmesg neither. This is strange.

Could you please provide more info as following:
  1) make sure the SAS tape drive is well connected before the system boots;
  2) boot the system, after the system booted, run following commands as root:
      a) # echo ^M | sysreport
      b) # tree /proc/ > /root/proc-tree.log
      c) # tree /sys/ > /root/sys-tree.log
  3) attach three files: "/root/*.tar.bz2" and "/root/proc-tree.log" and
"/root/sys-tree.log" here.

Thanks

Comment 7 YangKun 2007-04-26 06:58:26 UTC
Created attachment 153481 [details]
sysreport

Comment 8 YangKun 2007-04-26 07:01:02 UTC
Created attachment 153482 [details]
proc-tree.log

Comment 9 YangKun 2007-04-26 07:01:38 UTC
Created attachment 153483 [details]
sys-tree.log

Comment 10 YangKun 2007-04-26 07:56:59 UTC
Hi Keith,

I didn't see any tape-related device driver been loaded into kernel.

Can you confirm if this SAS tape drive(HP Ultrium LTO 448 SAS) works well under
RHEL5 ?  Is there a proper device name for this tape drive under "/dev/"
directory ? If yes, could you manually run following command to verify if it works:
    #  mt -f /dev/DEVICE_NAME rewind

Thanks

Comment 11 Keith Orsak 2007-04-27 21:18:14 UTC
The HBA I used to plug the tape drive into the server did not have a driver 
installed.  I used a Sputnik SAS card instead and it worked fine.

-Keith

Comment 12 YangKun 2007-04-28 08:01:01 UTC
That's great. 

Closing this bug now.


Note You need to log in before you can comment on or make changes to this bug.