Bug 23475 - fix to 1.6 to make -I,-X consistent with local filenames (%escapes)
fix to 1.6 to make -I,-X consistent with local filenames (%escapes)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: wget (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-06 01:54 EST by j. alan eldridge
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-06 01:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to unescape %xx in paths before fnmatch compares them (2.41 KB, patch)
2001-01-06 01:56 EST, j. alan eldridge
no flags Details | Diff

  None (edit)
Description j. alan eldridge 2001-01-06 01:54:34 EST
this patch may backport to 1.5.3 ok.

the -I and -X options give lists of directories to include/exclude from a
recursive suck. there's an inconsistency in the way they are handled in
case the path has funky characters.

e.g., the dir /wow/neat%20stuff will be created with a literal %20 in the
name (not a space).  however, in the -I or -X list, to include or exclude
that dir, you would have to say: /wow/net\ stuff (with an escaped space, or
quoted, or whatever gets it through the shell for you) in order for that
directory to be recognized. this is, well, kinda stupid.

attachment follows which patches the fnmatch function to unescape both
strings before comparing, thus giving consistent behavior. since fnmatch is
used pervasively, this probably fixes a number of other inconsistencies as
well.

patch sent to wget maintainers as well.
Comment 1 j. alan eldridge 2001-01-06 01:56:40 EST
Created attachment 7125 [details]
patch to unescape %xx in paths before fnmatch compares them
Comment 2 Bill Nottingham 2001-01-06 17:13:05 EST
Will be fixed in 1.6-1, which will be in the next rawhide release.
Thanks for the patch!

Note You need to log in before you can comment on or make changes to this bug.