Bug 234778 - config.(guess|sub) files are outdated
config.(guess|sub) files are outdated
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
:
: 173351 (view as bug list)
Depends On:
Blocks: 211069
  Show dependency treegraph
 
Reported: 2007-04-01 18:18 EDT by David Zeuthen
Modified: 2013-03-05 22:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 02:51:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2007-04-01 18:18:45 EDT
Debian tells me that the config.(guess|sub) files shipped with Fedora's libtool
are outdated and that tarballs created by me (on Fedora) makes lintian (a Debian
package checker) complain about them. Any chance these files can be updated? Thanks!

For the record, I'm using libtool-1.5.22-10.fc7

2007/4/1, David Zeuthen <david@fubar.dk>:
> On Sun, 2007-04-01 at 20:30 +0200, Michael Biebl wrote:
> > rc3 still has the same problem. lintian (a Debian package checker) complains:
> > # lintian /home/michael/debian/build-area/hal_0.5.9~rc3-1_i386.changes
> > E: hal source: outdated-autotools-helper-file config.sub 2003-06-18
> > E: hal source: outdated-autotools-helper-file config.guess 2003-06-17
> >
> > config.guess/config.sub is usually shipped by libtool, so you should
> > check this package first.
>
> Mmm.. I'm using
>
>  $ rpm -q libtool
>  libtool-1.5.22-10.fc7
>
> which I *think* is pretty recent not only because of the fact that I
> think that the upstream libtool guy works for Red Hat. What version are
> you using?
>

I just checked the fc7 package (by downloading [1]) and the
config.(guess|sub) files are indeed outdated. You should file a bug
report against the Fedora libtool package so that they ship more
recent versions of these files.


Cheers,
Michael

[1]ftp://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/os/Fedora/libtool-1.5.22-10.fc7.i386.rpm
Comment 1 Karsten Hopp 2007-04-05 09:34:55 EDT
redhat-rpm-config is to blame here. redhat-rpm-config still ships those ancient
config.{guess,sub} files and copies them into the root of any package that uses
%configure in the spec file.

JCM, how about an update of those files ? Those from the latest automake should
do, you just have to check for any RH specific patches in the old files.

I'll patch libtool.spec in the meantime to avoid %configure 

Comment 2 Karsten Hopp 2007-04-05 10:39:01 EDT
fixed in libtool-1.5.22-11.fc7
Comment 3 Jeremy Katz 2007-06-19 14:32:49 EDT
*** Bug 173351 has been marked as a duplicate of this bug. ***
Comment 4 Jon Masters 2007-08-20 02:09:18 EDT
Ok. I will update the files. Apologies for the delay.

Jon.

Note You need to log in before you can comment on or make changes to this bug.