Bug 23497 - [PATCH] Move some rc.sysinit functionality into SysV style scripts
Summary: [PATCH] Move some rc.sysinit functionality into SysV style scripts
Status: CLOSED DUPLICATE of bug 67681
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 14672
TreeView+ depends on / blocked
 
Reported: 2001-01-07 02:10 UTC by Andrew Bartlett
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 19:16:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to move parts of rc.local into SysV subsystems (8.03 KB, patch)
2001-01-07 02:13 UTC, Andrew Bartlett
no flags Details | Diff

Description Andrew Bartlett 2001-01-07 02:10:55 UTC
I think that rc.sysinit is too big, it does many things that could be done
early (or late) in the normal boot sequence.  It also does some things that
can lock a machine (loading sound modules) that would make recovering with
single user impossible.  Attached is a prelimarly patch that moves the
kernel /boot stuff into an early part of the SysV init, and the sound
drivers into a later part, also saving the sound driver settings at service
shutdown (rather than in rc.halt).  

The patch needs a cleanup, a sainity check (I don't have sound in my test
machine yet), and symlinks etc need to be added, but this gives you a
start.

This is similar to bug 14672 and I hope that both can find there way into a
future initscripts release.

Comment 1 Andrew Bartlett 2001-01-07 02:13:50 UTC
Created attachment 7163 [details]
Patch to move parts of rc.local into SysV subsystems

Comment 2 Andrew Bartlett 2001-01-07 03:53:25 UTC
Sorry, that patch is for rc.sysinit not rc.local

Comment 3 Bill Nottingham 2005-04-28 19:16:47 UTC

*** This bug has been marked as a duplicate of 67681 ***


Note You need to log in before you can comment on or make changes to this bug.