Bug 67681 - [RFE] Break rc.sysinit into rc.sysinit.d/* scripts
[RFE] Break rc.sysinit into rc.sysinit.d/* scripts
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
: 23497 427857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-28 22:06 EDT by Robin Holt
Modified: 2014-03-16 22:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-06 17:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against the cvs sources (57.27 KB, patch)
2002-06-28 22:12 EDT, Robin Holt
no flags Details | Diff

  None (edit)
Description Robin Holt 2002-06-28 22:06:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
This is an RFE to follow up on the redhat-devel-lists' discussion
of breaking the rc.sysinit script into a series of scripts under
the rc.sysinit.d directory.

The rc.sysinit script sources all the files in the rc.sysinit.d
directory in order.  This is necessary to carry environment settings
from one script to the next.

Version-Release number of selected component (if applicable):



Additional info:
Comment 1 Robin Holt 2002-06-28 22:12:01 EDT
Created attachment 63125 [details]
Patch against the cvs sources
Comment 2 Bill Nottingham 2005-04-28 15:17:00 EDT
*** Bug 23497 has been marked as a duplicate of this bug. ***
Comment 3 Russell Coker 2006-08-09 01:35:19 EDT
Currently the EMC PowerPath drivers insert a few lines in the rc.sysinit file to
start the powerpath system before filesystems are mounted.  If there was a
rc.sysinit.d directory then a powerpath script could be dropped in at the
appropriate point to conveniently provide this functionality without breaking
systems on upgrade.

NB  PowerPath is only supported on RHEL, please regard this as a future feature
request for RHEL5.
Comment 4 Bill Nottingham 2006-08-09 11:45:16 EDT
Anything device related (like powerpath) should probably be done via udev rules.
Comment 5 Jeff Pitman 2007-01-03 12:43:41 EST
Ping. We really need this. Is there any other rework in progress along these lines?
Comment 6 Till Maas 2007-06-28 13:28:29 EDT
Bill, would you accept a new patch or don't you want this feature at all? This
bug is now open around 5 years, so when you do not want it, why don't you close
it? But I would like to have this very much to make it easier to apply own
changes to the initscript.
Comment 7 Bill Nottingham 2007-09-18 15:13:24 EDT
The issue is that it really needs to be done so that services are at least
somewhat configurable with chkconfig, etc. Which makes it a larger change (esp.
as that could then break system-config-services.) Moreover, it's unknown how
much use this becomes if we do change init systems in the future.
Comment 8 Bill Nottingham 2008-01-07 16:46:58 EST
*** Bug 427857 has been marked as a duplicate of this bug. ***
Comment 9 Jon Stanley 2008-04-23 16:30:41 EDT
Adding FutureFeature keyword to RFE's.
Comment 10 Bill Nottingham 2009-10-06 17:06:24 EDT
Obviously, this bug is very old. Realistically, as this has not happened by now, it is not going to happen until we move rc.sysinit to be upstart-based, likely in the F13 or F14 timeframe. Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.