Bug 235114 - having face browser at 800x600 is desirable
having face browser at 800x600 is desirable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 235118 238295 (view as bug list)
Depends On:
Blocks: FC7Target FC7Blocker Fedora7LiveCD
  Show dependency treegraph
 
Reported: 2007-04-03 15:54 EDT by Jeremy Katz
Modified: 2013-03-05 22:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 19:49:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-04-03 15:54:53 EDT
Having the face browser only available at > 800x600 means that we don't have the
feature on a substantial amount of virtual machines.  Which, when coupled with
the live CD, leads to a less than ideal experience where people are going to be
a little confounded with the login prompt.

We really need to be able to select the user so that other important things such
as language can be selected at login time.
Comment 1 Jeremy Katz 2007-04-03 16:09:42 EDT
*** Bug 235118 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Clasen 2007-04-03 19:53:14 EDT
David, didn't we discuss doing a face browser with a reduced number of visible
rows for small screens ?
Comment 3 David Zeuthen 2007-04-03 19:55:49 EDT
(In reply to comment #2)
> David, didn't we discuss doing a face browser with a reduced number of visible
> rows for small screens ?

Yes we did.
Comment 4 David Zeuthen 2007-04-28 15:44:57 EDT
Reassigning to gdm and moving from FC7Target to FC7Blocker: We need to fix this
for Fedora 7.

(Also, we should disable root login on the live cd entirely because some people
just type 'root' without realizing they just have to click the icon. This can
probably be done in gdm too so people can still login on VT1-VT6. We should most
probably do it for non-livecd use cases too. People who want to shoot themselves
in the foot by running X as root can use 'startx'.)
Comment 5 Per Bothner 2007-04-28 15:56:01 EDT
Why are people being asked to log into a LiveCD in the first place?
I found it confusing, and I'm hardly a newbie.  (MCC Linux, anyone?)
At least have a "Will log in as user fedora in 20 seconds" timer.
Comment 6 David Zeuthen 2007-04-28 20:30:20 EDT
(In reply to comment #5)
> Why are people being asked to log into a LiveCD in the first place?
> I found it confusing, and I'm hardly a newbie.  (MCC Linux, anyone?)
> At least have a "Will log in as user fedora in 20 seconds" timer.

We show the login screen so the user can a) select their language of choice; b)
start Assistive Technologies (e.g. ctrl+s for one second to start the
screenreader); and in the future c) select their keyboard layout of choice. 

(Before you suggest that this should be done in the bootloader as some other
distros do... then keep in mind that the bootloader 1) is constrained wrt. to
fonts; 2) is not accessible.)

Comment 7 David Zeuthen 2007-04-28 20:33:37 EDT
*** Bug 238295 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2007-04-29 18:59:07 EDT
I agree with comment 5 (and I've suggested it and talked about it with David and
Matthias before).  For the livecd, we should be using timed login.  That's a
livecd specific change though.  

Making the user list show less users is a a theme issue.  It shouldn't be hard
coding a pixel height but instead should be using percentages.  If it's too hard
to rework the theme to use percentages by the final release then we should ship
a separate livecd theme, which is the easier solution.

Root login is a separate issue, and there is a separate bug for it (although I
don't know the number off the top of my head).

Moving back to redhat-artwork.

Comment 9 Ray Strode [halfline] 2007-04-30 10:30:40 EDT
So I apparently didn't move it back to redhat-artwork last night.

Anyway, I'll have a look.
Comment 10 Matthias Clasen 2007-05-08 19:49:39 EDT
should be built and tagged

Note You need to log in before you can comment on or make changes to this bug.