Bug 235128 - hal pkgs conflict update failure fedora7test3
hal pkgs conflict update failure fedora7test3
Status: CLOSED DUPLICATE of bug 235152
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-03 16:47 EDT by dean owensby
Modified: 2013-03-05 22:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-08 19:08:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dean owensby 2007-04-03 16:47:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.3) Gecko/20070325 Firefox/2.0.0.3

Description of problem:
The program runs until either pup or yum update hits transaction testing. then freezes and gives error notification (log output below)

Version-Release number of selected component (if applicable):
hal-0.5.9-1.fc7 

How reproducible:
Always


Steps to Reproduce:
1.click the updates panel widget
2.confirm 'view updates'
3.click 'Apply" on gui
4.or use yum update on console

Actual Results:
full run of standard gui update or yum update, untill transaction test secquence failure

Expected Results:
a normal update 

Additional info:
[('file /usr/share/man/man1/hal-disable-polling.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7', (7, '/usr/share/man/man1/hal-disable-polling.1.gz', 0L)), ('file /usr/share/man/man1/hal-find-by-capability.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7', (7, '/usr/share/man/man1/hal-find-by-capability.1.gz', 0L)), ('file /usr/share/man/man1/hal-find-by-property.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7', (7, '/usr/share/man/man1/hal-find-by-property.1.gz', 0L)), ('file /usr/share/man/man1/hal-get-property.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7', (7, '/usr/share/man/man1/hal-get-property.1.gz', 0L)), ('file /usr/share/man/man1/hal-is-caller-locked-out.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7', (7, '/usr/share/man/man1/hal-is-caller-locked-out.1.gz', 0L)), ('file /usr/share/man/man1/hal-lock.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7', (7, '/usr/share/man/man1/hal-lock.1.gz', 0L)), ('file /usr/share/man/man1/hal-set-property.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7', (7, '/usr/share/man/man1/hal-set-property.1.gz', 0L)), ('file /usr/share/man/man1/lshal.1.gz from install of hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7', (7, '/usr/share/man/man1/lshal.1.gz', 0L))]
Comment 1 Will Woods 2007-04-03 16:59:20 EDT
The problem is that hal used be multilib ('yum list installed hal' will probably
show both i386 and x86_64 packages), but has now been split into hal-libs (which
is multilib) and hal (which isn't - it's not a library). 

Your system is trying to upgrade the (unneeded) i386 hal package, which would be
allowed if it was multilib, but now that it isn't.. it's not OK.

We will probably have a fixed version of hal in a day or two, but if you really
want to update now, you can probably get around this by removing the i386
version of hal.
Comment 2 Will Woods 2007-04-08 19:08:20 EDT

*** This bug has been marked as a duplicate of 235152 ***

Note You need to log in before you can comment on or make changes to this bug.