Bug 235152 - hal multilib conflict
hal multilib conflict
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
:
: 235128 (view as bug list)
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-04-03 22:24 EDT by Skip Palin
Modified: 2014-01-21 17:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 13:59:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yum update errors (1.58 KB, application/octet-stream)
2007-04-03 22:24 EDT, Skip Palin
no flags Details

  None (edit)
Description Skip Palin 2007-04-03 22:24:30 EDT
Description of problem:
Yum udates error

Version-Release number of selected component (if applicable):
3.1.5
How reproducible:
Yum update on login

Steps to Reproduce:
1.Login to X
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Skip Palin 2007-04-03 22:24:30 EDT
Created attachment 151639 [details]
Yum update errors
Comment 2 David Zeuthen 2007-04-03 23:01:14 EDT
I checked in this change

 http://cvs.fedora.redhat.com/viewcvs/devel/hal/hal.spec?r1=1.125&r2=1.126

earlier today but someone needs to a) test it; and b) put it into rawhide; as
Jesse told me told build it with 'make build BREW_FLAGS="--skip-tag"'. Jesse?
Comment 3 Will Woods 2007-04-08 19:08:33 EDT
*** Bug 235128 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Clasen 2007-04-17 14:58:02 EDT
According to David, this is going to be fixed in yum.
Comment 5 David Zeuthen 2007-04-17 15:00:33 EDT
(In reply to comment #4)
> According to David, this is going to be fixed in yum.

That's what Jesse told me. Thoughts?
Comment 6 Jesse Keating 2007-04-17 15:09:07 EDT
Seth was working on a plugin to be able to work around known issues like this,
but I don't think it's done yet and Seth is busy with moving and such.  We may
have to work around it in Anaconda for upgrades, but that won't help people who
just yum upgrade.
Comment 7 Seth Vidal 2007-04-17 15:11:38 EDT
one way or another I'll do it this week. Not much choice, is there?
Comment 8 Seth Vidal 2007-04-26 00:03:31 EDT
okie doke here is the plugin:
http://linux.duke.edu/~skvidal/yum-misc/remove-stuff-plugin.py

here is the file format it will need to grab from the repodata.
http://linux.duke.edu/~skvidal/yum-misc/cleanup.xml

you need to use modifyrepo in createrepo to shove it into the repomd.xml, etc.

after that it's all gravy, I think.

Jesse can you give this a whirl?

Note You need to log in before you can comment on or make changes to this bug.