Bug 23531 - include search path
Summary: include search path
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 23532 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-07 11:56 UTC by Michael Redinger
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-07 18:37:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Redinger 2001-01-07 11:56:49 UTC
When running cpp -v I do get the following output:

(...)
ignoring nonexistent directory "/usr/local/include"
ignoring nonexistent directory "/usr/i386-redhat-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/include
 /usr/include
End of search list.
^C

Hm, I do understand why /usr/local/include is here,
but why /usr/i386-redhat-linux/include? Bug?

Comment 1 Michael Redinger 2001-01-07 11:58:17 UTC
*** Bug 23532 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2001-01-07 18:37:39 UTC
I believe it's just how the compiler works. It tries
to look in $prefix/$host-$vendor-$os/include (probably for cross-compiling
situations or somesuch.)

Comment 3 Jakub Jelinek 2001-01-07 21:47:35 UTC
Yes, that's how compiler worked for years, /usr/arch-vendor-os/include
is there for toolchain includes.


Note You need to log in before you can comment on or make changes to this bug.