Bug 2354 - news.daily fails in cron due to permissions
news.daily fails in cron due to permissions
Status: CLOSED NEXTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: inn (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
: 3570 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-24 13:28 EDT by Jay Freeman
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-31 15:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Freeman 1999-04-24 13:28:52 EDT
Mail keeps being sent to root that sais:

Subject: Cron <root@ironclad>
/usr/bin/news.daily: /var/lib/news/.news.daily: Permission
denied

[root(2)@ironclad news]# rpm --dump -q inn |
grep .news.daily | grep -Ev "man|samples"
/usr/bin/news.daily 12077 922826764
613d0b7b0fa856c9e0cac6a8a2011f99 0100550 news news 0 0 0 X
/var/lib/news/.news.daily 0 922826779
d41d8cd98f00b204e9800998ecf8427e 0100644 root root 0 0 0 X
Comment 1 Jay Freeman 1999-04-24 13:32:59 EDT
Sorry was task switching back and forth and tabbed onto the commit
button by accident and sent it before I was done.  The mail message
was:

Subject: Cron <root@ironclad> run-parts /etc/cron.daily
/usr/bin/news.daily: /var/lib/news/.news.daily: Permission denied

The brick on the bottom shows that the permissions on .news.daily are
root even though it is being used by news.daily which is owned by
news.  The file is used as follows:

##  All done
if ${DAILY} ; then
    date >${PATHDB}/.news.daily
fi
Comment 2 Jeff Johnson 1999-05-31 15:09:59 EDT
Fixed in inn-2.2-10. Thanks for the report.
Comment 3 Jeff Johnson 1999-06-18 11:11:59 EDT
*** Bug 3570 has been marked as a duplicate of this bug. ***

When cron runs cron.daily it runs a shell script
/etc/cron.daily/inn-cron-expire which does an su to news who
then runs /usr/bin/news.daily.  That script tries to write
to the file /var/lib/new/.news.daily, but fails because it
doesn't have permission.  The entire /var/lib/news directory
is owned by news and every file inside of it is owned by
news except .news.daily.  I was thinking that there was
probably a part of the installation code that did a chown
news:news on /var/lib/news/* which wouldn't affect files
that begin with a .

Note You need to log in before you can comment on or make changes to this bug.