Bug 3570 - news doesn't have permissions to file it needs
Summary: news doesn't have permissions to file it needs
Status: CLOSED DUPLICATE of bug 2354
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: crontabs (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-18 13:43 UTC by ajvukich
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 21:58:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ajvukich 1999-06-18 13:43:08 UTC
When cron runs cron.daily it runs a shell script
/etc/cron.daily/inn-cron-expire which does an su to news who
then runs /usr/bin/news.daily.  That script tries to write
to the file /var/lib/new/.news.daily, but fails because it
doesn't have permission.  The entire /var/lib/news directory
is owned by news and every file inside of it is owned by
news except .news.daily.  I was thinking that there was
probably a part of the installation code that did a chown
news:news on /var/lib/news/* which wouldn't affect files
that begin with a .

Comment 1 Jeff Johnson 1999-06-18 15:11:59 UTC
*** This bug has been marked as a duplicate of 2354 ***


Note You need to log in before you can comment on or make changes to this bug.