Bug 235493 - Xvideo croaks X server with Via driver (Unichrome)
Xvideo croaks X server with Via driver (Unichrome)
Status: CLOSED DUPLICATE of bug 241214
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-06 05:16 EDT by Jonathan Kamens
Modified: 2008-01-20 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-20 17:21:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.89 KB, application/octet-stream)
2007-04-06 12:20 EDT, Jonathan Kamens
no flags Details
Xorg.0.log with xorg.conf (46.77 KB, application/octet-stream)
2007-04-06 12:21 EDT, Jonathan Kamens
no flags Details
Xorg.0.log without xorg.conf (54.97 KB, application/octet-stream)
2007-04-06 12:21 EDT, Jonathan Kamens
no flags Details
xorg log (43.85 KB, text/plain)
2007-06-06 06:13 EDT, Miroslav Lichvar
no flags Details

  None (edit)
Description Jonathan Kamens 2007-04-06 05:16:16 EDT
I'm filing this under the Via driver although for all I know it could be generic
to all drivers which support XVideo.

When I try to use XVideo with my Unichrome card and the Via driver, the X server
locks up.

I made the problem go away by disabling XVideo and XVideo-MotionCompensation in
xorg.conf.

This used to work.

I'm using xorg-x11-drv-0.2.2-1.fc7, xorg-x11-server-Xorg-1.2.99.903-.fc7, and
other current packages from Fedora Devel.
Comment 1 Matěj Cepl 2007-04-06 08:22:26 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jonathan Kamens 2007-04-06 12:20:37 EDT
Created attachment 151881 [details]
xorg.conf
Comment 3 Jonathan Kamens 2007-04-06 12:21:15 EDT
Created attachment 151882 [details]
Xorg.0.log with xorg.conf
Comment 4 Jonathan Kamens 2007-04-06 12:21:51 EDT
Created attachment 151883 [details]
Xorg.0.log without xorg.conf
Comment 5 Jonathan Kamens 2007-04-06 12:23:07 EDT
Requested files attached.  Note that the log files don't show Xorg shutting down
because once it gets wedged by playing the AVI file through the XVideo
extension, the only way to unwedge it is kill -9.
Comment 6 Miroslav Lichvar 2007-06-06 06:11:28 EDT
I have a related problem.

mplayer using xv output plays a video fine until I switch to another desktop and
back, xorg crashes with a backtrace in the log. It also crashes when I shade and
unshade the window with video. If mplayer is paused while switching desktops or
unshading the window, it doesn't crash.

It worked fine on FC6. Let me know if more info is needed.
Comment 7 Miroslav Lichvar 2007-06-06 06:13:22 EDT
Created attachment 156333 [details]
xorg log
Comment 8 Miroslav Lichvar 2007-06-21 03:56:52 EDT
With xorg-x11-server-Xorg-1.3.0.0-9 that has fix for bug #241214 I no longer
have the problem.
Comment 9 Adam Jackson 2007-11-28 11:10:41 EST
Mass migration: via -> openchrome.
Comment 10 Xavier Bachelot 2007-11-28 16:51:29 EST
Please retry with xorg-x11-drv-openchrome. This is the successor to
xorg-x11-drv-via.
Comment 11 Xavier Bachelot 2008-01-20 17:21:18 EST
I do think the update to xorg server mentioned in comment #8 fixed this pb. I
close this bug, please re-open if needed. 

*** This bug has been marked as a duplicate of 241214 ***

Note You need to log in before you can comment on or make changes to this bug.