Bug 241214 - Minimizing an Xvideo window crashes Xserver
Summary: Minimizing an Xvideo window crashes Xserver
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords: Patch
: 235493 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-24 13:27 UTC by Jon Nettleton
Modified: 2008-01-20 22:21 UTC (History)
3 users (show)

Fixed In Version: 1.3.0.0-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 13:24:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Nettleton 2007-05-24 13:27:08 UTC
Description of problem:
Any driver that uses xf86XVReputImage will crash the X server if a window with
an XV overlay is minimized.  Currently only the VIA family of drivers use this
function.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0

How reproducible:
Very. Start playing a video in an Xvideo enabled player on a system using the
via xorg driver and then minimize the window.


There is a fix available in xorg git.

http://gitweb.freedesktop.org/?p=xorg/xserver.git;a=commitdiff;h=649e7f82d8d4333443493056b81eb20d6cf022bc

Comment 1 Adam Jackson 2007-06-14 16:15:12 UTC
Added this patch to xorg-x11-server-1.3.0.0-9.fc7, should get pushed to updates
shortly.

Comment 2 Fedora Update System 2007-06-14 21:11:29 UTC
xorg-x11-server-1.3.0.0-9.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 3 Jon Nettleton 2007-06-15 02:27:00 UTC
working great. Thanks.

Comment 4 Fedora Update System 2007-06-16 13:24:49 UTC
xorg-x11-server-1.3.0.0-9.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Xavier Bachelot 2008-01-20 22:21:19 UTC
*** Bug 235493 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.