Bug 23604 - FreeS/Wan
Summary: FreeS/Wan
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
: 51851 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-08 17:59 UTC by chrismcc
Modified: 2007-04-18 16:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-16 17:51:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff to/from kernel-2.4.0-0.43.12.src.rpm (2.76 KB, patch)
2001-01-15 16:00 UTC, chrismcc
no flags Details | Diff
kernel confing patch for srpm configs (482 bytes, patch)
2001-01-15 16:01 UTC, chrismcc
no flags Details | Diff

Description chrismcc 2001-01-08 17:59:52 UTC
Is it possible to get FreeS/Wan support in the rawhide tree?

I was searching around for this and trustix linux (redhat based) has
FreeS/Wan support.  This could be used as a starting point.

I perused the FreeS/Wan list archives and IIRC the 'latest.tar.gz' has been
updated to support kernel v 2.4.0 (release).

Comment 1 chrismcc 2001-01-15 16:00:00 UTC
Created attachment 7614 [details]
diff to/from kernel-2.4.0-0.43.12.src.rpm

Comment 2 chrismcc 2001-01-15 16:01:43 UTC
Created attachment 7615 [details]
kernel confing patch for srpm configs

Comment 3 chrismcc 2001-01-15 16:04:50 UTC
freeswan-snap2001jan14b.tar.gz is latest.tar.gz from www.freeswan.org

The patches and configs are correct.  However it doesn't compile.  I believe
this is due to slight differences between kernels 2.4.0.test11 and 2.4.0 (final)

Waiting for a 2.4.0 final source rpm.


Comment 4 Andreas Thienemann 2001-08-10 18:49:40 UTC
Well, I have to second that motion.

FreeS/Wan as a RedHAT RPM may be a good selling point because installation is a 
PITA!

Comment 5 Arjan van de Ven 2001-08-13 09:09:40 UTC
The reasons for not including FreeSWAN at this moment are twofold
1) The FreeSWAN group refuses patches from people living in the US, and
   several of our key developers would fall under that category
2) The maturity of the FreeSWAN code isn't at the point where we judge it
   usable by a wide audience (read: it contains too many small and bigger bugs,
   which in combination with 1) are a problem)

Comment 6 R P Herrold 2002-02-11 02:28:31 UTC
On Feb  5, frees/wan issued its ver 1.95, with fixes, and a .specfile to build
and apply cleanly on RH 7.2.  Perhaps it might be revisited.

Comment 7 Chris Ricker 2002-03-16 17:49:42 UTC
*** Bug 51851 has been marked as a duplicate of this bug. ***

Comment 8 Michael K. Johnson 2002-03-27 23:05:05 UTC
I haven't heard that FreeS/WAN is accepting patches from the US yet.


Note You need to log in before you can comment on or make changes to this bug.