Bug 51851 - IPSEC in kernel via FreeS/WAN
Summary: IPSEC in kernel via FreeS/WAN
Status: CLOSED DUPLICATE of bug 23604
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: roswell
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL: http://www.freeswan.org/
Whiteboard:
Keywords: FutureFeature
: 57462 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-15 20:39 UTC by Christopher McCrory
Modified: 2007-04-18 16:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 08:26:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher McCrory 2001-08-15 20:39:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:

encription is always good

FreeS/WAN provides IPSEC connections to other IPSEC devices
i.e. Cisco PIX, FW/1, xBSD

Additional info:

http://www.freeswan.org/doc.html
http://www.freeswan.org/freeswan_trees/freeswan-1.91/CHANGES

Comment 1 Matt Gunter 2001-10-16 16:13:10 UTC
This would allow my company to save lots of time recompiling kernels.  I realize
that this will not happen in 7.2 because it is coming out next week, but please
consider it for a future version or at the very least release it in the powertools.

Comment 2 Dax Kelson 2001-10-27 07:55:41 UTC
I would also like FreeSWAN added to Red Hat.

I'm implemented CIPE and IPsec with FreeSWAN and I was shocked at the difference
in latency.  While the IPsec spec is a big nasty 200+ pager, the protocol quick,
lean and mean.

In my test, no VPN: 59ms latency, IPsec: 65ms latency, CIPE: 85ms latency

I could "feel" the difference in my remote interactive shell sessions.

IPsec includes compression too, I took all the fortune files (2.5MB of text) and
xfered them.  No VPN: 98KB/sec, IPSec: 155KB/sec.

Finally, if you are going to create a "VPN concentrator", FreeSWAN supports
hardware crypto accelerators.

Comment 3 Need Real Name 2002-02-08 14:05:46 UTC
And it looks like somebody already did most of the work ...

http://www.platypus.bc.ca/~bishop/software/freeswan/

I like the clean way in which he did it, if you do a (xx)diff of 
the spec files you'll see that he only added some lines and as a result 
an extra kernel-freeswan-2.4.9-13.i386.rpm is built. It had absolutely no
effect on the other kernels being built as far as I could tell.

So only people to gain from this .. except maybe the extra burden for 
RedHat of supporting it ;)

Side note: #57462 can be marked as a duplicate of this.

Comment 4 Mike A. Harris 2002-02-11 08:26:25 UTC
*** Bug 57462 has been marked as a duplicate of this bug. ***

Comment 5 Chris Ricker 2002-03-16 17:49:47 UTC

*** This bug has been marked as a duplicate of 23604 ***


Note You need to log in before you can comment on or make changes to this bug.