Bug 236073 - autoconf 2.61 requires m4 >= 1.4.7
autoconf 2.61 requires m4 >= 1.4.7
Product: Fedora
Classification: Fedora
Component: autoconf (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Karsten Hopp
Brian Brock
: EasyFix
Depends On:
  Show dependency treegraph
Reported: 2007-04-11 15:54 EDT by Ville Skyttä
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-29 13:39:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-04-11 15:54:26 EDT
I needed autoconf 2.61 on FC-6 for something, and updated it from Rawhide
locally.  However, that resulted in a broken setup without rpm notifying me
about it, as autoconf 2.61 appears to require m4 version 1.4.7 or later due to
its use of "m4 --debugfile".

So the dependency on m4 in autoconf should be made versioned like "Requires: m4
>= 1.4.7".  Don't know whether the BuildRequires on m4 should be versioned or not.

See also bug 230601 and http://www.gnu.org/software/autoconf/#TOCintroduction
Comment 1 Ville Skyttä 2007-04-11 15:55:20 EDT
Oops, how did that severity end up as "urgent"?  Fixed.
Comment 2 Stepan Kasal 2007-10-29 13:39:19 EDT
Resolved in autoconf-2.61-10.fc9.

Note You need to log in before you can comment on or make changes to this bug.