Bug 23612 - PGP support in RPM documentation
Summary: PGP support in RPM documentation
Status: CLOSED DUPLICATE of bug 21289
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-08 20:05 UTC by Piet E Barber
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-08 20:06:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Piet E Barber 2001-01-08 20:05:37 UTC
The RPM manpage says that PGP is currently the only one supported. 

"In order to use the signature feature RPM must be configured to run PGP
[or GPG], and it must be able to find a public key ring with RPM public
keys in it. 

_pgp_path is llisted
but through my testing, _gpg_path also works. 

_signature states that "The Signature type.  Right now only pgp is
supported."
My testing indicated that gpg in that field works fine. 

_pgp_name the name of the "User" whose key you wish to sign your packages. 
Through my testing, i discovered that the 'pgp_name' had to exactly match
the name of the UserID in my gpg public key.  You might want to mention
this.

Comment 1 Jeff Johnson 2001-01-09 14:51:29 UTC

*** This bug has been marked as a duplicate of 21289 ***


Note You need to log in before you can comment on or make changes to this bug.