Bug 23663 - Anaconda fails at video set-up
Anaconda fails at video set-up
Status: CLOSED DUPLICATE of bug 21904
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0J
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-09 13:24 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 12:00:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-09 13:24:25 EST
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1664, in 
doInstall
    self.x.write (self.instPath + "/etc/X11")
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 
895, in write
    config4 = self.Version4Config ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 
1173, in Version4Config
    info["enableVariant"] = ""
NameError: info

Local variables in innermost frame:
data: {'screenModes': '\012\011Subsection "Display"\012        
\011Depth       16\012                
Modes       "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x48
0" \012\011EndSubsection\012\012\011Subsection "Display"\012        
\011Depth       24\012                
Modes       "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x48
0" \012\011EndSubsection\012\012\011Subsection "Display"\012        
\011Depth       8\012                
Modes       "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x48
0" \012\011EndSubsection\012', 'videoRam': '', 'pex5Mod': '\012
\011Load "pex5"', 'XkbModel': 'pc101', 'monitorVert': '48 - 
120', 'mouseDevice': 'psaux', 'cardVendor': 'Intel 
810', 'cardsOptions': '\011# no known 
options', 'XkbRules': 'xfree86', 'cardBoardName': 'Intel 
810', 'ia64Mods': '', 'XkbLayout': 'us', 'nonSparcMods': '\012
\011Load "fbdevhw"', 'defaultDepth': '', 'XkbOptions': '', 'cardID': 'Intel
 810', 'emulate3': 'yes', 'enableOptions': '#', 'monitorHoriz': '30 - 
85', 'enableVariant': '#', 'XkbVariant': 'nodeadkeys', 'mouseProto': 'PS/2'
, 'files': '\012# The location of the RGB database.  Note, this is the 
name of the\012# file minus the extension (like ".txt" or ".db").  There 
is normally\012# no need to change the default.\012\012    
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are 
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and 
later now use a font server independent of\012# the X server to render 
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012    
FontPath   "unix/:7100"\012'}
self: <xf86config.XF86Config instance at 829c498>
maxdepth: 24
res: 640x480
test: 0
mouseProto: PS/2
emulate3: yes
modes: 
['1600x1200', '1280x1024', '1152x864', '1024x768', '800x600', '640x480']
depth: 8
screens: 
	Subsection "Display"
        	Depth       16
                
Modes       "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x48
0" 
	EndSubsection

	Subsection "Display"
        	Depth       24
                
Modes       "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x48
0" 
	EndSubsection

	Subsection "Display"
        	Depth       8
                
Modes       "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x48
0" 
	EndSubsection


ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2001-01-09 17:47:22 EST

*** This bug has been marked as a duplicate of 21904 ***
Comment 2 Need Real Name 2001-01-10 14:27:01 EST
I have resolved the previous problem. I had erroneously chosen the wrong 
display adapter for the PC. However, now I get the following error message at 
the very end of the install. I have checked the partition sizes and display 
settings. Everything appears normal. On reboot, none of the previously defined 
partitions were set up even though it had just finished copying all of the 
program to them. What happened to the partitions?

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1664, in 
doInstall
    self.x.write (self.instPath + "/etc/X11")
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 895, in 
write
    config4 = self.Version4Config ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 1173, in 
Version4Config
    info["enableVariant"] = ""
NameError: info

Local variables in innermost frame:
data: {'screenModes': '\012\011Subsection "Display"\012        \011Depth       
16\012                Modes       "1024x768" \012
\011EndSubsection\012', 'videoRam': '', 'pex5Mod': '\012
\011Load "pex5"', 'XkbModel': 'dell101', 'monitorVert': '48 - 
120', 'mouseDevice': 'psaux', 'cardVendor': 'ATI 
Mach64', 'cardsOptions': '\011# no known 
options', 'XkbRules': 'xfree86', 'cardBoardName': 'ATI 
Mach64', 'ia64Mods': '', 'XkbLayout': 'us', 'nonSparcMods': '\012
\011Load "fbdevhw"', 'defaultDepth': '', 'XkbOptions': '', 'cardID': 'ATI 
Mach64', 'emulate3': 'yes', 'enableOptions': '#', 'monitorHoriz': '30 - 
85', 'enableVariant': '#', 'XkbVariant': 'nodeadkeys', 'mouseProto': 'PS/2', 'fi
les': '\012# The location of the RGB database.  Note, this is the name of 
the\012# file minus the extension (like ".txt" or ".db").  There is 
normally\012# no need to change the default.\012\012    
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are 
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and later 
now use a font server independent of\012# the X server to render fonts.\012
\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012    
FontPath   "unix/:7100"\012'}
self: <xf86config.XF86Config instance at 829c498>
maxdepth: 16
res: 1024x768
test: 0
mouseProto: PS/2
emulate3: yes
modes: ['1024x768']
depth: 32
screens: 
	Subsection "Display"
        	Depth       16
                Modes       "1024x768" 
	EndSubsection


Comment 3 Michael Fulbright 2001-01-10 16:43:15 EST

*** This bug has been marked as a duplicate of 21904 ***
Comment 4 Need Real Name 2001-01-10 18:54:12 EST
Could you give me more help than the reference to the bug report #21904? I am 
not allowed to access this report by the system. I get a "permission denied" 
error.

Thanks.
Comment 5 Michael Fulbright 2001-01-11 12:00:32 EST
I made the bug publicly viewable.

*** This bug has been marked as a duplicate of 21904 ***
Comment 6 Need Real Name 2001-01-12 11:40:41 EST
This still doesn't help me any. I am using the latest downloadable iso images. 
What else do I need to make this work?

Note You need to log in before you can comment on or make changes to this bug.