Bug 21904 - GUI CDROM Custom w/X: traceback
GUI CDROM Custom w/X: traceback
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 21567 22943 23427 23663 23968 23980 24013 24515 24671 24694 24800 24912 25370 25393 25434 25843 31353 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-07 15:01 EST by Brock Organ
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-18 19:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brock Organ 2000-12-07 15:01:46 EST
Testing using the qa1206.1 (w/updates disk!) tree (after choosing the wrong
video adapter, RivaTNT instead of ATI Mach 64):

 GUI CDROM Custom w/X
 ----------
 KEYBOARD CONFIGURATION 
        *  Dead keys :  Select Disable Dead keys  (/etc/sysconfig/keyboard)
        *  Model :  Select Default Model  (/etc/sysconfig/keyboard KEYTABLE
value)
 WELCOME TO RED HAT LINUX 
        *  Screen Invariants :  Toggle help button  (can toggle on/off)
 INSTALL OPTIONS 
        *  Install/Upgrade :  Choose Custom Install  
 ACCOUNT CONFIGURATION 
        *  root acct create :  Enter Root password  (message "root password
accepted")
 AUTHENTICATION CONFIGURATION 
        *  Enable LDAP :  Default LDAP  (/etc/nsswitch.conf no ldap
entries; ldap packages not installed)
 X CONFIGURATION - VIDEO ADAPTER 
        *  Adapter :  Choose Adapter  (post-install: verify device in
XF86Config{-4})
        *  Test :  Choose Test Configuration  
 ABOUT TO INSTALL 
        *  message :  Verify About to Install Message  
 BOOTDISK 
        *  floppy :  Skip creation
Comment 1 Brock Organ 2000-12-07 15:03:00 EST
Here is the traceback:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in
run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1685, in
doInstall
    self.x.write (self.instPath + "/etc/X11")
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/xf86config.py", line 938, in
write
    config4 = self.Version4Config ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/xf86config.py", line 1220, in
Version4Config
    info["enableVariant"] = ""
NameError: info

Local variables in innermost frame:
data: {'screenModes': '\012\011Subsection "Display"\012        \011Depth      
16\012                Modes       "1024x768" \012\011EndSubsection\012',
'videoRam': '', 'pex5Mod': '\012\011Load "pex5"', 'XkbModel': 'pc105',
'monitorVert': '48 - 120', 'mouseDevice': 'psaux', 'cardVendor': 'RIVA TNT',
'cardsOptions': '\011# no known options', 'XkbRules': 'xfree86',
'cardBoardName': 'RIVA TNT', 'ia64Mods': '', 'XkbLayout': 'us', 'nonSparcMods':
'\012\011Load "fbdevhw"', 'defaultDepth': '', 'XkbOptions': '', 'cardID': 'RIVA
TNT', 'emulate3': 'no', 'enableOptions': '#', 'monitorHoriz': '30 - 107',
'enableVariant': '#', 'XkbVariant': 'nodeadkeys', 'mouseProto': 'PS/2', 'files':
'\012# The location of the RGB database.  Note, this is the name of the\012#
file minus the extension (like ".txt" or ".db").  There is normally\012# no need
to change the default.\012\012    RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012#
Multiple FontPath entries are allowed (they are concatenated together)\012# By
default, Red Hat 6.0 and later now use a font server independent of\012# the X
server to render fonts.\012\012    FontPath  
"/usr/X11R6/lib/X11/fonts/TrueType"\012    FontPath   "unix/:7100"\012'}
self: <xf86config.XF86Config instance at 822c268>
maxdepth: 16
res: 1024x768
test: 0
mouseProto: PS/2
emulate3: no
modes: ['1024x768']
depth: 16
screens: 
        Subsection "Display"
                Depth       16
                Modes       "1024x768" 
        EndSubsection


Comment 2 Michael Fulbright 2000-12-12 11:50:48 EST
Bug 22069 is a dupe of this.
Comment 3 Brent Fox 2000-12-18 19:16:54 EST
'info' should be 'data' instead.  This bug is my fault.  Fixed in cvs now.
Comment 4 Brock Organ 2001-01-08 10:20:23 EST
verified fixed in qa0108.0 test tree ...
Comment 5 Michael Fulbright 2001-01-09 16:39:40 EST
*** Bug 23427 has been marked as a duplicate of this bug. ***
Comment 6 Michael Fulbright 2001-01-09 17:47:17 EST
*** Bug 23663 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2001-01-09 18:04:14 EST
*** Bug 22943 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2001-01-10 16:42:59 EST
*** Bug 23663 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2001-01-11 12:00:29 EST
*** Bug 23663 has been marked as a duplicate of this bug. ***
Comment 10 Michael Fulbright 2001-01-15 19:32:17 EST
*** Bug 24013 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2001-01-15 19:35:43 EST
*** Bug 23980 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2001-01-15 19:39:59 EST
*** Bug 23968 has been marked as a duplicate of this bug. ***
Comment 13 Michael Fulbright 2001-01-24 10:30:08 EST
*** Bug 21567 has been marked as a duplicate of this bug. ***
Comment 14 Michael Fulbright 2001-01-24 10:33:29 EST
*** Bug 24671 has been marked as a duplicate of this bug. ***
Comment 15 Michael Fulbright 2001-01-24 15:36:26 EST
*** Bug 24694 has been marked as a duplicate of this bug. ***
Comment 16 Michael Fulbright 2001-01-24 16:37:33 EST
*** Bug 24515 has been marked as a duplicate of this bug. ***
Comment 17 Michael Fulbright 2001-01-25 17:36:43 EST
*** Bug 24912 has been marked as a duplicate of this bug. ***
Comment 18 Michael Fulbright 2001-01-26 12:35:05 EST
*** Bug 24800 has been marked as a duplicate of this bug. ***
Comment 19 Michael Fulbright 2001-01-31 13:28:56 EST
*** Bug 25393 has been marked as a duplicate of this bug. ***
Comment 20 Michael Fulbright 2001-02-01 11:41:34 EST
*** Bug 25434 has been marked as a duplicate of this bug. ***
Comment 21 Michael Fulbright 2001-02-01 11:43:29 EST
*** Bug 25370 has been marked as a duplicate of this bug. ***
Comment 22 Michael Fulbright 2001-02-06 13:53:43 EST
*** Bug 25843 has been marked as a duplicate of this bug. ***
Comment 23 Michael Fulbright 2001-03-12 11:38:12 EST
*** Bug 31353 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.